X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How to enable search from location bar by ONE word.

Posted

Search from location bar (CTR+L) works fine if I type several words (for example, "bla bla"). But if I type just one (for example, "bla" or "bla-bla") word then the search doesn't work.

I want to resolve it without any additional extensions.

Several hours of googling didn't get me a positive result. Please help me.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.01
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • 3.0.40818.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Madasan
  • Administrator
  • Moderator
6 solutions 65 answers

Hi moddom,

I'm sorry to hear you have this problem. What happens when you're trying to search for one word only? Are you getting any results or any error messages? How is it different from when you're trying to search two words?

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

See also:


Try to reset some preferences to the default with the SearchReset extension:

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

Question owner

If try to search by one world i have the message which is in the attachment.

If i try to search by two words, i have the page https://www.google.by/search?ie=utf-8&oe=utf-8&q=bal+bla

Also, i think it can happen because of my proxy doesn't give me error 404 if site isn't exist. And get me 503 instead of 404.

Question owner

Also, i've found additional information, which can be useful:

The problem appears only at this machine (windows 7 + firefox 18.0.1).

I have expected result with another machine (Ubuntu+ firefox [latest release version]). It means, search from location bar by one word is performed successfully.

I use Firefox Sync and i synchronize settings.

So it is one more case which is confirms that problem happens because of proxy.

Can I bypass this?

Dimpl 0 solutions 3 answers

I also get this error, but only at school, when I am connected through a proxy server. Attempting to search 'test' will connect me to' http://test' with 'ERROR: The requested URL could not be retrieved.'

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Yes, searching via the location bar when you use a proxy doesn't work very well.
If you use a proxy then best is to use a one letter keyword search, either via a bookmark or via manage search engine (drop down marker on the search bar).

muzzl 0 solutions 2 answers

When you type a single word in to the address bar Firefox will do a DNS lookup on that word to see if it is a valid domain. I don't know if you can change that behavior. I don't know if it is the right behavior since a word with no dots in it shouldn't be a valid domain, but I understand there has been some talk about it being allowed in the future so maybe it is the right behavior.

What's certainly wrong is the way a good number of DNS servers deal with domains that they don't recognize. Do they tell your machine it's an invalid DNS? No, they tell your machine that you're trying to look up their advertisement page. It's not just sketchy ISPs that do it, I see this behavior on OpenDNS too. How is Firefox supposed to know that you wanted to do a search when it is being told that the thing you put in the address bar actually is a valid URL?

If you have any control over your machine or your router I'd recommend finding a DNS server you can use that will return honest results. I've had success with the google public DNS servers, and I am sure there are others. When Firefox is told the truth about your single word not being a valid DNS then it will do a search on it.

Don't forget to clear your cache after you change the setting.

Blue Rasberry 0 solutions 2 answers

This question is being asked by many people in many places. These threads give conflicting answers but the right answer is in some of these threads.

https://support.mozilla.org/en-US/questions/941751 https://support.mozilla.org/en-US/questions/956921 https://support.mozilla.org/en-US/questions/955082 https://support.mozilla.org/en-US/questions/948972 https://support.mozilla.org/en-US/questions/963366 https://support.mozilla.org/en-US/questions/943162

The goal is to perform search in the URL. When multiple words are queried in the url, search works and for example, if Google is the default search engine the Firefox will take a user to the Google search results page for those multiple words. However, if only a single word is entered, then the default search engine is not queried and instead the user is taken to a malicious spam page set up by their ISP.

The situation is that Firefox tries to fix single words into www.word.com format and when that fails, instead of the ISP telling the user that the page does not exist they send them to their spam site.

How does one perform one-word searches in the Firefox URL? One solution would be to quit using an ISP's spammy DNS results and use some other results. Google, for example, offers this -

https://developers.google.com/speed/public-dns/

Doing this worked for me!

Some things which do not work -

  • Resetting Firefox
  • (1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful; (2) In the filter box, type or paste "fixup"; (3) Double-click browser.fixup.alternate.enabled to flip it to false.
  • changing the default search engine