X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

keyword.URL stopped not working for single words, goes to 'website-unavailable.com' instead

Posted

I have keyword.URL set to http://www.google.com/search?btnG=Google+Search&q= . This works fine if I enter more than one word in the address bar, like "Hello Goodbye." If I enter a SINGLE (non-url) word, however, I get sent to a website called website-unavailable.com, which I do not want. Why is keyword.URL not working correctly? Using Firefox 17 for linux.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202
  • Google Talk Plugin Video Accelerator version:0.1.44.23
  • Version: 3.10.2.0
  • Mime Type x-skype for Skype Buttons
  • The Totem 2.30.2 plugin handles video and audio streams.
  • DivX Web Player version 1.4.0.233

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:17.0) Gecko/17.0 Firefox/17.0

More Information

jscher2000
  • Top 10 Contributor
2377 solutions 21043 answers

Helpful Reply

Yes, when there is one word, Firefox will try it with www. at the beginning and .com at the end (depending on your location). If there is no such domain, you get the error from your DNS provider.

To prevent that, turn off the "fixup" feature here:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste fixup and pause while the list is filtered

(3) Double-click browser.fixup.alternate.enabled to flip it to false. That should take effect immediately with your next search, and you can close this tab.


In this thread, the user had to switch it to true, then back to false to reset it: Won't google search when one word is written in address bar.

Modified by jscher2000

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96973 answers

Helpful Reply

You may have an ISP that automatically redirects you to a search page if a DNS look up fails.
That takes the control from Firefox to do the normal keyword search like a Google I'm Lucky search.
In such cases you need to contact your ISP and ask for a DNS server to opt-out of that feature.
You can also check if there is a link on the search results page to go to your ISP and opt-out.