X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox will not search * I put a word in the search bar click enter and the word just sits there nothing changes

Posted

when i type anything in the Firefox search bar nothing happens 8 could be a phone number

,,, the  word Fire Fox  ,,the  search  never happens ..the  word ( or number )  just sits there in the search area ( bar) of  fir fox

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.64 Safari/537.31

More Information

ideato
  • Top 25 Contributor
617 solutions 4263 answers

Hello zappa,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

Different things happen when you enter one word vs. two words on the address bar.

  • With one word, Firefox may try to see whether it works as a domain name. For example, type pepsi and press Enter, and Firefox will check for www.pepsi.com. Of course, add-ons can change this behavior.
  • When there are two or more words, Firefox will immediately run a search using the provider listed in one of your preferences (keyword.URL which you can view if you type or paste about:config in the address bar and press Enter). Of course, add-ons can change this behavior.

Do you notice any difference between one word and two word searches?

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

This can also happen if you have a profile located on the network drive.

Is this only with searching via the search bar?

Try to use the SearchReset extension to reset some preferences to the default values.

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

Modified by cor-el

murenti 1 solutions 9 answers

Hi I am also having this issue with one word search's only. I don't really want to find an addon to fix this as I like to keep my browser as lite as possible to reduce extension issues. Is there a manual fix to tell Firefox that a single word in the URL bar should be treated as is and not with http://

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Use a keyword search and add a one letter keyword to the Google or other search engine via Manage Search Engines in the drop down list of the search bar icon.

murenti 1 solutions 9 answers

cor-el - Thanks for your reply but that does not solve my issue.

My issue relates to a single word search from the URL address bar. Currently Firefox is trying to add http:// to the beginning of the word that is added and this is causing an issue when returning a result.

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

Helpful Reply

Hi murenti, cor-el is suggesting a workaround. For example, to query Google for the word browser, you would assign g to Google one time, then instead of just typing browser, you would write:

g browser

That is indeed an extra two characters you would need to type, but if you do not get a solution for forcing single word addresses to be sent to the keyword service, you could try it.

Or just use the search box, which never thinks you might be entering an address.

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

You can also try to set the browser.urlbar.autoFill pref to false to disable auto-fill in the location bar in case that is interfering.

See "Prevent Firefox from automatically completing URLs":

murenti 1 solutions 9 answers

Thank you cor-el and jscher2000 I have impleted the keyword search and now understand what you mean, sorry. Its much better than before but I wish there was a Firefox fix for this.

Thank you both for your patience and help

muzzl 0 solutions 2 answers

When you type a single word in to the address bar Firefox will do a DNS lookup on that word to see if it is a valid domain. I don't know if you can change that behavior. I don't know if it is the right behavior since a word with no dots in it shouldn't be a valid domain, but I understand there has been some talk about it being allowed in the future so maybe it is the right behavior.

What's certainly wrong is the way a good number of DNS servers deal with domains that they don't recognize. Do they tell your machine it's an invalid DNS? No, they tell your machine that you're trying to look up their advertisement page. It's not just sketchy ISPs that do it, I see this behavior on OpenDNS too. How is Firefox supposed to know that you wanted to do a search when it is being told that the thing you put in the address bar actually is a valid URL?

If you have any control over your machine or your router I'd recommend finding a DNS server you can use that will return honest results. I've had success with the google public DNS servers, and I am sure there are others. When Firefox is told the truth about your single word not being a valid DNS then it will do a search on it.

Don't forget to clear your cache after you change the setting.

murenti 1 solutions 9 answers

Hi muzzl, I havn't been using Opendns for a while due to an extremely poor customer service experience I had from them. I have used Google Public DNS in my router and a word search returns a result as expected.

Many thanks

Blue Rasberry 0 solutions 2 answers

This question is being asked by many people in many places. These threads give conflicting answers but the right answer is in some of these threads.

https://support.mozilla.org/en-US/questions/941751 https://support.mozilla.org/en-US/questions/956921 https://support.mozilla.org/en-US/questions/955082 https://support.mozilla.org/en-US/questions/948972 https://support.mozilla.org/en-US/questions/963366 https://support.mozilla.org/en-US/questions/943162

The goal is to perform search in the URL. When multiple words are queried in the url, search works and for example, if Google is the default search engine the Firefox will take a user to the Google search results page for those multiple words. However, if only a single word is entered, then the default search engine is not queried and instead the user is taken to a malicious spam page set up by their ISP.

The situation is that Firefox tries to fix single words into www.word.com format and when that fails, instead of the ISP telling the user that the page does not exist they send them to their spam site.

How does one perform one-word searches in the Firefox URL? One solution would be to quit using an ISP's spammy DNS results and use some other results. Google, for example, offers this -

https://developers.google.com/speed/public-dns/

Doing this worked for me!

Some things which do not work -

  • Resetting Firefox
  • (1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful; (2) In the filter box, type or paste "fixup"; (3) Double-click browser.fixup.alternate.enabled to flip it to false.
  • changing the default search engine