X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Address bar search with single word does not work

Posted

When I perform a single word search in the firefox address bar, such as 'asdf', 'google' 'test', i get rediredted to sitecrafting.com At first a web logo for sitecrafting shows up but my single word search is still in the address bar. Then after a second or two the sitecrafting.com address appears in the address bar and the screen refreshes to the sitecrafting.com website.

However, if i do a multiple word serch in the address bar, then i get a google search as expected. For instance 'asdf asdf' give me a google search results page for that two worded phrase.

I have done the keyword.url reset. I have uninstalled firefox and removed all profile/preference and then reinstalled. I have tested in safe mode with all addons disabled. None of these have fixed the problem.

Please oh please help me!!!!

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • npsitesafety
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version 4.0.3.13724
  • VLC media player Web Plugin 2.0.6
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.7
  • Picasa plugin
  • GEPlugin
  • 5.1.20125.0
  • Garmin Communicator Plug-In 4.0.4.0
  • Amazon MP3 Downloader Plugin 1.0.17
  • CANON iMAGE GATEWAY Album Plugin Utility Module for IJ
  • Windows Activation Technologies Plugin for Mozilla

Application

  • Firefox 22.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:22.0) Gecko/20100101 Firefox/22.0
  • Support URL: http://support.mozilla.org/1/firefox/22.0/WINNT/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • AVG SafeGuard toolbar 15.3.0.11 (avg@toolbar) (Inactive)
  • Symantec Intrusion Prevention 11.3.0.9 - 5 ({BBDA0591-3099-440a-AA10-41764D9DB4DB}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Mobile Intel(R) 4 Series Express Chipset Family
  • adapterDescription2:
  • adapterDeviceID: 0x2a42
  • adapterDeviceID2:
  • adapterDrivers: igdumdx32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 3600 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 300
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'8.1500.1000.2202']
  • directWriteEnabled: False
  • directWriteVersion: 6.1.7600.16972
  • driverDate: 8-13-2009
  • driverDate2:
  • driverVersion: 8.15.10.1872
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Mobile Intel(R) 4 Series Express Chipset Family)
  • windowLayerManagerType: Direct3D 9

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130618035212
  • browser.startup.homepage_override.mstone: 22.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 22.0
  • keyword.URL: http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&q=
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 50090
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.cpd.offlineApps: True
  • privacy.cpd.siteSettings: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0

Misc

  • User JS: No
  • Accessibility: No
Amit Kumar Thakur 83 solutions 863 answers

Hello,

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

Thank you.

Waka_Flocka_Flame
  • Top 25 Contributor
528 solutions 5041 answers

Try the search reset addon.

https://addons.mozilla.org/en-us/firefox/addon/searchreset/

jscher2000
  • Top 10 Contributor
2348 solutions 20818 answers

Helpful Reply

If you enter a single word in the address bar, Firefox will try it has a URL (e.g., if you enter asdf, it will try http://asdf/). Your ISP either can honestly report that there is no such domain, in which case it would be referred to Google search, or could return its own search page instead. One of these is more lucrative than the other. :-)

I'm not sure anyone has found a way to force Firefox to send a single word (i.e., a submission with no spaces) to the keyword search service. And many times you will want a "single word" such as google.com to be tried as a domain instead of searched. Maybe there's an add-on that can tell the difference?

Question owner

Thank you all for your replys!

I have tried the reset button in Help->Troubleshooting. Does not fix the problem.

I have also installed the Reset plugin without any luck.

I guess I am leaning towards my ISP not responding with the correct domain info. If i do a single word search that begins with a special character such as ';2345', '[sfgn', etc the search works okay. but without a special character first, same issue.

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

you could try changing to a different dns server on your system, like the one offered by google: https://developers.google.com/speed/public-dns/

Question owner

Philipp,

After changing my IPv4 DNS to the google DNS (8.8.8.8 and 8.8.4.4), and verifying with ipconfig, I am still have the save problem. I tried ctrl-shift-del to clear everything, resetting, and safe mode, but still no working search for single word.

Thanks!

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

does anything related to sitecrafting[dot]com show up when you run a scan with the hijackthis tool from http://sourceforge.net/projects/hjt/?

Question owner

No, not that I see. Would you like to see the log? I didn't see a way to upload it.

Thanks!

finitarry 157 solutions 2175 answers

Sounds as if you have some malware hijacking your searches. Try these:

If these don't find it or can't clear it, post in one of these forums for specialized malware removal help:

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

no, if there's nothing obvious pointing to that page, then i probably wouldn't get anything out of it either - is the same issue also occurring with other browsers on the same machine?

DOG425 0 solutions 15 answers

Helpful Reply

Sorry for waking this old thing but if someone finds this thread and have the same problem (like I just did) then this solved it for me:

  1. open about:config and click past warning
  2. find key network.dns.ignoreHostonly and set to true

Good luck!

Costa 0 solutions 8 answers

So, the problem seems to be DNS hijacking. Your ISP (Time Warner or Verizon or another) has decided to 'help' you resolve your incorrectly entered website address (your single-word search). By help, I mean redirect you to a page where they can serve you ads.

I've solved this before for verizon by logging into my browser and disabling a setting, I can't recall which one, but I can't seem to fix it for Time Warner. Any help would rock!

Waka_Flocka_Flame
  • Top 25 Contributor
528 solutions 5041 answers

You would need to contact your ISP by phone I think to disable the DNS/BS hijacking.

Costa 0 solutions 8 answers

Already tried. They don't know what I'm talking about, haha.

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

...or just configure your OS to use a different dns-server, like google's one mentioned above.

Costa 0 solutions 8 answers

I fixed it by switching to Google's Public DNS servers (https://developers.google.com/speed/public-dns/docs/using) and then restarting my computer. This only fixes it for my laptop though, and I'm not entirely sure what else changed as a result.

Costa 0 solutions 8 answers

Hey Philipp, can you break down what that means for me? Doesn't my machine have to go through the router / modem to get to Google? I'm not sure I know enough to know how exactly this solves the issue, and what new problems it might create.

Modified by Costa

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

DNS is there to resolve a human readable hostname like google.com into an IP like 173.194.112.32. by changing your system's dns server you're outsourcing this resolving part (like a phone-book for IP addresses) on your laptop from the one provided by your isp to google's dns server. you might also be able to set that directly on your router, but this may depend by model.

for more details on the issue please also refer to the documentation on google's page...

Costa 0 solutions 8 answers

Thanks, Philipp!

jscher2000
  • Top 10 Contributor
2348 solutions 20818 answers

Hi dog425, that preference might only work if you have one of the family of Tab Utilities extensions installed. Do you have one of those?