X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Won't google search when one word is written in address bar.

Posted

Previously when I typed one word or more in the address bar, it would do a google search. Now when I enter one word and press enter it takes me to a while page with the following message on it:

502 Bad Gateway nginx/1.3.7

It does the google search when I type more than one word.

Chosen solution

Yes, when there is one word, Firefox will try it with www. at the beginning and .com at the end (depending on your location). To prevent that, turn off the "fixup" feature here:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste fixup and pause while the list is filtered

(3) Double-click browser.fixup.alternate.enabled to flip it to false. That should take effect immediately with your next search, and you can close this tab.

Read this answer in context 5

Additional System Details

Installed Plug-ins

  • npsitesafety
  • Shockwave Flash 11.4 r402
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.7.637
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.6.636
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • 5.1.10411.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

jscher2000
  • Top 10 Contributor
2365 solutions 20925 answers

Chosen Solution

Yes, when there is one word, Firefox will try it with www. at the beginning and .com at the end (depending on your location). To prevent that, turn off the "fixup" feature here:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste fixup and pause while the list is filtered

(3) Double-click browser.fixup.alternate.enabled to flip it to false. That should take effect immediately with your next search, and you can close this tab.

Question owner

Thanks. It was already at false, but I switched it to true and then false again, and now it google searches when I type anything that is not an address.

zuesuep 0 solutions 2 answers

I have the same problem, I tried jscher2000 and BabarSuhail's methods but still did not work. :(

jscher2000
  • Top 10 Contributor
2365 solutions 20925 answers

Hi zuesuep, can you confirm that two-word searches work correctly? If you get the same error for both, reset the value of keyword.URL as described in this article: https://support.mozilla.org/en-US/kb/search-web-address-bar#w_changing-the-internet-keyword-service

To summarize:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste keyword and pause while the list is filtered

(3) Right-click keyword.URL and choose Reset. Then test again in the other tab.

Any luck?

zuesuep 0 solutions 2 answers

hi jscher2000, It's just the one-word search giving a 502 error, the multi-word search works just fine.