X
Tap here to go to the mobile version of the site.

Support Forum

I play Mafia Wars and I get the following message going to Mafia Wars from Facebook: "You need Javascript enabled in your browser to use Facebook Applications."

Posted

I have Javascript enabled but it continually gives me this message. I followed the Safe Mode instructions and brought up FB and tried clicking on the Mafia Wars game link and still get the same message "You need Javascript enabled in your browser to use Facebook Applications." When I am on my home page of FB.com and someone posts a link to mafiawars.com, when I click on that link, it doesn't take me to that page, but gives me that message. It doesn't do it when I use Google Chrome.

I have Javascript enabled but it continually gives me this message. I followed the Safe Mode instructions and brought up FB and tried clicking on the Mafia Wars game link and still get the same message "You need Javascript enabled in your browser to use Facebook Applications." When I am on my home page of FB.com and someone posts a link to mafiawars.com, when I click on that link, it doesn't take me to that page, but gives me that message. It doesn't do it when I use Google Chrome.

Additional System Details

Sites Affected

http://apps.facebook.com/inthemafia/track.php?next_controller=index&next_action=fan_blast&next_params=%7B%22id%22%3A%22695%22%7D&zy_track=community&zy_affiliate=en_fan_page&zy_creative=fanblast_energy1_2012-07-29&_fb_noscript=1

Installed Plug-ins

  • Shockwave Flash 11.3 r300
  • Google Update
  • Picasa plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.5.1 for Mozilla browsers
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • 5.1.10411.0
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 15.0.2.72
  • Garmin Communicator Plug-In 3.0.1.0
  • Garmin Communicator Plug-In 2.9.3.0
  • Office Live Update v1.5
  • NPWLPG
  • Yahoo Application State Plugin version 1.0.0.7
  • Mozilla Firefox Canvid Integration Plugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll
  • np-mswmp
  • Office Plugin for Netscape Navigator
  • Yahoo! activeX Plug-in Bridge

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

FireChemist 4 solutions 53 answers

I assume you've checked your settings here, right? Firefox JavaScript Settings

Next, make sure your plugins are all up to date. Plugin Check

Moving on, make sure that the plugin called Java(TM) Platform SE 7 U5 10.5.1.255 is Enabled. To do this, go to Tools -> Add-ons -> Plugins and make sure this is Enabled.

Hopefully this helps.

I assume you've checked your settings here, right? [[JavaScript settings and preferences for interactive web pages|Firefox JavaScript Settings]] Next, make sure your plugins are all up to date. [http://www.mozilla.org/en-US/plugincheck/ Plugin Check] Moving on, make sure that the plugin called Java(TM) Platform SE 7 U5 10.5.1.255 is Enabled. To do this, go to Tools -> Add-ons -> Plugins and make sure this is Enabled. Hopefully this helps.

Question owner

Thanks for the reply. All of the above check out and I still get the message. There are times when I click a link that I am able to open the page, but most of the time, I get the message.

Thanks for the reply. All of the above check out and I still get the message. There are times when I click a link that I am able to open the page, but most of the time, I get the message.
FireChemist 4 solutions 53 answers

No problem I try to help if I can ^.^

According to cor-el's solution: Possible solution

1. Clear the cache

2. Remove cookies

3. Close and restart Firefox

Does that help?

No problem I try to help if I can ^.^ According to cor-el's solution: [https://support.mozilla.org/en-US/questions/916481#answer-305184 Possible solution] 1. Clear the cache 2. Remove cookies 3. Close and restart Firefox Does that help?

Question owner

I did that and still no good. I keep getting the same message.

I did that and still no good. I keep getting the same message.
cor-el
  • Top 10 Contributor
  • Moderator
17578 solutions 158993 answers

Start Firefox in Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes). *Don't make any changes on the Safe mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

I went through the whole process up to resetting Firefox and the problem still exists. The next step has me resetting Firefox. I'm not sure about that, since it will remove all my extensions and I want them back without a problem. Any thoughts on this process?

I went through the whole process up to resetting Firefox and the problem still exists. The next step has me resetting Firefox. I'm not sure about that, since it will remove all my extensions and I want them back without a problem. Any thoughts on this process?
FireChemist 4 solutions 53 answers

You're right, resetting will remove all your extensions. It'll just be a hassle to re-install them.

Before you do that, try this:

  1. Type "about:config" in the awesome (URL) bar. Accept the warning.
  2. Type "java" in the search box.
  3. Make sure every Preference is set as default

Could it be something wrong there?

You're right, resetting will remove all your extensions. It'll just be a hassle to re-install them. Before you do that, try this: # Type "about:config" in the awesome (URL) bar. Accept the warning. # Type "java" in the search box. # Make sure every Preference is set as default Could it be something wrong there?

Modified by FireChemist

cor-el
  • Top 10 Contributor
  • Moderator
17578 solutions 158993 answers

Do you have security software (firewall) that can block JavaScript?

Did you check that?

Do you have security software (firewall) that can block JavaScript? Did you check that?

Question owner

I do appreciate you two helping me out.

First I disabled my Norton 360 and still got the message. Then I typed about:config on awesome url and found one that was not set to default. Here it is:

Preference Name= pref.advanced.javascript.disable_button.advanced; Status= user set Type= boolean Value= true.

I don't know how to change it to default. I tried to double click on it and all that changed was the value from true to false. Next step?

I do appreciate you two helping me out. First I disabled my Norton 360 and still got the message. Then I typed about:config on awesome url and found one that was not set to default. Here it is: Preference Name= pref.advanced.javascript.disable_button.advanced; Status= user set Type= boolean Value= true. I don't know how to change it to default. I tried to double click on it and all that changed was the value from true to false. Next step?
FireChemist 4 solutions 53 answers

Hm, that's strange. I have

  • "services.sync.prefs.sync.pref.advanced.javascript.disable_button.advanced status=default type= boolean value=true"

instead as the closest match to that preference you indicated. It should start with the words "services.sync.prefs.sync." not sure what happened there. I would recreate the original "services.sync.prefs.sync.pref.advanced.javascript.disable_button.advanced" by going back to about:config

  1. Right-click
  2. New -> Boolean
  3. Enter "services.sync.prefs.sync.pref.advanced.javascript.disable_button.advanced"
  4. Set as true
Hm, that's strange. I have *"services.sync.prefs.sync.pref.advanced.javascript.disable_button.advanced status=default type= boolean value=true" instead as the closest match to that preference you indicated. It should start with the words "services.sync.prefs.sync." not sure what happened there. I would recreate the original "services.sync.prefs.sync.pref.advanced.javascript.disable_button.advanced" by going back to about:config # Right-click # New -> Boolean # Enter "services.sync.prefs.sync.pref.advanced.javascript.disable_button.advanced" # Set as true

Question owner

The line you asked me to recreate is there as well and has the following: status=default type= boolean value=true.

When I searched Java, the only line that was bold and was not set to default was the line as I mentioned above:

pref.advanced.javascript.disable_button.advanced; Status= user set Type= boolean Value= true.

Do you think that line could be the problem? Any suggestions?

The line you asked me to recreate is there as well and has the following: status=default type= boolean value=true. When I searched Java, the only line that was bold and was not set to default was the line as I mentioned above: pref.advanced.javascript.disable_button.advanced; Status= user set Type= boolean Value= true. Do you think that line could be the problem? Any suggestions?
FireChemist 4 solutions 53 answers

I can't say for sure. Here's what I recommend. Try toggling the state of that preference and see if it helps.

If it helps, great! If it doesn't help, I'm not sure what else to say...

But what I do know is that since toggling that preference doesn't show the Default status again, that means it's not a default firefox preference. Either yourself or an add-on created it. That means if you're ever going to reset Firefox and lose all your extensions and custom preferences, you might as well do this to remove that preference first to see if it will help.

  1. Right-click on that preference
  2. Select "Reset"
  3. Restart Firefox and that preference should disappear
I can't say for sure. Here's what I recommend. Try toggling the state of that preference and see if it helps. If it helps, great! If it doesn't help, I'm not sure what else to say... But what I do know is that since toggling that preference doesn't show the Default status again, that means it's not a default firefox preference. Either yourself or an add-on created it. That means if you're ever going to reset Firefox and lose all your extensions and custom preferences, you might as well do this to remove that preference first to see if it will help. # Right-click on that preference # Select "Reset" # Restart Firefox and that preference should disappear
cor-el
  • Top 10 Contributor
  • Moderator
17578 solutions 158993 answers

The services.sync.prefs.sync.pref prefs are only used to specify which prefs to include in that data that is saved on the sync server when you are using sync. It doesn't have any other purpose.

Anyway prefs like pref.advanced.javascript.disable_button.advanced are meant to disable specific buttons in options by locking them via a mozilla.cfg file to a the true value. In this case the button to modify the advanced JavaScript settings.

If this error is really about JavaScript being blocked then either a Firefox extension is blocking the JavaScript or your security software is blocking JavaScript.

To avoid confusion: http://kb.mozillazine.org/JavaScript_is_not_Java

The services.sync.prefs.sync.pref prefs are only used to specify which prefs to include in that data that is saved on the sync server when you are using sync. It doesn't have any other purpose. Anyway prefs like pref.advanced.javascript.disable_button.advanced are meant to disable specific buttons in options by locking them via a mozilla.cfg file to a the true value. In this case the button to modify the advanced JavaScript settings. If this error is really about JavaScript being blocked then either a Firefox extension is blocking the JavaScript or your security software is blocking JavaScript. To avoid confusion: http://kb.mozillazine.org/JavaScript_is_not_Java

Question owner

I tried Toggling it and it didn't work. I reset the preference to default and it didn't work. I guess I need to right down the extensions I have, reset Firefox and lose all extensions, restart Firefox and see if the problem continues. If it occurs, then there is another area that is the cause. If it doesn't then I will add each of my extensions, one by one, restarting each time to see if the problem occurs. That way if it does, I will know which extension is causing the problem.

I tried Toggling it and it didn't work. I reset the preference to default and it didn't work. I guess I need to right down the extensions I have, reset Firefox and lose all extensions, restart Firefox and see if the problem continues. If it occurs, then there is another area that is the cause. If it doesn't then I will add each of my extensions, one by one, restarting each time to see if the problem occurs. That way if it does, I will know which extension is causing the problem.

Question owner

Cor-el, by me disabling my security software and the problem continues, then that should mean that my security software isn't what is causing the problem. So based on that, do you suggest I reset Firefox, removing all extensions and adding them one by one as I outlined above?

Cor-el, by me disabling my security software and the problem continues, then that should mean that my security software isn't what is causing the problem. So based on that, do you suggest I reset Firefox, removing all extensions and adding them one by one as I outlined above?
jscher2000
  • Top 10 Contributor
8792 solutions 71909 answers
Not a solution, but similar problem: [https://support.mozilla.org/en-US/questions/933742 How to resolve Java Script Error Message when visiting Twitter Website?]