Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to resolve Java Script Error Message when visiting Twitter Website?

  • 4 replies
  • 5 have this problem
  • 251 views
  • Last reply by jscher2000

more options

When using firefox the following error message appears on the Twitter website regarding Java Script that is already enabled in firefox. It only happens in firefox when I visit the Twitter Website, it doesn't happen on any other website and it does not happen in Internet Explorer when I visit Twitter's website.

Error Message: Twitter.com makes heavy use of JavaScript. If you cannot enable it in your browser's preferences, you may have a better experience on our mobile site.

Modified by glomtt

All Replies (4)

more options

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

1. Clear Firefox's Cache

orange Firefox button or Tools menu > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

2. If needed, delete your twitter.com cookies here

While viewing a page on the site, right-click and choose View Page Info > Security > "View Cookies"

Then try reloading the page. Does that help? If you restart Firefox does it help? If not, please see the next section.


If you have JavaScript enabled in Firefox's options (support article) then there are a few different ways that JavaScript could be blocked for twitter.com.

One common one is the add-on NoScript, which manages scripts on a site-by-site basis. However, you probably would be well aware if you were using NoScript.

Another is external security software that filters pages on a site-by-site basis. Can you check whether your security software includes this feature?

A third possibility is another add-on which for some reason is targeting Twitter. Check any ad blockers, Flash blockers or other "blockers" as well as any relating to privacy.

Finally, there could be other settings, software, or even malware interfering with your Twitter connection.

One standard diagnostic for interference by add-ons is to try Firefox's Safe Mode.

First, I recommend backing up your Firefox settings in case something goes wrong. See Back up and restore information in Firefox profiles. (You can copy your entire Firefox profile folder somewhere outside of the Mozilla folder.)

Next, restart Firefox in Firefox's Safe Mode (Troubleshoot Firefox issues using Safe Mode) using

Help > Restart with Add-ons Disabled

In the Safe Mode dialog, do not check any boxes, just click "Continue in Safe Mode."

If the site works correctly, this points to one of your add-ons or custom settings as the problem.

Any change?

more options

None of it worked, most of the suggestions I had tried already anyway. Here is the screenshot of the error message anyway. I'm having a few problems with Twitter using Internet Explorer. I think it might be a Twitter problem and not a browser problem. Thanks for your help.

more options
more options

On the off chance that the message is a weird artifact rather than an indication of reality, could you try this:

Press Ctrl+Shift+k to open the Web Console. Copy the following line of script, paste it into the command line next to the > and press Enter. If JavaScript is enabled in the page, the expected result is a long number. If it isn't the expected result is the word undefined.


alert(document.startTime);