Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

New Firefox Browser

  • 1 reply
  • 1 has this problem
  • 5 views
  • Last reply by FredMcD

more options

Just downloaded the subject and made it my default browser. However 'googles' browser 'defaults' to the field. How do I get rid of an intrusive unwanted browser. ...Thanks...Thomas

Just downloaded the subject and made it my default browser. However 'googles' browser 'defaults' to the field. How do I get rid of an intrusive unwanted browser. ...Thanks...Thomas

Chosen solution

Are you talking about the home page? https://support.mozilla.org/en-US/kb/how-to-set-the-home-page

Or the search engine? Type about:preferences#search<enter> in the address bar. You can select any search engine to be your default from here.

You can also remove any engine from here.

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

Are you talking about the home page? https://support.mozilla.org/en-US/kb/how-to-set-the-home-page

Or the search engine? Type about:preferences#search<enter> in the address bar. You can select any search engine to be your default from here.

You can also remove any engine from here.