Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Nightly won't let me set another browser as default. I uninstalled it and now no broswer opens as default?

  • 12 replies
  • 8 have this problem
  • 853 views
  • Last reply by VQuick

more options

I am using Win8 After I installed Nightly it set itself as the default browser and won't let me set any other browser as the default, Chrome, FF, Pale Moon, even though FF says it is the default browser Nightly opens the link. I uninstalled Nightly and now no browser will open automatically when a link is clicked. I have tried to set the default browser through the browser, the default program, and through allowing access to the default programs but no success. When I reinstall Nightly it picks up as the default browser again.

All Replies (12)

more options

If you still have Nightly installed, you should be able to stop it from asserting dominance in the options:

orange Firefox button (or Tools menu) > Options > Advanced > General

Uncheck the option to "always check"

Can IE10 make itself the default browser? If not, something definitely sounds broken in the Windows registry.

more options

IE10 can set itself as the default browser. I had already unchecked the check if Nightly is default browser and the problem remains. At present, the only browser I can set as default is Nightly and IE10

more options
more options

I've tried everything in those links. It seems to be limited to Mozilla, as I've also been able to set Chrome as default. FF reports itself as default but Nightly opens the link when any Mozilla browser is default. I'm going to try uninstalling FF, Nightly, Pale Moon and then reinstall all but Nightly.

more options

I an having a more focused problem. I installed Nightly, then uninstalled it. It left itself behind as the http protocol default program. Windows 8 doesn't offer you the option of searching for another program to handle these protocols. You have the choice of Nightly (which doesn't exist), IE or some App you have to buy from them.

I tried registry edits but couldn't shake Windows 8 obsession with Nightly as the only other "installed" program that could handle internet protocols.

And shame on the Nightly developers for an incomplete uninstall.

See popup image

Any help?

more options
more options

I tried all avenues to change, Firefox is my default browser, what it isn't is the default program to process http, etc. protocols, so I get an "Unregistered Class" error every time I click on a link.

more options

You may need to run Firefox once as Administrator to get the elevated permissions to update all registry keys.

  • firefox.exe -setDefaultBrowser
more options

I was able to reassign the .url file extension but the Default internet protocol handler is still Nightly.

more options

HeavyDrop,

Your screenshot shows the ftp protocol, not http, in the How do you want to open this type of link (ftp)?

Is that screenshot related to your support issue?

more options

ftp is just the first protocol listed, all do not work. http, https. See attached.

thanks for helping.

more options

I had the same problem: I use Cyberfox, and installed Nightly to try the Win8 Metro app, then uninstalled Nightly. It orphaned the http, https, and ftp protocols and Windows would not allow me to set it as Cyberfox. Reinstalling Cyberfox and giving it all its default associations did not help; they still showed up as Nightly even though it was not installed.

Solution is here: https://support.mozilla.org/en-US/questions/955799

The HKEY_CLASSES_ROOT/FirefoxURL registry key is the culprit for us. Delete it entirely. Start up Firefox/Cyberfox and say yes to make default browser. Windows gave me a little popup that still didn't show Cyberfox as an option, but when I went to Control Panel > Defaults > Set your default programs it showed all the associations properly.