Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Partial Dark Mode issue

  • 11 replies
  • 1 has this problem
  • 118 views
  • Last reply by barblenny

more options

When I enter text in the 'find in page' (cntrl-F) text box the screen goes into partial Dark Mode, sometimes full Dark Mode. The issue presents itself as soon as a word in the find box cannot be found - 'commu' is OK, 'commue' is ng. It happens in 'Safe Mode' also. I am using the 'light theme' but the problem occurs using any theme.

Attached screenshots

Chosen solution

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting for changes to take effect.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.


Try a different Windows theme and its settings to see if you can find one that works. You can try a different Firefox and Windows theme to see if that makes a difference. Try a different Windows theme or experiment with its settings to see if can find one that works.

You can boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

Read this answer in context 👍 0

All Replies (11)

more options

That's really strange. I use the Light theme, too, and I've never seen that. I do always keep Highlight All selected, but I don't notice any difference if I turn that off temporarily.

Do you think Firefox might be trying to pick up color cues from your system theme?

Have you created a userChrome.css or userContent.css file to modify the appearance of Firefox?

Helpful?

more options

The problem started about a week ago and occurs in Firefox safe mode also. It does not occur in my Windows 10 laptop. Again, as seen in the jpg the screen is only partially in dark mode. Each time I spell a word that cannot be found the 'partial' is different.

Helpful?

more options

I think it's possible your Firefox program files are damaged in some weird way. What we usually suggest in that case is the following:

Clean Re-install

This takes about 5 minutes. It's not about your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. It's not essential to uninstall Firefox, but you can if you like, saying No to any request about removing personal data.

If you want to make a backup first just in case, see: Back up and restore information in Firefox profiles

(A) Download a fresh installer for Firefox to a convenient location:

https://www.mozilla.org/firefox/all/

(B) Exit out of Firefox (if applicable).

If you have Microsoft Office installed locally, please change your default browser to Internet Explorer temporarily before the next step.

(C) Using File Explorer (hold down the Windows key and press E to launch it), right-click > rename the program folder as follows (you might have one or both):

C:\Program Files\Mozilla Firefox =to=> C:\Program Files\OldFirefox

C:\Program Files (x86)\Mozilla Firefox =to=> C:\Program Files (x86)\OldFirefox

(D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings.

Any improvement at your next startup?

Helpful?

more options

Thank you for your help so far. I was hoping to not do a reinstall but it appears that it was painless. All add-ons and bookmarks were saved. However, the partial dark mode problem is still there.

Helpful?

more options

Wow, I really have no idea. Hopefully someone else will be able to figure out the connection. And this just started when you updated to Firefox 75?

Helpful?

more options

I can't recall if it started with the update but the timing seems right.

Helpful?

more options

Chosen Solution

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting for changes to take effect.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.


Try a different Windows theme and its settings to see if you can find one that works. You can try a different Firefox and Windows theme to see if that makes a difference. Try a different Windows theme or experiment with its settings to see if can find one that works.

You can boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

Modified by cor-el

Helpful?

more options

Partial success. I disabled Firefox hardware acceleration and now, when I type an unfound word in the find box, the screen flashes dark. I can't tell if the screen goes into dark mode because the flash is extremely short. I tried Windows safe mode - same thing. I can live with this if no one else has any ideas though it would be nice to solve the problem.

Helpful?

more options

I found another example of the night mode issue. It is when I try to save a file from an email and the file already exists. As I hit 'save' the message '...already exists, Do you want to replace it?' appears and the screen goes into night mode for about 1/2 second. Any other ideas?

Helpful?

more options

I noticed that an unsuccessful 'find' in other applications also produces a dark screen type effect. Meaning it is something in Windows 10 and not a Firefox problem. Thanks to those that tried to help.

Helpful?

more options

I found the problem. There is a setting in Windows 10, 'Ease of Access - Audio - Select how visual alerts for notifications are displayed'. It was set to 'Flash the active window'. I clicked on 'No visual alert' to stop the flashing screen. Who knew?

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.