Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Dark Mode and Dark Themes have white text on a white background in the address bar

more options

It seems since Firefox 100 the address bar has taken to being white-on-white, making it nearly impossible to read. There isn't any issues with light themes. It doesn't matter if I change the Windows 10 default app mode to light or dark. Light themes have black text on white background, but dark themes have white text on white background. Any ideas?

It seems since Firefox 100 the address bar has taken to being white-on-white, making it nearly impossible to read. There isn't any issues with light themes. It doesn't matter if I change the Windows 10 default app mode to light or dark. Light themes have black text on white background, but dark themes have white text on white background. Any ideas?

Chosen solution

You didn't share a screenshot like the other thread linked above, so this might not be relevant, but...

That can be caused by older versions of the MaterialFox theme for userChrome.css and may require a manual tweak. https://www.reddit.com/r/firefox/comments/ujrbyg/ff_100_white_address_bar_on_default_theme/

Read this answer in context 👍 1

All Replies (5)

more options

You can create your own Theme with the Firefox Color Plugin.

Helpful?

more options

The plugin seems unable to affect the colour of the search bar or search bar text.

Helpful?

more options

The same question is unanswered at https://support.mozilla.org/en-US/questions/1376134

You could try changing this preference in about:config to Dark (0), light (1), system (2) or browser (3). layout.css.prefers-color-scheme.content-override

If that doesn't work, try creating the following preference as a number and make it 1 for dark mode (0 for light). ui.systemUsesDarkTheme

https://support.mozilla.org/en-US/kb/about-config-editor-firefox

Helpful?

more options

Chosen Solution

You didn't share a screenshot like the other thread linked above, so this might not be relevant, but...

That can be caused by older versions of the MaterialFox theme for userChrome.css and may require a manual tweak. https://www.reddit.com/r/firefox/comments/ujrbyg/ff_100_white_address_bar_on_default_theme/

Helpful?

more options

jscher2000 - Support Volunteer said

You didn't share a screenshot like the other thread linked above, so this might not be relevant, but... That can be caused by older versions of the MaterialFox theme for userChrome.css and may require a manual tweak. https://www.reddit.com/r/firefox/comments/ujrbyg/ff_100_white_address_bar_on_default_theme/

That worked! I deleted the chrome folder and user.js, restarted firefox and everything works like normal now. Thank you!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.