Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Dark mode in all firefox browsing sites do not work now

more options

Hi, I am using the dark mode in firefox which is god sent boon to persons having glaucoma, with dark mode in firefox and dark reader add on. This was going well and after a recent update, I could not find it working. The dark mode is enabled and dark reader was there, but the browsing pages only shows in white. Has firefox changed anything recently to have this issue? If I miss something would the experts say, how to get back my dark browsing experience in all sites. If I find anything not visible in some sites, I used to go the windows properties and change the contrast theme to windows basic blue theme and then switched back to dark theme. this was helping the glaucoma persons very much. please, say how to solve this problem

Chosen solution

You can check whether Firefox is applying a High Contrast system theme in the Colors dialog. Either:

  • Windows: "3-bar" menu button (or Tools menu) > Settings (previously "Options")
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the Language and Appearance section, click the Colors... button.

There is a 3-position selector and I think you need the middle position:

For more accurate site colors, you can use the Dark Reader extension instead.

Read this answer in context 👍 0

All Replies (12)

more options

Is the dark mode working now in firefox. Or is there a bug and will be fixed

more options

Firefox for Windows doesn't have an automatic dark mode for web pages. It has that only for its built-in pages.

You can use an add-on to modify other pages, for example:

Dark Reader: https://addons.mozilla.org/firefox/addon/darkreader/

Or maybe you were using the Windows "high contrast" dark mode??

more options

Hi, jscher,

    Yes , I am using the high contrast theme and the latest version of ff.
    I think that the latest version has some bugs , so the dark mode even when selected would just would not work correctly. i tried all sorts of things.
    Nothing worked. Even, I tried modified add of strings in about:config as has been found in the mozilla support questions and answers. Nothing worked . Instead , every page becomes totally white glaring pages.
     I just uninstalled the latest ff through  control panel and reinstalled the previous latest version 92 and just selected the dark theme and it worked as previously.
      Does the ff made any changes in the behavior of inbuilt dark theme in the new version?
      If , why . It was helpful for glaucoma persons like me to have the dark mode instead of light mode
more options

Chosen Solution

You can check whether Firefox is applying a High Contrast system theme in the Colors dialog. Either:

  • Windows: "3-bar" menu button (or Tools menu) > Settings (previously "Options")
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the Language and Appearance section, click the Colors... button.

There is a 3-position selector and I think you need the middle position:

For more accurate site colors, you can use the Dark Reader extension instead.

more options

Another person reported a problem with colors they set personally after upgrading to Firefox 94. Hopefully more people will be investigating the issue and figure out what's going on.

https://www.reddit.com/r/firefox/comments/qlyrjc/firefox_94_breaks_the_colors_option_under_fonts/

more options

Hi, jscher , I checked the settings. the only high contrast color was selected .right. But, just changing to the previous version and then opting dark theme in theme section solved the problem for me. Is there any change in the color mode by firefox in the latest version that triggered this issue? I saw some threads regarding this issue in the firefox questions and answer section.

more options

Hi jrj, I don't have any other information at this point.

more options

Hi, jscher, i saw this thread and applied a fix given by mongolia in this link. this did not work for me and only opting to version 92 version backwards only solved the issue. i need not get add on dark reader to get all sites black. dark reader add on slows browsing as it load pages slowly There is a bug in the latest edition of 93 version https://www.reddit.com/r/firefox/comments/al9d11/dark_theme_issues_with_new_update/

more options

Hi, jscher. It automatically updates to the present edition.Now I have no white annoying pages. All are black and white good for glaucoma persons. do not know, what changed the default behaviour of dark mode. thanks for all your solutions

more options

This goddamn web page isn't even dark in Firefox no matter what color settings are used in Firefox or system color theme is set in Windows.

more options

You can change this pref on the about:config page from 3 to 2 to revert to the Firefox 94 behavior.

  • layout.css.prefers-color-scheme.content-override
    Dark (0), light (1), system (2) or browser (3)

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

See also this pref:

  • ui.systemUsesDarkTheme [0:light; 1:dark; 2:no-preference]
  • 1736218 - Add some sort of UI to select content dark theme preference
more options

FFUser said

This goddamn web page isn't even dark in Firefox no matter what color settings are used in Firefox or system color theme is set in Windows.

Websites can but aren't required to ask Firefox your light/dark theme preference when styling their pages. This is one of many sites that do not check. For those sites, the traditional remedy is an add-on like:

https://addons.mozilla.org/firefox/addon/darkreader/