Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Where is my "junk mail folder" in outlook gone?

  • 4 replies
  • 1 has this problem
  • 2290 views
  • Last reply by FredMcD

more options

Hello to whom it may concern: Two days ago my Firefox Browser was updated for my automatically, to 75.0(64-Bit). But today I need to reboot my computer due to things getting slow. Once I rebooted I had noticed when I had opened Outlook Email in my Firefox Browser the "Junk E-mail Folder" had disappeared. I immediately went to my standby browser on 'Edge' and checked to see if things had also changed on my Outlook E-mail account, it was all good nothing missing or changed. I totally only use Firefox Browser it is the only browser I trust and know that protects me(plus Firefox is so much faster). I do hope this issue can be fixed fast, since I do get important e-mails that end up in my Junk e-mail folder I need to have access to. Kindest regards, Milton

Attached screenshots

Chosen solution

FredMcD, rather than deleting all cookies and clearing the cache which is a last measure, I decided to try the Safe Mode first and disabling Hardware Acceleration. (the disabling is just a bite different now with the new Firefox update, but not hard to figure out). Once My "Junk E-mail Folder" showed up after disabling it, I re-enabled my Hardware Acceleration and my "Junk Mail Folder" was still there. I will know what to do to correct it if it happens again!!! Thank-you for all your help! Stay safe, (2 meters away). Milton.

Read this answer in context 👍 0

All Replies (4)

more options

Do Not Use the support number. It is a fake.

more options

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

Chosen Solution

FredMcD, rather than deleting all cookies and clearing the cache which is a last measure, I decided to try the Safe Mode first and disabling Hardware Acceleration. (the disabling is just a bite different now with the new Firefox update, but not hard to figure out). Once My "Junk E-mail Folder" showed up after disabling it, I re-enabled my Hardware Acceleration and my "Junk Mail Folder" was still there. I will know what to do to correct it if it happens again!!! Thank-you for all your help! Stay safe, (2 meters away). Milton.

more options

Well done.