Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

On the Daily Racing Form website Flash Player works for one feature but won't work for another. Why is this?

  • 3 replies
  • 1 has this problem
  • Last reply by FredMcD

more options

I am into horse racing and use the Daily Racing Form website from which I can watch live streaming races using Adobe Flash Player. They have a feature called Formulator that I am trying to access but Adobe Flash Player won't bring it up. It starts but will not complete. Flash Player works for both in Windows Edge.

All Replies (3)

more options

Is it the same that does not play, or any?

Please provide a public link (no password) that we can check out. No Personal Information Please !

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

more options

I have found that if I wait a few minutes and then right click on the pinned Firefox link in the taskbar and then click on close window it will bring up an option to exit and close the tabs after which the Formulator will open before I choose to close the window. I have used these steps with another issue on the website where the page freezes. It appears these two issues are related in origin.

more options

Sorry, login required.

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}