X
Tap here to go to the mobile version of the site.

Support Forum

How to fix Drop down menus that do not stay open after updating to Windows 10

Posted

I not keep down menus open long enough to select favorites, get to options or to print etc. The menu and the favorites open but won't let me scroll down to select. They close before I click on anything. In Favorites I have various folder but can not get them to click on the site I want because the drop down disappears. The same thing happens with the favorites menu bar list that extend beyond the the bar at the top of the browser.

I not keep down menus open long enough to select favorites, get to options or to print etc. The menu and the favorites open but won't let me scroll down to select. They close before I click on anything. In Favorites I have various folder but can not get them to click on the site I want because the drop down disappears. The same thing happens with the favorites menu bar list that extend beyond the the bar at the top of the browser.

Chosen solution

Separate Issue; Your System Details shows;

Installed Plug-ins

Garmin Communicator Plug-In 4.2.0.0 BETA Garmin Communicator Plug-In 4.1.0.0

Shockwave Flash 19.0 r0 Shockwave Flash 18.0 r0
Having more than one version of a program may cause issues. You must remove the older programs. Then get the current full installer.

Note: Edge on Win10 does not use ActiveX version but its own Flash.

Flash: Grab the uninstaller from here: Uninstall Flash Player | Windows Uninstall Flash Player | Mac

Then reinstall the latest version.

Flash Player Version 19.0.0.185
https://www.adobe.com/products/flashplayer/distribution3.html
Note: Windows users must download the “Internet Explorer” and “Plugin-based browsers” installers.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • ActiveTouch General Plugin Container Version 105
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.12
  • Citrix Online App Detector Plugin
  • Coupons, Inc. Coupon Printer 4.0.2.0
  • Garmin Communicator Plug-In 4.2.0.0 BETA
  • Garmin Communicator Plug-In 4.1.0.0
  • Version 5.41.2.0
  • Google Update
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • CANON iMAGE GATEWAY Mycamera Plugin
  • NPWLPG
  • Shockwave Flash 19.0 r0
  • Shockwave Flash 18.0 r0
  • 5.1.40728.0
  • WildTangent Games App V2 Presence Detector
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
16408 solutions 148014 answers

Helpful Reply

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
You can try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes You can check if there is an update for your graphics display driver and check for hardware acceleration related issues. *https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration ---- Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes
FredMcD
  • Top 10 Contributor
3669 solutions 50336 answers

Chosen Solution

Separate Issue; Your System Details shows;

Installed Plug-ins

Garmin Communicator Plug-In 4.2.0.0 BETA Garmin Communicator Plug-In 4.1.0.0

Shockwave Flash 19.0 r0 Shockwave Flash 18.0 r0
Having more than one version of a program may cause issues. You must remove the older programs. Then get the current full installer.

Note: Edge on Win10 does not use ActiveX version but its own Flash.

Flash: Grab the uninstaller from here: Uninstall Flash Player | Windows Uninstall Flash Player | Mac

Then reinstall the latest version.

Flash Player Version 19.0.0.185
https://www.adobe.com/products/flashplayer/distribution3.html
Note: Windows users must download the “Internet Explorer” and “Plugin-based browsers” installers.

Separate Issue; Your System Details shows; Installed Plug-ins Garmin Communicator Plug-In 4.2.0.0 BETA Garmin Communicator Plug-In 4.1.0.0 Shockwave Flash 19.0 r0 Shockwave Flash 18.0 r0 <br>Having more than one version of a program may cause issues. You must remove the older programs. Then get the current full installer. Note: Edge on Win10 does not use ActiveX version but its own Flash. Flash: Grab the uninstaller from here: '''[http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows]''' '''[http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac]''' Then reinstall the latest version. Flash Player '''Version 19.0.0.185<br>https://www.adobe.com/products/flashplayer/distribution3.html''' '''Note: Windows users''' must download the “Internet Explorer” '''and''' “Plugin-based browsers” installers.
MarjaE 2 solutions 199 answers

I am using a Mac, do not have hardware acceleration or flash enabled, do not have two versions of any one plugin, and am now encountering the same problem.

I am using a Mac, do not have hardware acceleration or flash enabled, do not have two versions of any one plugin, and am now encountering the same problem.
FredMcD
  • Top 10 Contributor
3669 solutions 50336 answers

MarjaE Please go to the top of any support.mozilla.org web page and use the Ask A Question link; https://support.mozilla.org/en-US/questions/new This will let us look at your system details. No Personal Information Is Collected.

'''MarjaE''' Please go to the top of any '''support.mozilla.org''' web page and use the '''Ask A Question link; https://support.mozilla.org/en-US/questions/new''' This will let us look at your system details. '''No Personal Information Is Collected.'''