X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

right click menu doesn't work

PRB
Posted

(This issue has been ongoing for several versions now. I've uninstalled and reinstalled, and tried safe mode.)

The right click menu, within the menu bar drop down menus, disappears as soon as I move the mouse. Making it impossible to select anything from it.

For example: I click "Bookmarks" in the menu bar and get a drop down window of all my bookmarks. I then mouse over a bookmark and right click to get the drop down menu that will let me "Open", "Open in new Window", "Open in new Tab", etc... As soon as I move the mouse, this menu disappears. I cannot mouse over it to make a selection.

If I don't move the mouse I can use the arrow keys to make a selection and then hit enter.

Additional System Details

Installed Plug-ins

  • getplusplusadobe16291
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.448
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.4"
  • Default Plug-in
  • Shockwave Flash 10.1 r53
  • 4.0.50826.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 GTB7.1 ( .NET CLR 3.5.30729)

More Information

Application Basics
Name
Firefox
Version
3.6.10
Profile Directory
Open Containing Folder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Java Console
6.0.20
true
{CAFEEFAC-0016-0000-0020-ABCDEFFEDCBA}
Adblock Plus: Element Hiding Helper
1.0.6
true
elemhidehelper@adblockplus.org
external IP
0.9.9.6
false
externalip@erik.morlin
Last tab close button
0.3.3
true
last-tab-close-button@victor.sacharin
Outwit Images
0.2.4.77
true
outwit-images@outwit.com
Tab Scope
0.3.6
false
tabscope@xuldev.org
Microsoft .NET Framework Assistant
1.2.1
true
{20a82645-c095-46ed-80e3-08825760534b}
Google Toolbar for Firefox
7.1.20100830W
true
{3112ca9c-de6d-4884-a869-9855de68056c}
OutWit Kernel
0.9.4.77
true
{5fb1186a-3398-4c47-b579-0f2eee222ad1}
CookieCuller
1.4
true
{99B98C2C-7274-45a3-A640-D9DF1A1C8460}
Image Toolbar
0.6.8
true
{A4732521-77D9-447E-A557-B279AC923F06}
DownloadHelper
4.8
true
{b9db16a4-6edc-47ec-a1f4-b86292ed211d}
Adblock Plus
1.2.2
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
BetterPrivacy
1.48.3
true
{d40f5e7b-d2cf-4856-b441-cc613eeffbe3}
Torbutton
1.2.5
true
{e0204bd5-9d31-402b-a99d-a6aa8ffebdca}
WorldIP
2.0.2
true
{f36c6cd1-da73-491d-b290-8fc9115bfa55}
Download Manager Tweak
0.9.2
true
{F8A55C97-3DB6-4961-A81D-0DE0080E53CB}
Java Quick Starter
1.0
false
jqs@sun.com
Norton IPS
2.0
true
{BBDA0591-3099-440a-AA10-41764D9DB4DB}
Norton Toolbar
5.1
true
{2D3F3651-74B9-4795-BDEC-6DA2F431CB62}
Adobe DLM (powered by getPlus(R))
1.6.2.91
true
{E2883E8F-472F-4fb0-9522-AC9BF37916A7}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.fixup.alternate.enabled
false
browser.history_expire_days.mirror
180
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://www.google.com/webhp?sourceid=navclient-ff
browser.startup.homepage_override.mstone
rv:1.9.2.10
browser.tabs.warnOnOpen
false
extensions.lastAppVersion
3.6.10
font.name.serif.x-western
Verdana
font.size.variable.x-western
17
general.useragent.extra.microsoftdotnet
( .NET CLR 3.5.30729)
network.cookie.prefsMigrated
true
network.security.ports.banned
8118,8123,9050,9051
places.last_vacuum
1281294476
print.print_printer
Microsoft XPS Document Writer
print.printer_Microsoft_XPS_Document_Writer.print_bgcolor
false
print.printer_Microsoft_XPS_Document_Writer.print_bgimages
false
print.printer_Microsoft_XPS_Document_Writer.print_command
print.printer_Microsoft_XPS_Document_Writer.print_downloadfonts
false
print.printer_Microsoft_XPS_Document_Writer.print_edge_bottom
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_left
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_right
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_top
0
print.printer_Microsoft_XPS_Document_Writer.print_evenpages
true
print.printer_Microsoft_XPS_Document_Writer.print_footercenter
print.printer_Microsoft_XPS_Document_Writer.print_footerleft
&PT
print.printer_Microsoft_XPS_Document_Writer.print_footerright
&D
print.printer_Microsoft_XPS_Document_Writer.print_headercenter
print.printer_Microsoft_XPS_Document_Writer.print_headerleft
&T
print.printer_Microsoft_XPS_Document_Writer.print_headerright
&U
print.printer_Microsoft_XPS_Document_Writer.print_in_color
true
print.printer_Microsoft_XPS_Document_Writer.print_margin_bottom
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_left
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_right
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_top
0.5
print.printer_Microsoft_XPS_Document_Writer.print_oddpages
true
print.printer_Microsoft_XPS_Document_Writer.print_orientation
0
print.printer_Microsoft_XPS_Document_Writer.print_pagedelay
500
print.printer_Microsoft_XPS_Document_Writer.print_paper_data
1
print.printer_Microsoft_XPS_Document_Writer.print_paper_height
11.00
print.printer_Microsoft_XPS_Document_Writer.print_paper_size_type
0
print.printer_Microsoft_XPS_Document_Writer.print_paper_size_unit
0
print.printer_Microsoft_XPS_Document_Writer.print_paper_width
8.50
print.printer_Microsoft_XPS_Document_Writer.print_reversed
false
print.printer_Microsoft_XPS_Document_Writer.print_scaling
1.00
print.printer_Microsoft_XPS_Document_Writer.print_shrink_to_fit
true
print.printer_Microsoft_XPS_Document_Writer.print_to_file
false
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_bottom
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_left
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_right
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_top
0
privacy.cpd.cookies
false
privacy.cpd.extensions-betterprivacy
true
privacy.popups.showBrowserMessage
false
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.warn_viewing_mixed
false

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).

See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems and Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

Question owner

Tried it. Didn't work.

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24384 answers

You still had that problem while running in the Firefox SafeMode?

Bezz 0 solutions 1 answers

Hi,

3.6.10 dutch is the first version in which I have encountered this.

The safe mode trick didn't fix it for me.

It happened while right clicking a link in a wikipedia page (I was looking for Open in a new tab).

It appears to be intermittent. After a while within one Firefox session, it went away. I have been able to reproduce a few times, but for now it's gone alltogether.

While I was experiencing the problem, I switched to Windows explorer. Much to my surprise, I couldn't use right click in explorer aswell! After the situation went away (intermittent) I could use right click in both Firefox and explorer (I know this one sounds like a UFO sighting, and maybe it's an OS problem (Vista Ultimate, Dutch), but maybe it's a Firefox problem that extends outside Firefox because of some shady Windows event hook thingy).

Hope this helps finding the bug.

Question owner

Yeah. It still does it in safe mode.

Unlike Bezz, mine only does it in the drop down menus, which are within the drop down menus of the "Menu Bar" (File, Edit, View, History, Bookmarks, Tools, Help.

Right click works fine the rest of the time. It's only when I open something on the menu bar, and then right click on one of the selections (like you'd do to delete a bookmark).

bendikro 0 solutions 1 answers

No news on this?

I'm on Ubuntu 10.10 and experience this extremely annoying bug. All the menus, and popup (right-click) menus disappear as soon as the mouse hovers over the menu.

But that is only when the bug is "active". No idea wha (de)activates the bug.

vedster 0 solutions 1 answers

Firefox 4 - Ubuntu 10.10 x64

Same bug as Bendikro. Suddenly my right click menus stop working. I right click, the menu pops up but as soon as the mouse hovers over the menu it dissapears (the menu). Restarting Firefox seems to solve the problem.

Extremely annoying!

speed32219 0 solutions 1 answers

I have the same problem as vedster above except it doesn't cure itself after restarting FF or rebooting, 2.6.35-28-generic #49-Ubuntu, Mozilla firefox 4.0 canonical - 1.0. It is also not working by left clicking on a menu item (Toolbar, File, Edit), it opens the sub menu but as soon as I move the mouse it disappears. I have uninstalled all addons, but .9RC2 stills shows up as not compatible with 4.0 but it is disabled. Maybe something is lthere is casuing my problem since it was a upgrade and not a fresh install.

If I load safemode it corrects the problem. I have removed flash but still encounter the sub menu disappearing after left click and as soon as mouse movement is detected the sub menu drop down closes. I need to use keyboard after right clicking. PIA

I have also renamed the hidden mozilla folder and mozilla creates a repalcement, but FF will not start with the replacement hidden folder, so I moved the old one back and everything is fine except for the right and left mouse and submenus disappearing.

Modified by speed32219

herbie643 0 solutions 2 answers

I have the same problem. However, I thought there might be a correlation between Thunderbird and Firefox. I usually have both open. Well the menu in Thunderbird was disappearing. I closed Firefox and the menu was fine. Later the reverse happened, Firefox menu was disappearing. Closed Thunderbird and menu is fine. Curious isn't it?

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

It is possible that Thunderbird is using an older version of one or more DLL files that Firefox is using as well and starting Thunderbird before Firefox will cause Firefox to use an older incompatible version. So try to first start Firefox and then Thunderbird to see if that works.

Peter_sydar 0 solutions 1 answers

Helpful Reply

Hello, here is the fix: Go to advanced javascript settings in ubuntu it's at Edit->Preferences->Content->Advanced (next to "Enable javascript")-> and now make sure "Disable or replace contex menus" is not selected.

)

Modified by Peter_sydar

mattjabs 0 solutions 2 answers

I confirm that this solution works for me. I run Ubuntu 10.10 on 64bit with FireFox 4.0.

allpowerful 0 solutions 1 answers

Yep, seems to be working in Ubuntu 11.04 32bit with Firefox 4.0... Thanks :)

johnheritage 0 solutions 1 answers

I'll take your right click and raise you a none functioning application menu, making it impossible to click file / edit etc to resolve things that way.

It stopped 'randomly'. Restarting browser didn't work, resetting computer did nothing. Couldn't alter toolbars or java through edit, or manually update.

Then looked at the update button in Ubuntu and realised I hadn't clicked that in a while. 283mb to download. About half way through, the right click returned. A minute later, still downloading, the menus began to work again. Reset the browser and then the computer, everything working fine again.

But on restarting the computer, I received an error message when coming into the desktop warning of an applet that wasn't functioning. Something called 'trash' and with ubuntu asking me if I wanted to delete it.

So my answer is, try checking for updates before deleting or reinstalling.

My question is, could this have been prompted by some form of malicious script? I've never seen the error before and was doing precisely zero messing around with settings when it occurred whilst browsing.

The only things I have installed are google search box, ABP (pop up blocked) and Flash Block. Flash bBock is currently off. Neither of the other two have ever caused any problems. I would highly recommend ABP and Flash Block to stand between your ram and all the spurious junk trying to force it's way in from the tubes.

Modified by johnheritage

ericyolai 0 solutions 2 answers

Helpful Reply

This solution worked for me (Dell E6320 laptop running Firefox 5 on Windows 7 Pro) immediately:

Go to Options > Advanced > General and uncheck the "Use hardware acceleration when available"

I found it here: https://support.mozilla.com/en-US/questions/764278#question-reply

It's a pity that you might be slowing the rendering somewhat, but the tradeoff is well-worth it...

jhmark 0 solutions 1 answers

I know this is the Firefox forum but I wanted to mention I am seeing this same behavior with Thunderbird 6.0 on Ubuntu 9.10. It happens intermittently but at least once per hour. Both context menus and menu bar menus disappear as soon as I move the mouse into them. Minimize/restore causes it to work normally again.

Changing "dom.event.contextmenu.enabled" from true to false did not fix it (in config editor under Edit/Preferences/Advanced). I will try setting "layers.acceleration.disabled" next.

Modified by jhmark

zx5000 0 solutions 1 answers

Thunderbird 7.0.1 still has this issue. I stopped using FF since my CPU goes to 100% so often.

I have noticed that you can click on any other program then back to Thunderbird and the menus work correctly.

This is a real nuisance. It does it multiple times a day without any apparent provocation.

gsxrchris 0 solutions 1 answers

Firefox 7, Ubuntu 11.10.

In my case right-click didn't work, restarting firefox, logging out and in didn't work, safe-mode didn't work. Multiple tabs open within one window, right-click didn't work ANYWHERE in the window (whether in the page, in the URL bar, etc.) or in any tabs.

Solution found: Open a new window (File -> New Window). Right-click to test. If successful: Move all open tabs to new window, including pinned tabs; close old window.

In my case the faulty window was the one with my pinned tabs. So I had to repin them. Hope this can work for somebody else...

Modified by gsxrchris

achimt 0 solutions 1 answers

Firefox 7.0.1, Ubuntu 11.10. gsxrchris' solution worked a treat. A new window solved the problem.

john 0 solutions 1 answers

For me the solution was to disable the Unity plug-in "Global Menu Bar integration 2.0.1". After that I had no problem.