X
Tap here to go to the mobile version of the site.

Support Forum

FireFox hangs with Adobe Flash Player

Posted

I am using Firefox 35.0.1 and I have installed Shockwave Flash 16.0.0.296. As soon as Flash starts, Firefox freezes and unfreezes until it can't be used at all. I have tried uninstalling and reinstalling the flash player and I have also used Firefox's Refresh option. This problem started a couple of days ago & I don't know what else I can do.

I am using Firefox 35.0.1 and I have installed Shockwave Flash 16.0.0.296. As soon as Flash starts, Firefox freezes and unfreezes until it can't be used at all. I have tried uninstalling and reinstalling the flash player and I have also used Firefox's Refresh option. This problem started a couple of days ago & I don't know what else I can do.

Chosen solution

UPDATE 2: Now the Flash Player does work on some sites & when it doesn't work, it doesn't freeze FF. I did uninstall Opera before this so maybe that software had something to do with the problem?

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.31.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Nielsen FirefoxTracker Plug-in
  • NPWLPG
  • Shockwave Flash 16.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.6.156
  • 5.1.31211.0
  • VLC media player Web Plugin 2.1.3

Application

  • Firefox 35.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
  • Support URL: https://support.mozilla.org/1/firefox/35.0.1/WINNT/en-US/

Extensions

  • Nielsen NetSight 2.3.7 (netsight@nielsen.com)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 8400
  • adapterDescription2:
  • adapterDeviceID: 0x9830
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.17111
  • driverDate: 8-30-2013
  • driverDate2:
  • driverVersion: 13.152.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 8400 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: Yes
guigs
  • Administrator
  • Moderator
1043 solutions 11412 answers

Hello,

Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See this article for more information on using the Flash plugin in Firefox).

To disable hardware acceleration in Flash Player:

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.

Does this solve the problem? Let us know.

Hello, Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See [[Flash Plugin - Keep it up to date and troubleshoot problems|this article]] for more information on using the Flash plugin in Firefox). To disable hardware acceleration in Flash Player: #Go to this [http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues Adobe Flash Player Help page]. #Right-click on the Flash Player logo on that page. #Click on '''Settings''' in the context menu. The Adobe Flash Player Settings screen will open. # Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel. <br/> <br/>[[Image:fpSettings1.PNG]] <br/> # Remove the check mark from '''Enable hardware acceleration'''. # Click '''Close''' to close the Adobe Flash Player Settings Window. # Restart Firefox. This [http://www.macromedia.com/support/documentation/en/flashplayer/help/help01.html Flash Player Help - Display Settings page] has more information on Flash Player hardware acceleration, if you're interested. Does this solve the problem? Let us know.

Question owner

Hi,

I can't get that far! All I see is a white square and clicking on it doesn't work.

Thanx anyway!

Steve J

Hi, I can't get that far! All I see is a white square and clicking on it doesn't work. Thanx anyway! Steve J
AliceWyman
  • Moderator
229 solutions 2491 answers

You could try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

You could try '''Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem.
FredMcD
  • Top 10 Contributor
3227 solutions 43540 answers

Start Firefox in Safe Mode {web Link} by holding down the <Shift (Mac Options) > key, and then starting Firefox.

Now try the above.


This add-on can give you some help by stopping flash until you want it.

Flash block {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift ''(Mac Options)'' >''' key, and then starting Firefox. Now try the above. ----------------------------- This add-on can give you some help by stopping flash until you want it. '''[https://addons.mozilla.org/en-US/firefox/addon/flashblock/ Flash block]''' {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it

Question owner

OK, I'll give this a try...

Steve J.

OK, I'll give this a try... Steve J.

Question owner

Alice,

I know that the Adobe Flash Player is the problem so starting in Safe Mode isn't a real solution. In the meantime, I have disabled the player.

Steve Jandreau

AliceWyman said

You could try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:
  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.
If Firefox is not running, you can start Firefox in Safe Mode as follows:
  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
When the Firefox Safe Mode window appears, select "Start in Safe Mode".
SafeMode-Fx35
If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause. To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again. When you figure out what's causing your issues, please let us know. It might help others with the same problem.
Alice, I know that the Adobe Flash Player is the problem so starting in Safe Mode isn't a real solution. In the meantime, I have disabled the player. Steve Jandreau ''AliceWyman [[#answer-684004|said]]'' <blockquote> You could try '''Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem. </blockquote>
AliceWyman
  • Moderator
229 solutions 2491 answers

piniella said

Alice, I know that the Adobe Flash Player is the problem so starting in Safe Mode isn't a real solution. In the meantime, I have disabled the player.

It's not a permanent fix, its a toubleshooting step so you should try it.

Plugins like Flash are NOT disabled in Firefox Safe Mode, but add-on extensions ARE, and so is hardware acceleration. See http://kb.mozillazine.org/Safe_Mode

Who knows, maybe you won't see the hangs when Hardware Acceleration is disabled in Firefox ... or when your Nielsen NetSight extension is disabled (whatever that is) .

For other possible solutions, see the Troubleshooting section of Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems. See also: Fix common audio and video issues

''piniella [[#answer-684048|said]]'' <blockquote> Alice, I know that the Adobe Flash Player is the problem so starting in Safe Mode isn't a real solution. In the meantime, I have disabled the player. </blockquote> It's not a permanent fix, its a toubleshooting step so you should try it. Plugins like Flash are NOT disabled in Firefox Safe Mode, but add-on extensions ARE, and so is hardware acceleration. See http://kb.mozillazine.org/Safe_Mode Who knows, maybe you won't see the hangs when Hardware Acceleration is disabled in Firefox ... or when your Nielsen NetSight extension is disabled (whatever that is) . For other possible solutions, see the Troubleshooting section of [[Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems]]. See also: [[Fix common audio and video issues]]
AliceWyman
  • Moderator
229 solutions 2491 answers

piniella said

In the meantime, I have disabled the player.

Before trying Firefox Safe Mode, re-enable the Flash plugin. If the problem still exists and you can't find another solution, you can set the Flash plugin to "Ask to Activate" in the Add-ons manager, which lets you decide on a case-by-case basis whether to allow Flash content (you'll see an "Activate Adobe Flash" image where the Flash content should be, as shown HERE).

''piniella [[#answer-684048|said]]'' <blockquote> In the meantime, I have disabled the player. </blockquote> Before trying Firefox Safe Mode, re-enable the Flash plugin. If the problem still exists and you can't find another solution, you can set the Flash plugin to "Ask to Activate" in the Add-ons manager, which lets you decide on a case-by-case basis whether to allow Flash content (you'll see an "Activate Adobe Flash" image where the Flash content should be, as shown [https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues#w_enable-or-activate-plugins HERE]).
AliceWyman
  • Moderator
229 solutions 2491 answers

P.S. I see that, in addition to the Nielsen NetSight extension, you also have the "Nielsen FirefoxTracker Plug-in" installed. This might be contributing to your problem so disable the plugin as well as the extension. This software can cause Firefox problems - see /en-US/questions/1036378#answer-664933

P.S. I see that, in addition to the Nielsen NetSight extension, you also have the "Nielsen FirefoxTracker Plug-in" installed. This might be contributing to your problem so disable the plugin as well as the extension. This software can cause Firefox problems - see [/en-US/questions/1036378#answer-664933]
werdy666 0 solutions 1 answers

I have the exact same problem

Using Win 7, Firefox 35.01 and flash 16.0.0.296

Been for afew weeks now. Had to revert to an old version of flash player but now since firefox keeps warning me that the old one needs updating have tried it again and it does exactly as pinella describes

Loading youtube and the spot where the video would display is white, the mouse cursor flickers and firefox becomes very unresponsive. Any flash testing site etc do not work.

I can use 3rd party plugins for flash and they work fine....

I have also just updated my nvidia drivers and still no difference.

I have the exact same problem Using Win 7, Firefox 35.01 and flash 16.0.0.296 Been for afew weeks now. Had to revert to an old version of flash player but now since firefox keeps warning me that the old one needs updating have tried it again and it does exactly as pinella describes Loading youtube and the spot where the video would display is white, the mouse cursor flickers and firefox becomes very unresponsive. Any flash testing site etc do not work. I can use 3rd party plugins for flash and they work fine.... I have also just updated my nvidia drivers and still no difference.
AliceWyman
  • Moderator
229 solutions 2491 answers

werdy666 said

I have the exact same problem Using Win 7, Firefox 35.01 and flash 16.0.0.296 <snip>

To werdy666: Please ask a new question since this thread is for helping piniella and your issue may be different. See Forum rules and guidelines and Get community support. When you ask your question, post it using Firefox and use the "Share Data" button, so that we can see details about your setup.

''werdy666 [[#answer-684315|said]]'' <blockquote> I have the exact same problem Using Win 7, Firefox 35.01 and flash 16.0.0.296 <snip> </blockquote> '''To werdy666:''' Please ask a new question since this thread is for helping piniella and your issue may be different. See [[Forum rules and guidelines]] and [[Get community support]]. When you ask your question, post it using Firefox and use the "Share Data" button, so that we can see details about your setup.

Question owner

Alice,

The problem is with Firefox & Adobe Flash Player. The Player works fine when I use Internet Explorer 11 or Chrome. The Player also doesn't start (All I see is a white rectangle) so I can't choose to deselect Hardware Acceleration.

Steve Jandreau

AliceWyman said

P.S. I see that, in addition to the Nielsen NetSight extension, you also have the "Nielsen FirefoxTracker Plug-in" installed. This might be contributing to your problem so disable the plugin as well as the extension. This software can cause Firefox problems - see /en-US/questions/1036378#answer-664933
Alice, The problem is with Firefox & Adobe Flash Player. The Player works fine when I use Internet Explorer 11 or Chrome. The Player also doesn't start (All I see is a white rectangle) so I can't choose to deselect Hardware Acceleration. Steve Jandreau ''AliceWyman [[#answer-684290|said]]'' <blockquote> P.S. I see that, in addition to the Nielsen NetSight extension, you also have the "Nielsen FirefoxTracker Plug-in" installed. This might be contributing to your problem so disable the plugin as well as the extension. This software can cause Firefox problems - see [/en-US/questions/1036378#answer-664933] </blockquote>

Question owner

Wendy,

Which 3rd part plug-ins do you use?

Steve Jandreau

werdy666 said

I have the exact same problem Using Win 7, Firefox 35.01 and flash 16.0.0.296 Been for afew weeks now. Had to revert to an old version of flash player but now since firefox keeps warning me that the old one needs updating have tried it again and it does exactly as pinella describes Loading youtube and the spot where the video would display is white, the mouse cursor flickers and firefox becomes very unresponsive. Any flash testing site etc do not work. I can use 3rd party plugins for flash and they work fine.... I have also just updated my nvidia drivers and still no difference.
Wendy, Which 3rd part plug-ins do you use? Steve Jandreau ''werdy666 [[#answer-684315|said]]'' <blockquote> I have the exact same problem Using Win 7, Firefox 35.01 and flash 16.0.0.296 Been for afew weeks now. Had to revert to an old version of flash player but now since firefox keeps warning me that the old one needs updating have tried it again and it does exactly as pinella describes Loading youtube and the spot where the video would display is white, the mouse cursor flickers and firefox becomes very unresponsive. Any flash testing site etc do not work. I can use 3rd party plugins for flash and they work fine.... I have also just updated my nvidia drivers and still no difference. </blockquote>

Question owner

UPDATE: I just downloaded the Flash Player again and (drum roll) it doesn't crash FF. Of course, it doesn't play the video but this is still a big improvement. I could also turn off "hardware acceleration" but that didn't help.

Steve J

piniella said

I am using Firefox 35.0.1 and I have installed Shockwave Flash 16.0.0.296. As soon as Flash starts, Firefox freezes and unfreezes until it can't be used at all. I have tried uninstalling and reinstalling the flash player and I have also used Firefox's Refresh option. This problem started a couple of days ago & I don't know what else I can do.
'''UPDATE:''' I just downloaded the Flash Player again and (drum roll) it doesn't crash FF. Of course, it doesn't play the video but this is still a big improvement. I could also turn off "hardware acceleration" but that didn't help. Steve J ''piniella [[#question-1043743|said]]'' <blockquote> I am using Firefox 35.0.1 and I have installed Shockwave Flash 16.0.0.296. As soon as Flash starts, Firefox freezes and unfreezes until it can't be used at all. I have tried uninstalling and reinstalling the flash player and I have also used Firefox's Refresh option. This problem started a couple of days ago & I don't know what else I can do. </blockquote>

Chosen Solution

UPDATE 2: Now the Flash Player does work on some sites & when it doesn't work, it doesn't freeze FF. I did uninstall Opera before this so maybe that software had something to do with the problem?

'''UPDATE 2:''' Now the Flash Player does work on some sites & when it doesn't work, it doesn't freeze FF. I did uninstall Opera before this so maybe that software had something to do with the problem?
AliceWyman
  • Moderator
229 solutions 2491 answers

piniella said

UPDATE 2: Now the Flash Player does work on some sites & when it doesn't work, it doesn't freeze FF.

Sounds like the problem is essentially solved by reinstalling Flash Player. "When it doesn't work" ... could mean lots of things.

By the way, did you ever try disabling the Nielsen NetSight extension and the "Nielsen FirefoxTracker Plug-in"?

I did uninstall Opera before this so maybe that software had something to do with the problem?

I wouldn't think so.

''piniella [[#answer-684676|said]]'' <blockquote> '''UPDATE 2:''' Now the Flash Player does work on some sites & when it doesn't work, it doesn't freeze FF. </blockquote> Sounds like the problem is essentially solved by reinstalling Flash Player. "When it doesn't work" ... could mean lots of things. By the way, did you ever try disabling the Nielsen NetSight extension and the "Nielsen FirefoxTracker Plug-in"? <blockquote> I did uninstall Opera before this so maybe that software had something to do with the problem? </blockquote> I wouldn't think so.

Question owner

AliceWyman said

piniella said
UPDATE 2: Now the Flash Player does work on some sites & when it doesn't work, it doesn't freeze FF.

Sounds like the problem is essentially solved by reinstalling Flash Player. "When it doesn't work" ... could mean lots of things.

By the way, did you ever try disabling the Nielsen NetSight extension and the "Nielsen FirefoxTracker Plug-in"?

I did uninstall Opera before this so maybe that software had something to do with the problem?

I wouldn't think so.

I didn't explicitly do that although previously I tried a Refresh of FF

''AliceWyman [[#answer-684696|said]]'' <blockquote> ''piniella [[#answer-684676|said]]'' <blockquote> '''UPDATE 2:''' Now the Flash Player does work on some sites & when it doesn't work, it doesn't freeze FF. </blockquote> Sounds like the problem is essentially solved by reinstalling Flash Player. "When it doesn't work" ... could mean lots of things. By the way, did you ever try disabling the Nielsen NetSight extension and the "Nielsen FirefoxTracker Plug-in"? <blockquote> I did uninstall Opera before this so maybe that software had something to do with the problem? </blockquote> I wouldn't think so. </blockquote> I didn't explicitly do that although previously I tried a Refresh of FF