X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why won't images load in Bing with Firefox 22.0?

Posted

Ever since upgrading to Firefox 22.0 images on Bing will not load. Images on Google work fine. Images on Bing work fine in IE. I have tried all the solutions I've come across re: images not loading and it does not fix the problem with FF22.0 and Bing.

Chosen solution

You're welcome.

You can enable the Flash plugin as that plugin is used on a lot of web pages.

Firefox will notify you if a plugin is needed that is currently disabled, so you usually do not need to enable all other plugins.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • Intel web components updater - Installs and updates the Intel web components
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • Picasa plugin
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0

More Information

Waka_Flocka_Flame
  • Top 25 Contributor
529 solutions 5045 answers

Hello,

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

Thank you.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Do any of of those images show in "Tools > Page Info > Media"?

Clear the cache and the cookies from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

Question owner

Waka-Flocka: I did this previously, but did it again at your suggestion. Nothing changed.

cor-el: when I checked individual cookies:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

several Bing links were there and I cleared them. Now I get "Trending Image searches" but not the images of my search terms.

Any other suggestions? Thank you.

Question owner

I also cleared the cache

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"
Waka_Flocka_Flame
  • Top 25 Contributor
529 solutions 5045 answers

Hello,

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information such as bookmarks and history. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

Thank you.

Question owner

Well, I'm not ready to have to reset my fonts, colors, and whatever else I'll lose so I think I will hold off on trying this until I get fed up enough with Bing images not working. I wish Mozilla would work out kinks before rolling out endless updates. I haven't been completely happy with FF since 3.6. :( Also if they are gearing things toward tablets, it will just case more and more problems for us old timer desktop and laptop users.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

You haven't told us how missing images show in "Tools > Page Info > Media" in cases when they are missing.


You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

Question owner

Oh!! In "Tools>Page Info>Media" I can click on each "image" link and see individual photos. Does that tell you anything?

Will try the "Forget About This Site" if there is no other solution. Thank you so much!

Question owner

I just discovered, if I scroll way down on the (blank) Bing "results" page, there are tiny little thumbnail images titled "related topics" in a single column down the left side of the page.

Question owner

Also, did the "Forget About This Site" thing in history, but only get an option for "Today" and "Yesterday." Right clicked on all the Bing entries and clicked "Forget About This Site." No change.

Waka_Flocka_Flame
  • Top 25 Contributor
529 solutions 5045 answers

make a new profile then test it

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Helpful Reply

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.

You can delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default value.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)

Helpful Reply

When I started in "Safe Mode" Bing images appear.

So next I:

Turned off hardware acceleration. No change.

Was already running default theme.

Disabled all Plugins - No change

Disabled all Extensions - CHANGE!!

Now imagines are showing in Bing.

You are brilliant!! It turned out to be HTTPS-Everywhere 3.2.3 not allowing Bing to show images. Wow! Thank you so much.

I have no idea if you can help with this, but is it possible for you to tell me if I need all these Plugins? I don't even know what some of them are or how they got there:

3.0.72.0 (is there 2 times)

Google Update 1.3.21.149

RealDownloader Plugin 1.3.2.28

RealNetworks RealDownloader Chrome Background Exte 1.3.2.28

RealNetworks RealDownloader HTML5VideoShimPlugin 1.3.2.28

RealPlayer Download Plugin 16.0.2.32

RealPlayer G2LiveConnect-Enabled Plug-In 16.0.2.32

Shockwave Flash 11.7.700.224

Windows Live Photo Gallery 15.4.3555.308


At the moment they are all disabled. Will I get notification that such and such Plugin is needed to view this?

You guys rock. I never expected such prompt and helpful info. Thanks a million!!!

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Chosen Solution

You're welcome.

You can enable the Flash plugin as that plugin is used on a lot of web pages.

Firefox will notify you if a plugin is needed that is currently disabled, so you usually do not need to enable all other plugins.

JoeZyzyx 0 solutions 6 answers

I discovered if you remove the add-on that gave the BING virus to you, it goes away too. If you know the add-on, also do "about:config" on a page and find what's left of it in there and for each line do right clk and "reset" which will clear it's value box and FF will remove the line, which you can check by refresh of the "about:config" page. It will keep you from the nuclear option of a doing a RESET on FF, keep the extensions and add-ons you already have that are OK. I got my infection from Elite Screen Capture version 2.0.0.2 which does run on FF 22, but not worth those full page BING <iframe> inserts popping up constantly.