X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

when I call a file in firefox the address bar inserts a backslash (\) in fron of the file name and it will not load

Posted

When I call up some files in firefox a backslash is inserted when it loads (http://razorbackpark.com/%5Chole17.htm). Consequently it will not load. If I manually enter the file in the address bar, it loads fine. How do I correct this behavior?

Chosen solution

Hi LTCreations, glad to hear that worked. It seems to clear some cobwebs that can't be cleared through the other menu items, but I haven't researched the exact difference.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Next Generation Java Plug-in 10.15.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • Google Update
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Plug-in for detecting Nero Kwik Media.
  • Dragon NaturallySpeaking Rich Internet Application Support - Plugin
  • Coupons, Inc. Coupon Printer Plugin
  • Coupons, Inc. Coupon Printer DLL
  • GEPlugin
  • 5.1.10411.0
  • Windows Activation Technologies Plugin for Mozilla
  • HP Product Detection Plugin
  • HP Active Check Plugin

Application

  • Firefox 19.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
  • Support URL: http://support.mozilla.org/1/firefox/19.0/WINNT/en-US/

Extensions

  • Anti-Banner 13.0.1.4250 (anti_banner@kaspersky.com)
  • Dragon NaturallySpeaking Rich Internet Application Support 1.0.0.6 (jid0-lmZNVK7a82O8cufhdfB9dUDfA2w@jetpack)
  • HP Detect 1.0.15.0 ({ab91efd4-6975-4081-8552-1b3922ed79e2})
  • LastPass 2.0.20 (support@lastpass.com)
  • Troubleshooter 1.0a (troubleshooter@mozilla.org)
  • VMware OpsCloud Assistant 1.21.1 ({A4C6E7E1-7258-4B89-8B41-AD77CE839BC2})
  • Complitly - Speed up your search with your personal search suggestions tool 1.1 ({33e0daa6-3af3-d8b5-6752-10e949c61516}) (Inactive)
  • Content Blocker 13.0.1.4250 (content_blocker@kaspersky.com) (Inactive)
  • Default Manager 2.2 ({3252b9ae-c69a-4eaf-9502-dc9c1f6c009e}) (Inactive)
  • Freecorder Toolbar 5.0.0.0 ({70dd86e8-b5bc-4e4a-9d5c-b6234c24323c}) (Inactive)
  • Freecorder YouTube Download Wizard 1.1.10 (ytvdw@pgport.com) (Inactive)
  • Funmoods.com 1.5.0 (ffxtlbr@funmoods.com) (Inactive)
  • Kaspersky URL Advisor 13.0.1.4250 (url_advisor@kaspersky.com) (Inactive)
  • Safe Money 13.0.1.4250 (online_banking@kaspersky.com) (Inactive)
  • Search Helper Extension 1.0 ({27182e60-b5f3-411c-b545-b44205977502}) (Inactive)
  • Virtual Keyboard 13.0.1.4250 (virtual_keyboard@kaspersky.com) (Inactive)
  • WinZipBar Community Toolbar 3.18.0.7 ({50fafaf0-70a9-419d-a109-fa4b4ffd4e37}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Radeon HD 3200 Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x9610
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: BGR ClearType Level: 100 Enhanced Contrast: 400
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.1.7601.17789
  • driverDate: 4-19-2011
  • driverDate2:
  • driverVersion: 8.850.0.0
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d', u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Radeon HD 3200 Graphics)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.search.suggest.enabled: False
  • browser.startup.homepage: http://goodshepherdnwa.org/wp-admin/
  • browser.startup.homepage_override.buildID: 20130215130331
  • browser.startup.homepage_override.mstone: 19.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 19.0
  • font.internaluseonly.changed: True
  • general.useragent.extra.brc: BRI/1
  • gfx.blacklist.suggested-driver-version: 257.21
  • gfx.direct3d.checkDX10: False
  • gfx.direct3d.prefer_10_1: False
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1361989235
  • places.history.expiration.transient_current_max_pages: 104858
  • places.history.expiration.transient_optimal_database_size: 163351264
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.cpd.cookies: False
  • privacy.cpd.siteSettings: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False

Misc

  • User JS: Yes
  • Accessibility: No
patrickmc
  • Administrator
  • Moderator
23 solutions 174 answers

Hello gjmfim99,

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:


  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

jscher2000
  • Top 10 Contributor
2368 solutions 20966 answers

Helpful Reply

Is this your website?

On some websites where the author only tested in IE, the link paths actually are written incorrectly in the HTML code. There might be an add-on to quietly correct these URLs behind the scenes, but otherwise you would have to fix them on a case-by-case basis as you are doing now.


Edit: On the hole pages, they are written with a backslash:

<option value="\hole17.htm"> View of Seventeenth Hole</option>

Modified by jscher2000

Question owner

I took the backslash out of file and it worked in that file. When I go to a file from the original file, some of the goto filenames work and some don't. The ones that don't show the \ in the address bar even though it is not in the code of that file.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Try to clear the cache:

  • Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

Reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Press and hold Shift and left-click the Reload button.
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (MAC)

Question owner

That did not help..Interesting that it totally works in IE9. There has to be something unique with Firefox.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Can you post a link to a not working page?

Question owner

This page works: http://razorbackpark.com/layout.htm

This page partially works. If you click on different hole views in the box, some work and some don't. http://razorbackpark.com/hole4.htm

jscher2000
  • Top 10 Contributor
2368 solutions 20966 answers

IE automatically flips a backslash so it works as a forward slash; Firefox does not do that.

On the hole3.htm page, there is an error in the script in the drop-down control:

<select name="layout" size="1" id="layout" style="font-size: 11px; font-family: Arial" 
onChange="if(options[selectedIndex].value) window.location.href= (options[selectedIndex].value)>" 

In the above tag, the closing quotation mark is supposed to be before the >, not after it. Including the > inside the closing quotation mark causes a script error.

Note: This is not an exhaustive review of the site, I just happened to notice that one in going through the first few holes.

Modified by jscher2000

Question owner

Still does not work

jscher2000
  • Top 10 Contributor
2368 solutions 20966 answers

Hi gjmfim99, since the problem doesn't affect every page, can you list the URLs of the pages that do not work as designed? Otherwise I can't see the problem.

LTCreations 0 solutions 4 answers

I have a variation to this problem. My server went down last night. I was trying to see what happened and met with an SSL error. I have a dedicated server that has an unsigned (not purchased) SSL and, when logging in to the WHM portion of the server I get the warning about the SSL. I used the following URI to access the site, and was NOT trying to access the WHM: mysite.com/ Notice, there is no http://, no https:// or www before the domain name. I access the site in Firefox as well as every other browser multiple times daily using the exact same URI. I changed nothing, but this morning (and still now) when I tried to access the site, just like anybody else, when typing the first part of the URI the full URI is filled into the address bar and one simply hits the "Enter" key on the keyboard. But every time I use the pre-determined URI, the one I've always used, which is mysite.com/ (specifically uses the forward slash), the site defaults to the https://www.mysite.com/ which does not exist.

I've never used the https:// or SSL for my site. Nothing was changed between yesterday and today. My HostGator server went down, but that was the only thing different. I cleared cache. I cleared history. I cleared the dns cache using a command prompt. I closed the browser several times. I tried to retrain the browser using the full URI http://www.mysite.com

Everything works - UNLESS I add the / at the end. If I allow the site to properly resolve using the URI with NO / and then adding the forward slash "after" the site is resolved, it works. But attempting to get to the site using mysite.com/ takes me to the https://www.mysite.com/ and I'm met with the "Default Website Page" from the dedicated server.

I've had the server in place and been developing the site on the new server for nearly 2 months. So this is not my first rodeo nor the first day after implementing the site.

I spent quite a while on line with HostGator and they could find nothing wrong. They suggested it was an htaccess issue, but that's not even something I considered, although I did look at my extensive htaccess and found nothing that wasn't there yesterday.

No other browser has the problem, but then I only had FF open and attempting to access my site last night.

I'm certain that someone from Mozilla will need to review this and let me know what's happening. I'm at a loss as to what to update, clear, or whatever in order to get FF back on the right track...it's very annoying and I have a ton of work to do on the site...I don't need this speed bump in my already 3 months overdue progress.

Thanks to anybody who can truly help on this.

jscher2000
  • Top 10 Contributor
2368 solutions 20966 answers

Hi LTCreations, I think it's URL bar autofill.

Although you are not seeing the entire URL, if Firefox is proposing the URL inline in the URL bar, that is indicative of autofill, which is distinct from the autosuggest drop-down. Autofill has a strong bias toward using SSL if it appears anywhere in history (perhaps even if it has been erased from history).

To disable it:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste fill and pause while the list is filtered

(3) Double-click browser.urlbar.autoFill to switch its value from true to false.

Past threads from the time of Firefox 14:

LTCreations 0 solutions 4 answers

Thanks, JSCHER2000

That works, but the problem still stumps me. I considered changing "something" in the config, but didn't want to wade through all the possibilities.

I did change it as you suggested, and it works...as long as I'm tying in the address manually because it no longer fills in automatically.

That works if I want to disable what "was" working up until last night.

For me, I'm not into just work around the thing. I want to find out "why" I can use the browser as I have been forever. Now I have to disable the auto fill so that I have to manually type in every address I go to all the time?

I'm a developer and that's just one more thing that is slowing me down.

But I appreciate the suggestion. I just hope that someone from Mozilla will poke their head in here and say, "Oh! You need to just clear out....???...and the world will be right again." I don't know if that's "pie in the sky", but I can hope....

Thanks, though.

jscher2000
  • Top 10 Contributor
2368 solutions 20966 answers

Hi LTCreations, I don't know whether there is an answer as to "why" in the historical threads or bug reports, but you may want to skim through those.

I agree URL bar autofill is more convenient. You could try the "Forget about this site" feature to see whether that purges the mistaken association of your site with HTTPS. Note that this removes all data for the site including bookmarks, history, cookies, cache, and permissions. Note also that when I've done this on an installation with a lot of history it locks up Firefox for 1-2 minutes with plenty of hard drive thrashing. YMMV.

This option is available in two places:

  • Library dialog > History (Ctrl+Shift+h): right-click an entry for the site
  • The about:permissions page: after selecting the site, look for the button on the right side of the page
LTCreations 0 solutions 4 answers

Thanks, JSCHER2000.

I've tried that too....didn't help.

I've deleted the site in history, I've deleted it through permissions, closed the browser, reopened and it goes to the home page (default when launching the browser). But, when I type in city.... and the auto fill completes the URI, which is correct as I can see it written in the address bar, then I hit the enter key and it defaults to the https domain.

I only started "re-using" FF a few days ago. I've been married to Chrome for years, but heard that FF had made some breakthroughs with speed (and I would say that while it was working it was definitely better than Chrome) and switched to FF. So I have no problem in deleting the history or cookies...not that it's helping though.

I use my computer enough that what may sound petty with this issue is forcing me to return to Chrome. With as much time as I spend on the computer, my browser just has to work 100% - no work arounds or features turned off that I use constantly.

Can you think of anything else that may work? "Somewhere" in the browser, or in the settings, or perhaps in the files kept on the hard drive there is ONE that needs to be deleted. I've gone through all the files that I can find in "Profile", but nothing looks remotely likely as something that would hold the answer. I was even willing to delete everything dated 07/19/2013 with a time after midnight through 03:00. But the only thing I found with that time and date was my "Bitdefender" files - my anti virus. And, of course, I'm willing to blame this on the anti virus files that are being stored. But I have no clue which may deal with the issue and those that would stop the software from working if I blindly deleted them.

Sigh....back to Chrome until I can get a definitive answer on a fix.

Thanks again.

LTCreations 0 solutions 4 answers

OH! Sorry! My bad! I didn't take it far enough! You're right. I needed to tell FF to "Forget About This Site". I saw the button the first time but figured deleting the cookies was the same.

I bow to you. That worked. FF forgot the site, I went there using any method I wanted in the URI and it works now.

Clearly I just didn't follow the full instructions you laid out. Thank you. I can return now to enjoy FF and work normally.

jscher2000
  • Top 10 Contributor
2368 solutions 20966 answers

Chosen Solution

Hi LTCreations, glad to hear that worked. It seems to clear some cobwebs that can't be cleared through the other menu items, but I haven't researched the exact difference.