X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

redirecting to https

Posted

Our company website is http://www.workday.com/ when someone in the office types in just workday.com (no http or www) the browser redirects users to https://www.workday.com/. Our product guys told us that this is a bug in 15 that happens if we have a bookmark that points to https it will redirect or use that instead of resolving the url correctly.

Chosen solution

In Firefox 14, the autoFill feature was turned on. If you have ever used the HTTPS protocol for a site, or perhaps based on a bookmark, autoFill prefers HTTPS. This doesn't work well for all sites.

You can disable autoFill in your Firefox, but for your site visitors, the solution may involve a redirect or other approach. These threads have more information:


Edit: Actually, your site seems to be perfectly fine with this behavior. Is it creating problems on your end?

Read this answer in context 1

Additional System Details

This happened

Every time Firefox opened

This started when...

Firefox 15.

Installed Plug-ins

  • Next Generation Java Plug-in 1.6.0_35 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • ActiveTouch General Plugin Container Version 105
  • Pokki Download Helper
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.2"
  • Google Update
  • Shockwave Flash 11.2 r202
  • VLC media player Web Plugin 2.0.2
  • Picasa plugin
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.4.634
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1

More Information

typing in workday.com in the address bar turns our url into HTTPS.

ScottPlunkett 0 solutions 2 answers

Helpful Reply

Hello nwestwind,

Are you asking for assistance on this matter or would you like this to be submitted as a bug report to the development team?

Scott

Helpful Reply

Ah, dang it, probably a dev team question!

Question owner

Unless there is a solution we can implement? Or we have to delete any bookmark pointing to our site? I still don't know if that's the issue.

ScottPlunkett 0 solutions 2 answers

Hello nwestwind,

I don't believe this is a bug, and is probably meant to be like that, I was able to reproduce this same outcome, it is of course going to load your bookmarks every time, so the easiest way to not have it redirect to https:// protocol would be to change https:// to http:// in your bookmarks or delete it altogether.

Scott

jscher2000
  • Top 10 Contributor
2375 solutions 21032 answers

Chosen Solution

In Firefox 14, the autoFill feature was turned on. If you have ever used the HTTPS protocol for a site, or perhaps based on a bookmark, autoFill prefers HTTPS. This doesn't work well for all sites.

You can disable autoFill in your Firefox, but for your site visitors, the solution may involve a redirect or other approach. These threads have more information:


Edit: Actually, your site seems to be perfectly fine with this behavior. Is it creating problems on your end?

Modified by jscher2000

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Try to set the Boolean pref browser.urlbar.autoFill to false on the about:config page.

See "Prevent Firefox from automatically completing URLs":

Question owner

I am reading up on the other thread. Thanks for all your help and suggestions!

Thank you!