Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Update to Firefox 19 - Now Text is Hard to Read


I just updated to Firefox 19 and now, sporadically, text has become difficult to read. It's noticible in emails, on Facebook, etc. It corrects itself if I click on the start menu or on another area of the page but the text starts out as very jumbled and hard to interpret - unclear, if you will.

This is brand new with Firefox 19.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Google Talk Plugin Video Accelerator version:
  • Version
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • Next Generation Java Plug-in 10.13.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.3"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • GEPlugin
  • 5.1.10411.0
  • CouponNetwork Coupon Activator
  • AmazonMP3DownloaderPlugin 1.0.15
  • Coupons, Inc. Coupon Printer Plugin
  • np-mswmp
  • Office Plugin for Netscape Navigator


  • Firefox 19.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
  • Support URL: http://support.mozilla.org/1/firefox/19.0/WINNT/en-US/


  • Navigational Sounds 1.2.3 ({d84a846d-f7cb-4187-a408-b171020e8940})
  • The Camelizer 1.6 (izer@camelcamelcamel.com)
  • Troubleshooter 1.0a (troubleshooter@mozilla.org)
  • Unfriend Finder 42.220 (firefox@unfriendfinder.com)
  • Garmin Communicator 4.0.4 ({195A3098-0BD5-4e90-AE22-BA1C540AFD1E}) (Inactive)


  • incrementalGCEnabled: True


  • adapterDescription: ATI Radeon HD 4600 Series
  • adapterDescription2:
  • adapterDeviceID: 0x9490
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 300
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 4-19-2011
  • driverDate2:
  • driverVersion: 8.850.0.0
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d', u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Radeon HD 4600 Series)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: my.yahoo.com
  • browser.startup.homepage_override.buildID: 20130215130331
  • browser.startup.homepage_override.mstone: 19.0
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 19.0
  • font.name.serif.x-western: Arial
  • gfx.direct3d.prefer_10_1: True
  • keyword.URL: http://www.google.com/search?sourceid=navclient&hl=en&q=
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1361921239
  • places.history.expiration.transient_current_max_pages: 104858
  • places.history.expiration.transient_optimal_database_size: 167772160
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.cpd.offlineApps: True
  • privacy.cpd.siteSettings: True
  • privacy.popups.showBrowserMessage: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False


  • User JS: No
  • Accessibility: No
Tyler Downer
  • Top 25 Contributor
  • Administrator
  • Moderator
1166 solutions 6653 answers

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

Question owner

I completed the reset that Tylerdowner suggested above. To no avail. Text is still unclear.

Question owner

This image show what the text looks like.

Modified by Chipotle54

mozdk 0 solutions 1 answers

For me, the text rendering started being ugly today. Here is a screenshot of the result, with ClearType disabled (I initially though it was related to ClearType).

The OS is Windows 7 and the graphics card is a Radeon HD 4870 with recent drivers (november 2012).

Question owner

It looks like they're aware of it but they can't fix it fast enough for me. I'll be using other browsers in the mean time.


  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

Try to disable hardware acceleration in Firefox.

Question owner

Does disabling hardware acceleration work? I removed the Windows Platform update and IE10 in order to make it work. I'd prefer to put them back on if disabling hardware acceleration is a viable solution.

Rasputin26 0 solutions 1 answers

I am having the same exact text issue with 19.0

Disabling the hardware acceleration worked for me. They need to fix this issue so I can continue to use the resources of my computer instead of having to wait for the software to run everything. For people that play browser games with a lot of resources being used, disabling will lag the game and can cause potential problems. I will be using chrome and opera until they fix this broken browser.

dkb100 0 solutions 1 answers

I have this problem. It gets worse if I go to mthe bottom of the page and then scroll up again. If I then highlight the text it corrects itself. Does not happen with IE or Chrome on same computer.

Marficzech 0 solutions 3 answers

Helpful Reply

I have the same problem (FF 19), but if you type "about:config" on adres bar and find "gfx.content.azure.enabled", then set this as "false" (duble click), then all text looks fine too.

Question owner

Marficzech's solution seems to work as well. I have re-enabled hardware acceleration and will monitor for any changes.

Warbler 0 solutions 3 answers

Back to 18 for me. I don't want to disable acceleration. Glad it isn't just me.

Helpful Reply

Warbler, try Marficzech's solution: type about:config on address bar and find gfx.content.azure.enabled, then set this as false (duble click), then all text looks fine. No need to disable acceleration.