X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Can't enable javascript- No plugins Icon appears to click on adressbar

Posted

I have this problem with win7/firefox 18, java is "enabled" at every turn in my settings for win and firefox, but every site I want to use with java gives "javascript not enabled" and there Is NO red icon thing as you describe on my address bar- where is it?? I am using firefox 18, but have never seen the red lego looking plugin icon on the addressbar you mention in your how to fix javascript article- turning off javascript is making it impossible to buy things and to download on several sites!

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Google Update
  • VLC media player Web Plugin 2.0.2
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.8.638
  • Foxit Reader Plug-In For Firefox and Netscape
  • Winamp Application Detector
  • DivX Plus Web Player version 2.2.0.52
  • DivX VOD Helper Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Application Basics
Name
Firefox
Version
18.0.1
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
DivX Plus Web Player HTML5 <video>
2.1.2.145
true
{23fcfd51-4958-4f00-80a3-ae97e717ed8b}
StumbleUpon
4.16
true
{AE93811A-5C9A-4d34-8462-F7B864FC4696}
Adblock Plus Pop-up Addon
0.5
false
adblockpopups@jessehakanen.net
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
358400
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size.use_old_max
false
browser.cache.disk.smart_size_cached_value
358400
browser.places.smartBookmarksVersion
4
browser.startup.homepage
http://www.google.com/
browser.startup.homepage_override.buildID
20130116073211
browser.startup.homepage_override.mstone
18.0.1
dom.mozApps.used
true
extensions.lastAppVersion
18.0.1
gfx.direct3d.prefer_10_1
true
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1358617342
places.history.expiration.transient_current_max_pages
104858
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
NVIDIA GeForce GTX 560 Ti
Adapter Drivers
nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Adapter RAM
1024
Device ID
0x1200
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17789)
Driver Date
12-29-2012
Driver Version
9.18.13.1090
GPU #2 Active
false
GPU Accelerated Windows
1/1 Direct3D 10
Vendor ID
0x10de
WebGL Renderer
Google Inc. -- ANGLE (NVIDIA GeForce GTX 560 Ti )
AzureCanvasBackend
direct2d
AzureContentBackend
direct2d
AzureFallbackCanvasBackend
cairo
JavaScript
Incremental GC
true
Accessibility
Activated
false
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.4
4.9.4
NSS
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSSMIME
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSSSL
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSUTIL
3.14.1.0
3.14.1.0

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

hello, javascript is something different than java. please make sure that it is enabled in firefox > tools > options > content & not blocked by any addon (like noscript, etc.)

JavaScript settings and preferences for interactive web pages

Question owner

Yes, I am aware that javascript and java are not the same thing, I Have in fact checked and rechecked the "enable javascript" button a million times - it is "enabled", I do not use no-script, and have tried it with ad-blocker disabled and it did not help.

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

ok, in this case please try to reset firefox & see if this is making a difference:

Reset Firefox – easily fix most problems

manifestjoy 0 solutions 3 answers

I have the same problem - For me it happens on secure sites. The lock hides the java plugin icon. I can see the java red plugin icon just fine on pages that are not https:/encrypted.

Since the person above is shopping and downloading, I suspect that he is also trying to access features of a encrypted sites.

It's quite frustrating.

DianeFM 0 solutions 2 answers

SOLUTION--- Bizarrely, apparently Java was not installed at all on my PC. (I am running Windows 8 on a new HP Pavilon g7.)

  1. Tried re-setting Firefox, it didn't change anything.
  2. Went to Java.com, it suggested verifying the version of Java I was running but the verification process didn't work.
  3. I gave up trying to verify and just downloaded the current version of Java, restarted, went back to Java.com, and was able to verify the version of Java I am now running (the current one).
  4. Went back to the site that previously told me Java was not enabled, and this time it instead asked if I wanted to run Java, I walked through clicking yes/next a couple times, and then the video I wanted to watch ran, no problem.
  5. I closed out of that site, then went back, and this time videos run without
  6. I still show no red plugin icon on my browser address bar (on any site) but it apparently doesn't matter.

I hope this works for you!

Modified by DianeFM

DianeFM 0 solutions 2 answers

BTW--anomalon, your question repeatedly uses the terms "java" and "javascript" as if they are interchangeable; that's why madperson brought up that they are different things. I believe that the problem you are asking about is a java problem. If so, you will have better luck solving it if you omit the word "javascript" in your searches and questions.