X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Font is messed up on Firefox 17.0

Posted

Just updated to FF17.0 and the fonts look awful, something like when the ClearType is enabled in Windows. I have ClearType disabled cause I hate the look of the fonts with it enabled, and now Firefox looks like it's all over it. Font is like bolded. What happened? Can I disable it somewhere in Firefox?

Chosen solution

Hey guys! Thanks to everyone who helped us in troubleshooting this. We are fairly certain it's an azure problem. There is a patch in the works and setting gfx.content.azure.enabled = False seems to work in the meantime. I don't know if the patch will be part of a chemspill or wait until 18. Thanks for your help and patience.

Happy Thanksgiving!

Read this answer in context 17

Additional System Details

This happened

Every time Firefox opened

This started when...

I updated to Firefox 17.0

Installed Plug-ins

  • 2.1.2
  • Next Generation Java Plug-in 10.7.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.2 r202
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.7.637
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • 5.1.10411.0
  • 0.70.4
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0

More Information

Informacje o aplikacji
Nazwa
Firefox
Wersja
17.0
Identyfikator programu
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Folder profilu
Pokaż folder
Włączone wtyczki
about:plugins
Konfiguracja kompilacji
about:buildconfig
Zgłoszenia awarii
about:crashes
Zużycie pamięci
about:memory
Rozszerzenia
Nazwa
Wersja
Włączone
ID
Adblock Plus
2.1.2
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
British English Dictionary
1.19.1
true
en-GB@dictionaries.addons.mozilla.org
ColorfulTabs
17.1
true
{0545b830-f0aa-4d7e-8820-50a4629a56fe}
Download Statusbar
0.9.10
true
{D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389}
Ważne zmodyfikowane ustawienia
Nazwa
Wartość
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
524288
browser.cache.disk.smart_size.enabled
false
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
1048576
browser.display.background_color
#C0C0C0
browser.display.use_system_colors
true
browser.history_expire_days.mirror
2
browser.history_expire_days_min
2
browser.places.importBookmarksHTML
false
browser.places.importDefaults
false
browser.places.leftPaneFolderId
-1
browser.places.migratePostDataAnnotations
false
browser.places.smartBookmarksVersion
4
browser.places.updateRecentTagsUri
false
browser.privatebrowsing.dont_prompt_on_enter
true
browser.search.useDBForOrder
true
browser.sessionstore.restore_on_demand
false
browser.startup.homepage
http://www.onet.pl/
browser.startup.homepage_override.buildID
20121119183901
browser.startup.homepage_override.mstone
17.0
browser.tabs.loadInBackground
false
extensions.lastAppVersion
17.0
font.internaluseonly.changed
false
gfx.direct3d.prefer_10_1
true
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1353270609
places.history.expiration.transient_current_max_pages
104858
places.history.expiration.transient_optimal_database_size
167772160
places.last_vacuum
1296324654
plugin.disable_full_page_plugin_for_types
print.print_printer
Microsoft XPS Document Writer
print.printer_HP_LaserJet_1022.print_bgcolor
false
print.printer_HP_LaserJet_1022.print_bgimages
false
print.printer_HP_LaserJet_1022.print_command
print.printer_HP_LaserJet_1022.print_downloadfonts
false
print.printer_HP_LaserJet_1022.print_edge_bottom
0
print.printer_HP_LaserJet_1022.print_edge_left
0
print.printer_HP_LaserJet_1022.print_edge_right
0
print.printer_HP_LaserJet_1022.print_edge_top
0
print.printer_HP_LaserJet_1022.print_evenpages
true
print.printer_HP_LaserJet_1022.print_footercenter
print.printer_HP_LaserJet_1022.print_footerleft
&PT
print.printer_HP_LaserJet_1022.print_footerright
&D
print.printer_HP_LaserJet_1022.print_headercenter
print.printer_HP_LaserJet_1022.print_headerleft
&T
print.printer_HP_LaserJet_1022.print_headerright
&U
print.printer_HP_LaserJet_1022.print_in_color
true
print.printer_HP_LaserJet_1022.print_margin_bottom
0.5
print.printer_HP_LaserJet_1022.print_margin_left
0.5
print.printer_HP_LaserJet_1022.print_margin_right
0.5
print.printer_HP_LaserJet_1022.print_margin_top
0.5
print.printer_HP_LaserJet_1022.print_oddpages
true
print.printer_HP_LaserJet_1022.print_orientation
0
print.printer_HP_LaserJet_1022.print_pagedelay
500
print.printer_HP_LaserJet_1022.print_paper_data
9
print.printer_HP_LaserJet_1022.print_paper_height
11,00
print.printer_HP_LaserJet_1022.print_paper_size_type
0
print.printer_HP_LaserJet_1022.print_paper_size_unit
1
print.printer_HP_LaserJet_1022.print_paper_width
8,50
print.printer_HP_LaserJet_1022.print_reversed
false
print.printer_HP_LaserJet_1022.print_scaling
0,50
print.printer_HP_LaserJet_1022.print_shrink_to_fit
true
print.printer_HP_LaserJet_1022.print_to_file
false
print.printer_HP_LaserJet_1022.print_unwriteable_margin_bottom
0
print.printer_HP_LaserJet_1022.print_unwriteable_margin_left
0
print.printer_HP_LaserJet_1022.print_unwriteable_margin_right
0
print.printer_HP_LaserJet_1022.print_unwriteable_margin_top
0
print.printer_Microsoft_XPS_Document_Writer.print_bgcolor
false
print.printer_Microsoft_XPS_Document_Writer.print_bgimages
false
print.printer_Microsoft_XPS_Document_Writer.print_command
print.printer_Microsoft_XPS_Document_Writer.print_downloadfonts
false
print.printer_Microsoft_XPS_Document_Writer.print_edge_bottom
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_left
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_right
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_top
0
print.printer_Microsoft_XPS_Document_Writer.print_evenpages
true
print.printer_Microsoft_XPS_Document_Writer.print_footercenter
print.printer_Microsoft_XPS_Document_Writer.print_footerleft
&PT
print.printer_Microsoft_XPS_Document_Writer.print_footerright
&D
print.printer_Microsoft_XPS_Document_Writer.print_headercenter
print.printer_Microsoft_XPS_Document_Writer.print_headerleft
&T
print.printer_Microsoft_XPS_Document_Writer.print_headerright
&U
print.printer_Microsoft_XPS_Document_Writer.print_in_color
true
print.printer_Microsoft_XPS_Document_Writer.print_margin_bottom
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_left
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_right
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_top
0.5
print.printer_Microsoft_XPS_Document_Writer.print_oddpages
true
print.printer_Microsoft_XPS_Document_Writer.print_orientation
0
print.printer_Microsoft_XPS_Document_Writer.print_page_delay
50
print.printer_Microsoft_XPS_Document_Writer.print_paper_data
9
print.printer_Microsoft_XPS_Document_Writer.print_paper_height
11,00
print.printer_Microsoft_XPS_Document_Writer.print_paper_size_type
0
print.printer_Microsoft_XPS_Document_Writer.print_paper_size_unit
1
print.printer_Microsoft_XPS_Document_Writer.print_paper_width
8,50
print.printer_Microsoft_XPS_Document_Writer.print_reversed
false
print.printer_Microsoft_XPS_Document_Writer.print_scaling
1,00
print.printer_Microsoft_XPS_Document_Writer.print_shrink_to_fit
true
print.printer_Microsoft_XPS_Document_Writer.print_to_file
false
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_bottom
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_left
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_right
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_top
0
privacy.clearOnShutdown.cookies
false
privacy.clearOnShutdown.downloads
false
privacy.clearOnShutdown.formdata
false
privacy.clearOnShutdown.history
false
privacy.clearOnShutdown.offlineApps
true
privacy.cpd.cookies
false
privacy.cpd.sessions
false
privacy.donottrackheader.enabled
true
privacy.item.downloads
false
privacy.item.formdata
false
privacy.item.history
false
privacy.item.offlineApps
true
privacy.item.sessions
false
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.OCSP.disable_button.managecrl
false
security.disable_button.openCertManager
false
security.disable_button.openDeviceManager
false
security.warn_viewing_mixed
false
security.warn_viewing_mixed.show_once
false
Grafika
Opis adaptera
NVIDIA GeForce GTX 560 Ti
ID dostawcy
0x10de
ID urządzenia
0x1200
RAM adaptera
1023
Sterowniki adaptera
nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Wersja sterownika
9.18.13.697
Data sterownika
10-2-2012
Włączone Direct2D
true
Włączone DirectWrite
true (6.1.7601.17789)
Parametry ClearType
Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50
Renderer WebGL
Google Inc. -- ANGLE (NVIDIA GeForce GTX 560 Ti ) -- OpenGL ES 2.0 (ANGLE 1.0.0.1242)
Okna ze sprzętowym przyspieszeniem grafiki
1/1 Direct3D 10
AzureCanvasBackend
direct2d
AzureFallbackCanvasBackend
cairo
AzureContentBackend
direct2d
JavaScript
Przyrostowy GC
1
Ułatwienia dostępu
Aktywne
0
Zablokuj ułatwienia dostępu
0
Wersje bibliotek
Oczekiwana wersja minimalna
Wersja w użyciu
NSPR
4.9.2
4.9.2
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

jfkthame 0 solutions 4 answers

Violon, forhike: could you post a screenshot of what you're seeing in FF 17.0.1 (with ClearType OFF), please? Does this affect ALL fonts, or only certain ones?

forhike 0 solutions 11 answers

here is two screenshots on a webpage with cleartype off, the other one is with the setting azure.content false. Both is with ff 17.0.1

click on the image and then You have to right click and view image, otherwise you don't see the difference

Modified by forhike

Violon 0 solutions 3 answers

In two first cases, cleartype is enabled in web pages, which is also wrong.

Please, look the uploaded images in full size.

Usually I use cleartype OFF and smooth edges of screen fonts OFF. And normally (with firefox 16 to 3) it looks what you see on the screenshot 2.

Modified by Violon

forhike 0 solutions 11 answers

here is on the ff it self

Modified by forhike

Aeroxima 0 solutions 8 answers

Me too, 17.0.1, ClearType off. Here's how it looks fullscreen with azure on and off (seems to be all fonts).

Aeroxima 0 solutions 8 answers

Sorry, here's the same thing with the default font of Times New Roman rather than Verdana.

forhike 0 solutions 11 answers

On the bug report they say the font bug is fixed but it's not so The only solution is to turn gfx.content.azure.enabled to false again or go back to 16.0.2

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Did you already update to Firefox 17.0.1 that has just been released?

forhike 0 solutions 11 answers

Yes, I took a chance and logged in to Mozillas Ftp server and found it so I grabbed it. I'm quick....:)

Modified by forhike

ecarlson 0 solutions 4 answers

17.0.1 is still having the font problem for me too, so I set gfx.content.azure.enabled = False again, so I'm good until it is really fixed.

Also, it appears that my Windows 7 desktop is the only computer where I experience the problem: My Windows 7 laptop doesn't seem to have the problem (with 17.0), and my XP desktop doesn't have the problem (with 17.0).

matthew_eli 0 solutions 4 answers

Same problem here; installed 17.0.1, problem still persists

jfkthame 0 solutions 4 answers

OK, so it looks to me like there are two issues here, and only one of them is fixed in the 17.0.1 update. Here's what I think is going on, and why some people are reporting it's "fixed", and others "still bad".

There are two separate (but related) Windows options involved here, and these lead to three distinct scenarios: (A) Smooth Edges of Screen Fonts option, found in the System / Advanced Settings / Performance Options panel. (B) ClearType (subpixel antialiasing, which gives colored fringes on the glyphs), which is enabled/disabled using the ClearType Text Tuner (accessed through the Adjust ClearType Text option in the Display control panel).

(1) If you have both Smoothing (A) and ClearType (B) enabled (which is the Windows default), there's no issue; it all works as intended. But some people dislike the result. (Note that the ClearType Text Tuner may be able to improve things, if the default settings aren't good for your graphics system.)

(2) If you have Smoothing (A) enabled but ClearType (B) disabled, you should get text that uses grayscale-only antialiasing, so there's a "smoothing" effect but without the colored fringing that ClearType can give. This configuration was broken in Azure in Firefox 17.0 - it used subpixel rendering, although it shouldn't have - and fixed in 17.0.1. So the people reporting that things are now fixed are the people who have Font Smoothing enabled, but ClearType disabled.

(3) Finally, if you have both (A) and (B) disabled, meaning you want no font smoothing AT ALL, things are still broken. These settings should give completely "un-smoothed" glyphs, with crisp edges (but jagged curves) everywhere. However, this fails badly under Azure, and you actually get poorly subpixel-rendered text. (Looking at the screenshots, it seems to be WORSE than the default where (A) and (B) are both enabled.) And 17.0.1 did not address this problem.

So I believe the people who have turned off both (A) and (B) are the ones reporting that 17.0.1 is still broken.

As far as I can tell, scenario (3) is fixed in Firefox 18 (currently in Beta), so those experiencing this issue might like to try that version (see http://www.mozilla.org/en-US/firefox/beta/) - and please provide feedback, with details of your configuration, if you DO still see problems.

Matt_G
  • Administrator
  • Moderator
380 solutions 1848 answers

Hi guys. I've cloned the original bug so that we can continue to investigate the scenario that's been reported to still be causing the issue. Our QA team has tried to reproduce it and is failing to do so. I'm wondering it may be a hardware issue?

The new bug is 818164. Please do not post to this bug unless you can add clarity or provide more details on how to reproduce. If you are experiencing the issue but do not have any additional information, please add your "me too" vote to this thread.

Andreyka73 0 solutions 5 answers

FF 17.0.1 shows fine fonts now on my computer with any azure setting.

eetups 0 solutions 1 answers

For me, the font issue wasn't tied to version 17 of Firefox - the same (un)smoothing font problem existed even when I tried 16.0.0.2 and the newest 18 beta.

The issue arose when I did a Reset Firefox while using version 17 - after that the fonts in the tabs, address bar, bookmarks and FF dialogs looked screwed up.

I tried the tips offered in this thread (changes in the config), but none of them seemed to work, not even disabling the azure setting. At that point I checked again the Graphics section of the Troubleshooting Information page, and I noticed that both Direct2D enabled and GPU Accelerated Windows showed that they were 'disabled for this driver version'.

I was using AMD Catalyst 12.8 which I then updated to 12.10. After this, I re-enabled Direct2D and set content.azure to false, and lo and behold, the fonts looked legible again.

So in my case, the problem was a combination of old(?) graphics drivers and the azure functionality.

StratMan55 0 solutions 8 answers

Sigh... Same problem here...

And, about:config, changing gfx.direct2d.disabled to true, did NOT resolve the problem.

forhike 0 solutions 11 answers

It's fixed now in FF 18.....at least for me

StratMan55 0 solutions 8 answers

Geeze... Sorry 'bout that!

Was focused on "Font is messed up on Firefox" ~~ Not "17" in the title of this topic.

The problem began when I updated from FF17 to FF18.

Been researching and testing this-n-that for past two days to no avail and truly don't know what to look for to fix the problem that ONLY occurs in FF18, not IE9 both running on a new clean custom installation build of Win7-64.

The problem exists mostly on the curved elements in text characters. It seems as if the vertically straight text element characters are much sharper and crisper. Go figure...

Maybe I should start a new topic or go look for an existing general topic on POOR text font rendering.

Thoughts? Thanks so much.

StratMan55 0 solutions 8 answers

Here are two images: IE9 and FF18.

Take note of the "curved elements" in text characters to see how fuzzy they are in FF18 compared to IE9.

1) Left: Firefox_v18_PoorFontTextRendering_FromStratMan55_20130111__Using-FF18-WithFuzzyProblem.jpg

2) Right: Firefox_v18_PoorFontTextRendering_FromStratMan55_20130111__Using-IE9-NoProblem.jpg

Thanks.

Modified by StratMan55

StratMan55 0 solutions 8 answers

QUOTE: AliceWyman Top 25 Contributor Moderator 123 solutions Posted 11/29/12 6:44 PM: For Windows users, the blurry fonts issue will be fixed in Firefox 17.0.1, which should be released very soon (hopefully, tomorrow). More info here:

http://www.ghacks.net/2012/11/24/firefox-17-0-1-to-fix-blurry-font-issue-in-the-browser/

===========================================

Unfortunately, the problem has resurfaced in FF18. :(

Thoughts? Thanks.