X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Fonts in firefox 4 look blurry like I have ClearType disabled

Posted

I downloaded and installed Firefox 4, but the fonts on every page look edgy and blurry like I have no ClearType enabled. the only suggestion I've found is to disable hardware acceleration. This helps a bit, but is there a way to fix font problem in some other way because I don't want to disable direct2d

Additional System Details

This happened

Every time Firefox opened

This started when...

I downloaded Firefox 4

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • Default Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.2 r153
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60129.0
  • Google Update

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.15) Gecko/20110303 Firefox/3.6.15

More Information

Cheng Wang
  • Administrator
  • Moderator
36 solutions 435 answers

Try the steps at Fonts look blurry Some users report that they have to install the microsoft updates listed (they're not critical so most people don't have them) to get it to work right.

DarkflameX 0 solutions 1 answers

Helpful Reply

Strongly agree with topic author, the text is worse, i noticed instantly.

I have clear type enabled and it makes no difference, turning off hardware acceleration fixes the issue but now i don't get to enjoy the richness of future web content.

IE 9 features hardware acceleration and doesn't have this problem, so why does Firefox 4?

Please refer to my attached images as examples, in my opinion you can clearly see that hardware acceleration enabled causes the text to get worse.

A quick google reveals this issue was revealed during the beta testing stage so why wasn't it addressed and rectified?

As a long term Firefox user, i'm not impressed.

Darkflame

ricopreston 0 solutions 1 answers

Helpful Reply

Sorry, I am the person that accidentally clicked Cww's entry as helpful, it is most definitely not helpful. I can barely read anything on my screen now and no where in those "solutions" did anything make a difference. I have tried them all including upgrading my video drivers. The text was good for about 5 seconds after I started Firefox, then went to what I see now. It's beyond blurry to the point of looking like ghost letters, more shapes than actual words. I can see them if I highlight them, hence how I am writing this. I am going to uninstall Firefox 4, this is useless. I am using an ATI 6970 with the 11.2 drivers if that helps you troubleshoot in any way. Please fix, I don't want to use Chrome, but this is horrible. I've included a print screen of this post.

surferbum 0 solutions 2 answers

deleted.

Modified by surferbum

scrubs 0 solutions 2 answers

i think i have the same problem, but i dont want to use cleartype at all, i cant stand it..

ive tryed with cleartype both on and off and tryed different about:config-settings, no change.. in firefox 3 fonts are clean, not "cleartype clear" (which is actually not clean at all), but really clear.

i dont care about the menus though, but surfing with this is absolutely terrible.. i hate blurred fonts! wont be using firefox 4 until you can turn it off completely

edit: direct link to images, as they are not 100% scale when viewing them here so you dont see the difference.. https://support.mozilla.com/media/uploads/images/2011-03-28-14-51-37-387795.png https://support.mozilla.com/media/uploads/images/2011-03-28-14-51-44-7af73b.png

Modified by scrubs

Mr-Love 0 solutions 9 answers

Disabling hardware acceleration did the trick for me (I'm on Win 7 btw) - just remember that you have to restart Firefox for the change to take place.

See screenshots below - there's a HUGE difference!

With hardware acceleration | Without hardware acceleration

However, since upgrading to Firefox 4 I no longer get the option to save current tabs when I exit (I've tried disabling my few add-ons but problem remains) so I guess it's back to Firefox 3... :(

Modified by Mr-Love

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

You can also look at this extension:

WarmerVlad 0 solutions 2 answers

I HAVE EXACTLY THE SAME PROBLEM!!!!!!!!!!!

IT'S SO STUPID!!!!!!!!!!!!!!!!!!!!!!!!!

WarmerVlad 0 solutions 2 answers

Strongly agree with topic author, the text is worse, i noticed instantly.

slowfox 0 solutions 1 answers

Anti-Aliasing Tuner add-on works for me since I want to keep hardware acceleration for Intel G41 chipset.

See screen shot for my setting.

Note: 1. Default setting won't help. 2. After adjusting, fonts spacing are still a bit mess up.

Hope it gets fix on the next release.

mchel210 0 solutions 1 answers

This worked for me. All I did was download this add on and restarted firefox and it seems to be working now. Fingers crossed it will keep working.