X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Font is messed up on Firefox 17.0

Posted

Just updated to FF17.0 and the fonts look awful, something like when the ClearType is enabled in Windows. I have ClearType disabled cause I hate the look of the fonts with it enabled, and now Firefox looks like it's all over it. Font is like bolded. What happened? Can I disable it somewhere in Firefox?

Chosen solution

Hey guys! Thanks to everyone who helped us in troubleshooting this. We are fairly certain it's an azure problem. There is a patch in the works and setting gfx.content.azure.enabled = False seems to work in the meantime. I don't know if the patch will be part of a chemspill or wait until 18. Thanks for your help and patience.

Happy Thanksgiving!

Read this answer in context 17

Additional System Details

This happened

Every time Firefox opened

This started when...

I updated to Firefox 17.0

Installed Plug-ins

  • 2.1.2
  • Next Generation Java Plug-in 10.7.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.2 r202
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.7.637
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • 5.1.10411.0
  • 0.70.4
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0

More Information

Informacje o aplikacji
Nazwa
Firefox
Wersja
17.0
Identyfikator programu
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Folder profilu
Pokaż folder
Włączone wtyczki
about:plugins
Konfiguracja kompilacji
about:buildconfig
Zgłoszenia awarii
about:crashes
Zużycie pamięci
about:memory
Rozszerzenia
Nazwa
Wersja
Włączone
ID
Adblock Plus
2.1.2
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
British English Dictionary
1.19.1
true
en-GB@dictionaries.addons.mozilla.org
ColorfulTabs
17.1
true
{0545b830-f0aa-4d7e-8820-50a4629a56fe}
Download Statusbar
0.9.10
true
{D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389}
Ważne zmodyfikowane ustawienia
Nazwa
Wartość
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
524288
browser.cache.disk.smart_size.enabled
false
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
1048576
browser.display.background_color
#C0C0C0
browser.display.use_system_colors
true
browser.history_expire_days.mirror
2
browser.history_expire_days_min
2
browser.places.importBookmarksHTML
false
browser.places.importDefaults
false
browser.places.leftPaneFolderId
-1
browser.places.migratePostDataAnnotations
false
browser.places.smartBookmarksVersion
4
browser.places.updateRecentTagsUri
false
browser.privatebrowsing.dont_prompt_on_enter
true
browser.search.useDBForOrder
true
browser.sessionstore.restore_on_demand
false
browser.startup.homepage
http://www.onet.pl/
browser.startup.homepage_override.buildID
20121119183901
browser.startup.homepage_override.mstone
17.0
browser.tabs.loadInBackground
false
extensions.lastAppVersion
17.0
font.internaluseonly.changed
false
gfx.direct3d.prefer_10_1
true
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1353270609
places.history.expiration.transient_current_max_pages
104858
places.history.expiration.transient_optimal_database_size
167772160
places.last_vacuum
1296324654
plugin.disable_full_page_plugin_for_types
print.print_printer
Microsoft XPS Document Writer
print.printer_HP_LaserJet_1022.print_bgcolor
false
print.printer_HP_LaserJet_1022.print_bgimages
false
print.printer_HP_LaserJet_1022.print_command
print.printer_HP_LaserJet_1022.print_downloadfonts
false
print.printer_HP_LaserJet_1022.print_edge_bottom
0
print.printer_HP_LaserJet_1022.print_edge_left
0
print.printer_HP_LaserJet_1022.print_edge_right
0
print.printer_HP_LaserJet_1022.print_edge_top
0
print.printer_HP_LaserJet_1022.print_evenpages
true
print.printer_HP_LaserJet_1022.print_footercenter
print.printer_HP_LaserJet_1022.print_footerleft
&PT
print.printer_HP_LaserJet_1022.print_footerright
&D
print.printer_HP_LaserJet_1022.print_headercenter
print.printer_HP_LaserJet_1022.print_headerleft
&T
print.printer_HP_LaserJet_1022.print_headerright
&U
print.printer_HP_LaserJet_1022.print_in_color
true
print.printer_HP_LaserJet_1022.print_margin_bottom
0.5
print.printer_HP_LaserJet_1022.print_margin_left
0.5
print.printer_HP_LaserJet_1022.print_margin_right
0.5
print.printer_HP_LaserJet_1022.print_margin_top
0.5
print.printer_HP_LaserJet_1022.print_oddpages
true
print.printer_HP_LaserJet_1022.print_orientation
0
print.printer_HP_LaserJet_1022.print_pagedelay
500
print.printer_HP_LaserJet_1022.print_paper_data
9
print.printer_HP_LaserJet_1022.print_paper_height
11,00
print.printer_HP_LaserJet_1022.print_paper_size_type
0
print.printer_HP_LaserJet_1022.print_paper_size_unit
1
print.printer_HP_LaserJet_1022.print_paper_width
8,50
print.printer_HP_LaserJet_1022.print_reversed
false
print.printer_HP_LaserJet_1022.print_scaling
0,50
print.printer_HP_LaserJet_1022.print_shrink_to_fit
true
print.printer_HP_LaserJet_1022.print_to_file
false
print.printer_HP_LaserJet_1022.print_unwriteable_margin_bottom
0
print.printer_HP_LaserJet_1022.print_unwriteable_margin_left
0
print.printer_HP_LaserJet_1022.print_unwriteable_margin_right
0
print.printer_HP_LaserJet_1022.print_unwriteable_margin_top
0
print.printer_Microsoft_XPS_Document_Writer.print_bgcolor
false
print.printer_Microsoft_XPS_Document_Writer.print_bgimages
false
print.printer_Microsoft_XPS_Document_Writer.print_command
print.printer_Microsoft_XPS_Document_Writer.print_downloadfonts
false
print.printer_Microsoft_XPS_Document_Writer.print_edge_bottom
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_left
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_right
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_top
0
print.printer_Microsoft_XPS_Document_Writer.print_evenpages
true
print.printer_Microsoft_XPS_Document_Writer.print_footercenter
print.printer_Microsoft_XPS_Document_Writer.print_footerleft
&PT
print.printer_Microsoft_XPS_Document_Writer.print_footerright
&D
print.printer_Microsoft_XPS_Document_Writer.print_headercenter
print.printer_Microsoft_XPS_Document_Writer.print_headerleft
&T
print.printer_Microsoft_XPS_Document_Writer.print_headerright
&U
print.printer_Microsoft_XPS_Document_Writer.print_in_color
true
print.printer_Microsoft_XPS_Document_Writer.print_margin_bottom
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_left
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_right
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_top
0.5
print.printer_Microsoft_XPS_Document_Writer.print_oddpages
true
print.printer_Microsoft_XPS_Document_Writer.print_orientation
0
print.printer_Microsoft_XPS_Document_Writer.print_page_delay
50
print.printer_Microsoft_XPS_Document_Writer.print_paper_data
9
print.printer_Microsoft_XPS_Document_Writer.print_paper_height
11,00
print.printer_Microsoft_XPS_Document_Writer.print_paper_size_type
0
print.printer_Microsoft_XPS_Document_Writer.print_paper_size_unit
1
print.printer_Microsoft_XPS_Document_Writer.print_paper_width
8,50
print.printer_Microsoft_XPS_Document_Writer.print_reversed
false
print.printer_Microsoft_XPS_Document_Writer.print_scaling
1,00
print.printer_Microsoft_XPS_Document_Writer.print_shrink_to_fit
true
print.printer_Microsoft_XPS_Document_Writer.print_to_file
false
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_bottom
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_left
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_right
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_top
0
privacy.clearOnShutdown.cookies
false
privacy.clearOnShutdown.downloads
false
privacy.clearOnShutdown.formdata
false
privacy.clearOnShutdown.history
false
privacy.clearOnShutdown.offlineApps
true
privacy.cpd.cookies
false
privacy.cpd.sessions
false
privacy.donottrackheader.enabled
true
privacy.item.downloads
false
privacy.item.formdata
false
privacy.item.history
false
privacy.item.offlineApps
true
privacy.item.sessions
false
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.OCSP.disable_button.managecrl
false
security.disable_button.openCertManager
false
security.disable_button.openDeviceManager
false
security.warn_viewing_mixed
false
security.warn_viewing_mixed.show_once
false
Grafika
Opis adaptera
NVIDIA GeForce GTX 560 Ti
ID dostawcy
0x10de
ID urządzenia
0x1200
RAM adaptera
1023
Sterowniki adaptera
nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Wersja sterownika
9.18.13.697
Data sterownika
10-2-2012
Włączone Direct2D
true
Włączone DirectWrite
true (6.1.7601.17789)
Parametry ClearType
Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50
Renderer WebGL
Google Inc. -- ANGLE (NVIDIA GeForce GTX 560 Ti ) -- OpenGL ES 2.0 (ANGLE 1.0.0.1242)
Okna ze sprzętowym przyspieszeniem grafiki
1/1 Direct3D 10
AzureCanvasBackend
direct2d
AzureFallbackCanvasBackend
cairo
AzureContentBackend
direct2d
JavaScript
Przyrostowy GC
1
Ułatwienia dostępu
Aktywne
0
Zablokuj ułatwienia dostępu
0
Wersje bibliotek
Oczekiwana wersja minimalna
Wersja w użyciu
NSPR
4.9.2
4.9.2
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

matthew_eli 0 solutions 4 answers

But in this way you disable the HA. I guess mozzilla should release an update for fix thsi problem

ratsalad 0 solutions 3 answers

@ a587626

all that does is turn off hardware acceleration that we already have done in the settings.

Vitdom 0 solutions 2 answers

I have selected ClearType to be disabled in my OS, and it works in Windows Explorer and all other applications etc. (all except Adobe Reader and Windows Internet Explorer, which is primarily why I use Firefox...)

Since Windows handles non-ClearType fonts with hardware acceleration, and Firefox <17 managed to handle it as well, I see no reason why disabling hardware accelerated graphics in Firefox 17 should be regarded a valid solution to the problem.

I have downgraded to Firefox 16.0.2 and will wait there until this is fixed.

Modified by Vitdom

Spiralgalaxy5 0 solutions 3 answers

Sweet!

ecarlson 0 solutions 4 answers

Thanks member "a587626". Setting gfx.direct2d.disabled to true, then restarting Firefox 17 worked for me too.

Modified by ecarlson

ad_verbum 1 solutions 9 answers

Disabling hardware acceleration (setting gfx.direct2d.disabled to true) is only a partial solution, makes fonts looking thinner but it isn't the same look and quality of anty-aliasing as it was in previous (16.0.x) versions of FF. I want to get back fine looking fonts with hardware acceleration enabled.

Sugioh 0 solutions 3 answers

That also disables HW acceleration, and as thus is not a true solution but a temporary workaround. Still, thanks.

Matt_G
  • Administrator
  • Moderator
380 solutions 1848 answers

Hi guys,

We are looking into this issue right now, but we need more information. Anyone will to work 1 on 1 with us to get this solved, please PM me. Also, if you could list your graphics cards and drivers in this thread that would help as well!

ad_verbum 1 solutions 9 answers

Windows 7/64, Nvidia driver ver. 296.10 (WHQL), GeForce GTS450.

ecarlson 0 solutions 4 answers

Windows 7/64-bit, GeForce 8400GS (ASUS EN8400GS Silent), NVidia video driver 306.97 WHQL.

PM sent.

Modified by ecarlson

Question owner

Nvidia GTX 560Ti, driver: 306.97 WHQL, Windows 7 SP1 64bit

Ultro 0 solutions 2 answers

Windows 7/64bit SP1, AMD Radeon 6950, AMD Catalyst 12.10 2D-driver version 8.01.01.1266, Windows ClearType disabled

ratsalad 0 solutions 3 answers

Windows 7/32bit SP1, Nvidia 9600 GT, Driver: 9.18.13.0697 - nVIDIA Detonator 6.97

Andreyka73 0 solutions 5 answers

Thank you for submitting this ticket. I am using Firefox and Seamonkey, both got ugly after update. I downgraded FF to ver.16 and changed the hardware acceleration option in Seamonkey. I will see what is the best option.

I am disappointed in Firefox programmers, again...

BoMbY 0 solutions 2 answers

Same problem for me. Disabling the hardware acceleration removes the much unwanted blur, but some fonts are still hinky, especially on this site.

Windows 7 X64 - NVidia GTX 670 driver version 301.42

Aeroxima 0 solutions 8 answers

Setting gfx.direct2d.disabled to true only partially helps. It's better but still bad, I'm going to have to revert versions.

It lost the boldness, but it's still "imprecise" for lack of better word. Almost as if there's a resolution mismatch type issue?

(Edit: I'm not sure if this was correct anymore, since I didn't restart after it. It may have fixed it entirely then, but I'm not sure.)

Modified by Aeroxima

smorrissey 0 solutions 6 answers

Again blurriness is back

Matt_G
  • Administrator
  • Moderator
380 solutions 1848 answers

Hi guys! Thanks for all the feedback. We've got a bug on file for this and several volunteers to help us get to the bottom of it. Hopefully we'll have some answers and a resolution very soon. Please be patient though as the Thanksgiving holiday in the US is this week.

Auralviolence 1 solutions 8 answers

Isn't this the same as disabling hw acceleration in the settings, but "another side"

Mogster 0 solutions 2 answers

PC #1:

  • Intel HD 3000 (integrated 2nd-gen Core i3)
  • Driver version 9.17.10.2875
  • Windows 7 SP1 Pro 64-bit
  • ClearType is disabled

PC #2:

  • AMD Radeon HD 6950 w/ shaders unlocked, stock clocks
  • Catalyst 12.10 driver
  • Windows 7 SP1 Pro 64-bit
  • ClearType is disabled

Modified by Mogster