X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox doesn't remember browser settings.

Posted

Whenever I open firefox I have to reconfigure my preferences (homepage, internet history settings). This only happens when I close all firefox windows and tabs then reopen firefox. My homepage is my igoogle page. When I reopen firefox it take me to the general igoogle sign in page. after i configure to never remeber internet history then close firefox and reopen it the internet history settings go to "use customized settings. I tried everything on https://support.mozilla.com/en-US/kb/Preferences%20are%20not%20saved without success. There is no user.js file in my profile folder. I ran my antivirus, antimalware, and antispyware programs, McAfee, MalWareBytes, SpybotSearch&Destroy (which are up to date) and they found nothing. I also uninstalled firefox and reinstalled it without success. This is increibly frustrating. Please Help!

Modified by Noah_SUMO

Chosen solution

If you have Firefox set to Never Remember History it will not save your password for iGoogle (it's just like using Private Browsing, Private Browsing - Browse the web without saving information about the sites you visit). So in this case Firefox isn't doing anything wrong. Do you not want to save history? In that case you'll need to either adjust your settings to just delete the cache and pages history, or just log back into iGoogle everytime.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • Google Update
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • GEPlugin
  • 5.1.10411.0
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1

More Information

https://support.mozilla.com/en-US/kb/Preferences%20are%20not%20saved all solution presented here did not work for me

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6636 answers

Ok, so you have your homepage set to igoogle, and you have your history set to never remember history? Then you close Firefox, and igoogle is still your homepage, just not logged in, and your settings are to "use custom settings" instead of never remember?

Have you tried to Reset Firefox? Reset Firefox – easily fix most problems right now that's all I can think of unless you give me more details.

Noah_SUMO
  • Moderator
50 solutions 303 answers

Weird. Can you see if there's files with the names prefs-1.js, prefs-2.js, prefs-3.js, etc in your profile folder? Or a file called Invalidprefs.js. If you find those files, delete them to the Recycle Bin.

But keep the highest numbered prefs-number.js file. Example: Keep prefs-10.js, delete prefs-9.js. That one should have all your latest settings. Also delete the original prefs.js file to the Recycle bin. It might be corrupted.

And on some Windows PCs, the last part of the filename might be hidden. Example: prefs-9.js will look like prefs-9 or user.js will look like user. These are the same files you're looking for but Windows is hiding the .js part.

Also to make sure you are in the right profile folder, read:
How do I find my profile?

Modified by Noah_SUMO

Question owner

I've tried Reset FireFox, no success. I've also observed my privacy settings remaining the same (Never Remember History) which is what I want, but I don't remained signed in on my igoogle page.

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6636 answers

Chosen Solution

If you have Firefox set to Never Remember History it will not save your password for iGoogle (it's just like using Private Browsing, Private Browsing - Browse the web without saving information about the sites you visit). So in this case Firefox isn't doing anything wrong. Do you not want to save history? In that case you'll need to either adjust your settings to just delete the cache and pages history, or just log back into iGoogle everytime.

Question owner

When uncheck Cookies and Active Log ins so they are not deleted when I close firefox, that seemed to resolve the problem. Thanks for all your help.