Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox will not open my iGoogle home page without having to sign in

  • 1 reply
  • 73 have this problem
  • 5 views
  • Last reply by cor-el

more options

Despite setting my iGoogle page as the home page in preferences and asking iGoogle to keep me signed in, every time I start Firefox it opens a generic Google page and I have to sign in to iGoogle to see my home page. This does not happen in Safari, where my iGoogle home page opens when I start that browser. I have Firefox 3.6 and OS X 10.4.11. This is very annoying and keeps me from using Firefox more often. How do I get Firefox to open the page I set in preferences? Or, is this a Google problem?

All Replies (1)

more options
  • Websites remembering you and automatically log you in is stored in a cookie.
  • Create an allow cookie exception (Firefox > Preferences > Privacy > Cookies: Exceptions) to keep such a cookie, especially for secure websites and if cookies expire when Firefox is closed.
  • In Private Browsing - Use Firefox without saving history mode all cookies are session cookies that expire if that session is ended, so websites won't remember you.
  • Do not use Delete browsing, search and download history on Firefox to clear the "Cookies" and the "Site Preferences"

Clearing "Site Preferences" clears all cookies, images, pop-up windows, software installation, and password exceptions.

See also: