X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

URL does not show when Firefox starts up

Posted

When I first start up Firefox the address bar just shows "Go to a Web site" instead of the page's URL.

I tried starting in safe mode but could not find anything there.

Additional System Details

This happened

Every time Firefox opened

This started when...

Over last couple weeks

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • Google Update
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • Nitro PDF Plug-in for Firefox and Chrome
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • 5.1.10411.0
  • Picasa plugin
  • IE Tab 2 Plug-in for Mozilla/Firefox
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1

More Information

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6641 answers

What do you have set as the Home Page? If you have about:home (Firefox's default home page) this is what you will see. If you have something else set, you should see the URL.

AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

If you have Firefox set to open with a blank page, it will show "Go to a Web site" in the address bar. You can change that in the Firefox Options window - General panel under "Startup". See Startup, home page and download settings for details.

Question owner

Alice, no I don't have FF set to open with a blank page.

Tyler, no, I am not using about:config.

For instance: I have a link on my desktop [ http://www.instituteforlegalreform.com/states ], and if I double-click it, yes, it opens, but the address bar is not showing the url.

Yet, if I click that link now, with this answer page already open, the new link showing the page will also show the URL.

Very strange.

AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

An Internet Shortcut on your desktop is another story! I created an Internet Shortcut to http://www.instituteforlegalreform.com/states by dragging its icon in the Firefox address bar to my Windows 7 desktop. It works for me with Firefox closed, since I have Firefox set as my default browser ... but I do see "Go to a website" for a fraction of a second before the page loads and I DO see the URL in the address bar.

I checked http://kb.mozillazine.org/Windows_error_opening_Internet_shortcut_or_local_HTML_file_-_Firefox but it doesn't seem to apply to your error ... the page does open in Firefox, but the URL does not show up in the address bar? If that's not the problem please explain it better.

Also, maybe Tylerdowner has another suggestion or idea.

Modified by AliceWyman

Question owner

lice, yes, the page does open but the URL does not show in the address bar -- and yest, for links in text, like that getting tot his page, it seems to work fine. ?

Chuck

AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

Is the problem ONLY happening with Internet Shortcuts, when you double-click on one to start Firefox and open a specific website?

In any case, you could try the Troubleshooting extensions and themes suggestions, in case one of your Firefox extensions or themes is causing the URL to be missing from the address bar. Or, if you don't have many extensions installed or other customizations, you could try a Firefox Reset. See Reset Firefox – easily fix most problems.

Question owner

Alice, yes, it appears to be when I start FF from a shortcut to a site that I see it the most. Once I am in FF, as I move between sites, it appears to lessen.

Is that something that a site could control -- not showing in the address bar, or is that controlled at the FF level? I ask because if it were a FF issue, wouldn't it be consistently one way or the other?

I'll try the links you shared.

Thanks, Chuck

AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

Some web pages open in special windows which hide the address bar, change the window size, or make other changes via javaScript but that doesn't seem to be the case with your example Internet Shortcut to http://www.instituteforlegalreform.com/states , since it works for me just fine.

Do try the Troubleshooting extensions and themes suggestions.

Modified by AliceWyman

Question owner

Gotcha. thanks Alice.

Chuck

captianduck 0 solutions 1 answers

Helpful Reply

I have the same problem, but can force it to show the URL. When I click on a link in an email or open ANY link in a new window, the "Go to a Website" message shows instead of the URL although the page does load.

I can force the URL to appear if I open a new tap using the "+" next to the tab of that page then close it. The URL then shows in the address bar of the original tab. I do not have to put an address in the new tab, just create it then close it.

Maybe this will shed some light on what is causing this problem.

Modified by captianduck

Question owner

Yea, and I walked through my add-ons, but couldn't find any specific culprit. Mozilla ought to add an option that would lock the bar so that add-ons or sites couldn't shut it off.

It especially is strange since once one is in FF the problem doesn't seem to recur [for me] on any sites I subsequently browse to after startup.

CB

Question owner

I can't say as yet that it totally stopped the issue, but those links certainly answered several other quirks.

Thanks!

Regards, Chuck Billow

stoodles 0 solutions 1 answers

Helpful Reply

I had the same problem but it stopped once I disabling my divx plugin.

Question owner

That's terrible news since I don't have -- I cannot see any DivX plugin...sigh...

AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

Disabling the "'Gom player + ask' toolbar" and the "DivX (Plus) Web Player" add-ons reportedly resolved the problem according to the replies in these threads:

CWBillow: Did you already try disabling Firefox extensions and themes from the Add-ons Manager, then restarting Firefox? See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems. In that case, try disabling the plugins you have listed in the Firefox Add-ons -> Plugins panel. Your system details show that you have the following plugins enabled in Firefox:

   Shockwave Flash 11.4 r402
   Google Update
   The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
   RealJukebox Netscape Plugin
   RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
   RealPlayer(tm) HTML5VideoShim Plug-In
   RealPlayer(tm) LiveConnect-Enabled Plug-In
   RealPlayer Download Plugin
   Nitro PDF Plug-in for Firefox and Chrome
   NVIDIA 3D Vision Streaming plugin for Mozilla browsers
   NVIDIA 3D Vision plugin for Mozilla browsers
   5.1.10411.0
   Picasa plugin
   IE Tab 2 Plug-in for Mozilla/Firefox
   The plug-in allows you to open and edit files using Microsoft Office applications
   Office Authorization plug-in for NPAPI browsers 

Since both GomPlayer and DivX Plus Web Player are streaming media players, You could start by disabling those types of plugins first. See this article for help troubleshooting plugins:

Modified by AliceWyman

Question owner

Alice I finally just uninstalled everything, and started over. So far, so good.

Thanks, Chuck