X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Adobe Flash Player 11.4 quits working, won't show videos even after reinstalling.

Posted

Had Adobe Flash Player 11.3 r300 and it stopped showing videos, etc. in Firefox a few days ago. Now I've installed v 11.4 r402 and it still gives error message "Adobe Flash Player ... has stopped working." I uninstalled, downloaded again and reinstalled -- with the same result. No videos. Firefox Plugin check page shows it installed correctly. Any solutions?

Chosen solution

For 11.3, one of the workarounds was to disable protected mode. See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox? This appears to still be applicable in Flash 11.4.

You also could consider rolling back to Flash 10.3. However, some content may require new features of Flash 11.x. This article has the steps: Adobe Flash plugin has crashed - Prevent it from happening again.

Read this answer in context 23

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • Next Generation Java Plug-in 10.6.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • 5.1.10411.0
  • McAfee MSC FF plugin DLL
  • NPWLPG
  • Wacom Dynamic Link Library
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0

More Information

jscher2000
  • Top 10 Contributor
2344 solutions 20791 answers

I don't object to more and better testing and documentation. I just don't care to discuss questions like "Do you really think that despite the differences, that Adobe really cared about Firefox when they're offering Chrome?" I didn't mean to suggest you didn't have some valid points.

CheckMate 6 solutions 117 answers

Hi jscher2000, That's fine. Thanks for clarifying that .It was actually a rhetorical question. I didn't really mean there was anything more to discuss. Just making the point that Adobe needs to get their act together with Firefox because it does look like there could very possibly be a conflict of interest there even without intending it. But Adobe needs to answer that one, I just raised the question for everybody to think about, because this shouldn't still be going on, over 3 months later. I just wondered if you had any other thoughts on any of this, that's all I was asking.

Modified by CheckMate

soawesomejohn 0 solutions 2 answers

Still can't get this working despite all suggestions. Here are my notes.

Issue:

Flash videos on youtube freeze within seconds of starting. Firefox becomes unresponsive. I then have to go into task manager and kill the adobe flash process in order for Firefox to start working again. I actually had to install Flashblock in order to stop the freezing. Any flash I want to play, I have to use Chrome.

I have had issues with flash freezing my browser on other web sites as well. For example, videos on dailymotion sometimes work, sometimes freeze the browser. Though, I suppose dailymotion could occasionally be serving me html5 videos, though the ad before the definitely seems to be flash.

Firefox v 15 with Adobe Flash 11.4 (ie, most recent) Windows 7 Pro 64-bit, all updated. This is a relatively new install, so Firefox + Flash has never fully worked well for me. https://support.mozilla.org/en-US/questions/935857 http://support.mozilla.org/en-US/questions/935960 https://support.mozilla.org/en-US/questions/935797 http://www.sandboxie.com/phpbb/viewtopic.php?t=13280

steps taken that failed to resolve this issue. 0. I do not have realplayer or any add-ons related to it 1. disabled all extensions 2. Reinstalled firefox and flash 3. created a new, blank profile in firefox 4. disabled hardware acceleration (Tools -> Advanced -> General) 5. downgraded Adobe Flash to 11.3.300 6. downgraded to Firefox 14.0.1 7. disabled Avast Shields 8. disabled Protected Mode 64-bit C:\windows\syswow64\macromed\flash\mms.cfg ProtectedMode=0

9. disabled Protected Mode 32-bit C:\Windows\System32\Macromed\Flash\mms.cfg ProtectedMode=0

10. Upgraded back to Firefox 15 11. Downgraded to Flash Player 11.2.202.235 ( 5/04/2012)

http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html#main_Archived_versions

12. Downgraded back to FireFox 14 13. Downgrade to Adobe Flash 10.3 https://support.mozilla.org/en-US/kb/flash-113-crashes#w_step-2-install-flash-10-3

14. Why not.. reboot

15. Firefox safe mode (https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode)

AliceWyman
  • Top 25 Contributor
  • Moderator
190 solutions 1961 answers

soawesomejohn, This is about the Firefox freezes you've been having when attempting to play certain Flash videos (which is likely a different issue than the " "Adobe Flash Player ... has stopped working." error).

I see you tried disabling hardware acceleration in Firefox options but you should also try turning off hardware acceleration in Flash settings. See:

Modified by AliceWyman

CheckMate 6 solutions 117 answers

@soawesomejohn,

Try Alice's suggestion, but on the rollback to the 10.3, make sure you install the Active X Flash for Internet Explorer, which is needed for certain programs to work properly. Adobe's Uninstaller removes both versions of Flash, not just the Firefox Flash plugin. You're following the crash article instructions which were never corrected to add that warning that I recommended. See my explanation about that at the beginning, under Helpful Replies.

It may not have anything to do with your issue but it may cause other problems, so just make sure you do it.

To Install 10.3.183.23

Active X version For Internet Explorer http://fpdownload.macromedia.com/get/flashplayer/current/licensing/win/install_flash_player_10_active_x.exe

For Firefox http://fpdownload.macromedia.com/get/flashplayer/current/licensing/win/install_flash_player_10_plugin.exe

Also, you don't have to "suppose" anything about the HTML5 experiment. Right click on the video. If it says "About HTML5" you're either opted in at random or it's a mistaken WebM. Click on "About HTML5, and on the bottom of the menu - it'll tell you if you're opted in. You can opt out with one click on that. Or, you can type in the search bar "HTML5" and click on it in the search and it'll tell you the same way. I've experimented a lot with it - WebM's come in waves and sometimes they can cause crazy problems which they'll fix in a few days, so I've been in and out of that experiment. You're probably right, though, it wouldn't be causing problems on every video, but I'd opt out, anyway, just to rule it out.

Modified by CheckMate

soawesomejohn 0 solutions 2 answers

AliceWyman & CheckMate.

Thank you for the responses. Unfortunately, not long after posting, my hard drive crashed (less than 3 months old). I was able to go back to my previous hard drive and Flash is now working (11.3 currently on Firefox 15). Since my old hard drive is toast, I won't be able to troubleshoot further. Though.. I don't actually think the hard drive was the cause of this particular issue. Everything else was working great up until the sudden onset of premature drive death.

Alice, you are correct - I did not disable hardware acceleration in the Flash settings. I think that would have done the trick as it worked for so many others.

CheckMate: Actually, I did see your ActiveX tip and installed that as well.

Phillip21 0 solutions 2 answers

The reinstallation of Flash 10.3 plus ActiveX worked brilliantly for me on Firefox 16/Win7. And it also seems to significantly speed up Firefox! Thanks for the good advice!

hort62 0 solutions 1 answers

The only way I was able to get Flash Player working in Firefox, without reverting to a previous version, was to reinstall it EVERY time I turned on my computer. Adding the line "ProtectedMode=0" didn't do anything.

CheckMate 6 solutions 117 answers

Hi jscher2000,

I'm testing with Firefox 16.0.2 and an upgrade of the touch pad and Adobe 11.5. Now, the scrolling stops if I either click to change the video resolution, or pause it. This happens on YouTube but not other sites and clicking on another tab and then back gets the scrolling going again, but frequently not until I also click on the page again. Clicking outside the video does nothing. This time, however, going back to 10.3 doesn't fix it, and some sites require the current flash version. All other Flash features are normal. Clicking on the Desktop, then the page, works better than switching tabs, but you still have to click twice and this shouldn't be necessary.

Mozilla and Adobe better get there act together or experienced users like me are gonna be gone for good and I really don't care who thinks all this effort is worth it - I don't.

So far I've had these Firefox - video - touch pad - Flash issues on two fast computers, two versions of the touch pad, multiple versions of Flash, and not one other person is reporting this??????I guarantee that there are numerous others out there who don't even realize they've got the damn problem! Firefox in safe mode also proved useless, as usual.

Reinstalling Firefox doesn't fix it and, as always, this doesn't happen with IE9 or Chrome 23. Restore points don't seem to fix it either. I'll post a bug on Bugzilla unless you or cor-el or anyone have any other ideas. I tried Flash 11.4 again also, since there had been another update of that but that failed also.

Modified by CheckMate

jscher2000
  • Top 10 Contributor
2344 solutions 20791 answers

Hi CheckMate, this thread is so long that I can't tell whether your scrolling issue is a new issue or was discussed on an earlier page.

It certainly has been a problem in recent months that if you interact with the controls of the Flash player used on YouTube, it is difficult to get the focus out of the control back onto the page. We've had some posts on that, but I don't know whether anyone has created an entry in Bugzilla. Probably by now there is one, but it certainly would be a good idea to check.

CheckMate 6 solutions 117 answers

Hi jscher2000,

Thanks for the input. At least it's a known issue. I knew I couldn't be the only one. But I feel more confident now that it's a known issue with others reporting it.

I know what you mean about the long thread. I replied to your reply to my description of the similar problem testing the 11.4. It's on page one, where I said in testing the 11.4 , pausing the video disabled the scrolling.

I'll check the links you posted and then I'll see if anyone has posted a bug on Bugzilla and then I'll post it. I didn't know about the other posts on this. When I reported it about the 11.4 it was a while ago when that was first released, but I hadn't really checked for that again when I posted this time.

In the meantime, the simple workaround to just click on the Desktop and then click on the page gets the scrolling back and is the quickest way to do it if it works the same for others. With Firefox in full screen mode, switching tabs and then back again is the next best option.


Reply

Modified by CheckMate

jalyst 0 solutions 24 answers

The chosen sol'n in this thread isn't terribly helpful for folks that use OS X. I want to try disabling protection mode, but some Googling + reading the thread referenced, only reveals how to disable it in Windows. I haven't yet read though this entire thread, has anyone else already worked out how to disable it in OS X?

Thank-you.

Modified by jalyst

jscher2000
  • Top 10 Contributor
2344 solutions 20791 answers

Hi jalyst, I don't think Adobe has implemented protected mode on MacOSX. That could explain why you haven't found any articles on that. What are the specific symptoms you are trying to cure? Perhaps there is another solution/workaround.

jalyst 0 solutions 24 answers

constant crashing on firefox 18 beta, I dont recall it being as unstable on prior beta builds, I updated to the latest version of FP (11.5.something) but still no dice.

Modified by jalyst

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

You can check for problems caused by recent Flash updates and try these:

  • disable a possible RealPlayer Browser Record Plugin extension for Firefox and update the RealPlayer if installed
  • disable protected mode in Flash 11.3 and later
  • disable hardware acceleration in the Flash plugin

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.
CheckMate 6 solutions 117 answers

I'm way ahead of you, cor-el. I've actually done ALL of those steps and more. Disabling the RealPlayer extension doesn't always work, ( even though it reads disabled)and I reported that months ago , so I even unchecked "Enable Download and Recording"which removes it. I knew if there were a conflict, it would be caused by Adobe, but it made no sense this time given the symptoms. It didn't make a difference and neither did any of the other trouble shooting steps. That's why I've been trying to tell you that's it's a real bug and a Developer issue. I suspect many people might have this issue and don't realize it and I can't account for those who don't .

It can't be a Protected Mode issue alone because the 10.3 has the same problem, although clicking on the page alone works with that. Djisabling Protected Mode does eliminate the need for other workarounds, but you still have to click on the page again to get the focus back. I had forgotten that Protected Mode is enabled by default without showing it in the mms.cfg file.- I finally added the command line ProtectedMode=0 to disable it.

I finally proved this is a Flash caused issue, however. I opted back into the YouTube HTML5 Trial to test the webm format would reproduce the issue.http://www.youtube.com/html5?gl=AU&hl=en-GB# and then finding an HTML5 video - most of them will still be Flash videos. Here's one I tested after Joining the HTML5 Trial http://www.youtube.com/watch?v=1mXFVoX8INQStart the video and right click on it and if it says on the bottom of the menu "About HTML5, it's a webm. The issue doesn't reproduce with the webm's- scrolling was perfect after clicking on anything in the video, without having to even click on the page. That PROVES it's a Flash caused issue, because after being able to scroll with no problem in and HTML5 webm video, I copied and pasted the identical video http://www.youtube.com/watch?v=1mXFVoX8INQ after Leaving the Trial, and the same video, now an .flv Flash video, reproduced the scrolling problem again! That proves it. There's nothing left to do, but wait for the Developers to get on this, and I wish that staff would do something about that, because this clearly involves BOTH Mozilla and Adobe again,so they should be coordinating this because it's not reproducible on IE9 or Chrome 23. I think I noticed it months ago, but having rolled back to the 10.3 in June, it didn't seem like too big a deal to click on the page and there were more serious issues at the time. Until I saw it much worse while testing the 11.4, and now the 11.5.

I posted a formal, detailed bug on Bugzilla https://bugzilla.mozilla.org/show_bug.cgi?id=811225and Adobe. https://bugbase.adobe.com/index.cfm?event=bug&id=3372854 Adobe even has that last troubleshooting step I thought of on their own site, to test whether a problem is caused by Flash. The only person to answer me on Bugzilla is from softvision who tried to tell me it doesn't reproduce on the latest Nightly, version 20 and to start a new Profile in the Nightly in Safe Mode. She's wrong - it does reproduce and I knew it would. I reported my results on the bug report and she disappeared after that.

Sorry for the long post - there's a lot to explain.

Modified by CheckMate

jalyst 0 solutions 24 answers

@wall-o-text (CheckMate)

I had ZERO issues with FP 10.3, it only started to frequently occur once I updated to the latest Firefox 10.8 beta build, upgrading to FP 10.5x didn't change that, you don't make clear whether you're referring to a Windows install or OSX, my problems are on OSX (10.6.8).

Modified by jalyst

CheckMate 6 solutions 117 answers

Hi jscher2000, I checked the links and then after more troubleshooting I proved this is a Flash caused issue by testing with HTML5 webm videos after Joining the YouTube HTML5 Trial again and sure enough, the issue doesn't reproduce in that format. I then copied and pasted the identical video after Leaving the Trial (the video automatically becomes an .flv Flash video ) and the problem reproduces again! After I test and reported it on and Adobe but report, I later found that Adobe actually has this as a troubleshooting step to prove whether a problem is caused by Flash.

I posted a Bug with Bugzilla https://bugzilla.mozilla.org/show_bug.cgi?id=811225 and Adobe.https://bugbase.adobe.com/index.cfm?event=bug&id=3372854

You can read my more detailed reply to cor-el's suggestions today - no need to repeat it all.

Modified by CheckMate

CheckMate 6 solutions 117 answers

@jalyst

Windows 7 Home Premium 64 bit install. @wall-o-text (CheckMate) ??? LOL!!!

Modified by CheckMate

jalyst 0 solutions 24 answers

So it was a waste of time for my problem, sadly... glad I didn't read it >.>