X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Myspace music player says flash is unavailable

Posted

Before I begin, I would like to say that I have the current version of Adobe Flash, and that all other websites that require flash work just fine (YouTube, Facebook, A few other video sites, Pandora, etc)

Whenever I try to play something on the myspace video player, it displays a message something along the lines of "Flash is unavailable for playback. Your Flash version is: 11.2.202 To proceed, try the following:Refreshing the Page, Restarting your Browser, Upgrading your Flash Player"

I have tried uninstalling and reinstalling Flash (both the software and the plugin), and Firefox with no avail. Right now, I have to use IE to play anything off of myspace and it pisses me off, simply because I hate IE (I don't use Chrome, and who doesn't hate IE?)

My system specs are: Athlon II 2.6Ghz quad core 4gb of RAM ATI Radeon HD 4550 512mb DDR3 Graphics Card

Modified by Camden Stensland

Chosen solution

I found the answer: download the OrganizationalSSL Intermediate cert (http://www.globalsign.com/support/intermediate-root-install-old.php)

click the OrganizationSSL Intermediate link, copy/paste the contents into notepad, and save locally as OrganizationSSL.crt (click the dropdown box next to the file name, and make sure (All types) *.* is selected)

note: this cert is already installed on my mac firefox install...

import the cert into firefox by going toTools>Options>Advanced>Encryption>View Certificates, and click Import

Browse to wherever you saved it and select the file. Make sure you allow it to identify websites

Restart Firefox and launch the myspace music player, it should work.

Read this answer in context 46

Additional System Details

Sites Affected

http://http://www.myspace.com/music/player

Installed Plug-ins

  • Shockwave Flash 11.2 r202
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3
  • Version 2.8.7.6830
  • Google Talk Plugin Video Accelerator version:0.1.44.15
  • Google Update
  • Picasa plugin
  • VLC media player Web Plugin 2.0.0
  • Next Generation Java Plug-in 1.6.0_31 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • Microsoft Lync 2010 Meeting Join Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.3.633
  • 5.0.61118.0
  • Windows Activation Technologies Plugin for Mozilla
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0

More Information

Application Basics
Name
Firefox
Version
11.0
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Adblock Plus
2.0.3
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
DownloadHelper
4.9.9
true
{b9db16a4-6edc-47ec-a1f4-b86292ed211d}
Adobe Acrobat - Create PDF
1.2
false
web2pdfextension@web2pdf.adobedotcom
Adobe Contribute Toolbar
6.1
false
{01A8CA0A-4C96-465b-A49B-65C46FAD54F9}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.buildID
20120312181643
browser.startup.homepage_override.mstone
rv:11.0
browser.tabs.warnOnClose
false
extensions.lastAppVersion
11.0
gfx.blacklist.layers.opengl
5
gfx.blacklist.suggested-driver-version
10.6
gfx.blacklist.webgl.opengl
5
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1335071699
places.history.expiration.transient_current_max_pages
104858
places.history.expiration.transient_optimal_database_size
167772160
privacy.cpd.downloads
false
privacy.cpd.formdata
false
privacy.cpd.history
false
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.warn_viewing_mixed
false
Graphics
Adapter Description
ATI Radeon HD 4300/4500 Series
Vendor ID
1002
Device ID
954f
Adapter RAM
512
Adapter Drivers
aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
Driver Version
8.850.0.0
Driver Date
4-19-2011
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17776)
ClearType Parameters
Gamma: 2200 Pixel Structure: RGB ClearType Level: 50 Enhanced Contrast: 50
WebGL Renderer
Google Inc. -- ANGLE (ATI Radeon HD 4300/4500 Series ) -- OpenGL ES 2.0 (ANGLE 1.0.0.930)
GPU Accelerated Windows
2/2 Direct3D 10
AzureBackend
direct2d

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

You can check the local storage settings in Flash.

  • Windows Control Panel > Flash Player

Global Storage Settings Panel:

Flash Website Storage Settings panel:

Flash Local storage settings Help:

Question owner

There weren't any entries for any MySpace domain in the storage and playback settings in the control panel, so I added the MySpace domain, and allowed it to save entries and use peer-to-peer networking (although I doubt MySpace would use a p2p protocol). I used the links you gave me to change the global and local storage settings (I raised it from 100kb to 10mb), and the myspace music player still wouldn't load.

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

If you use extensions (Tools > Add-ons > Extensions) like Adblock Plus or NoScript or Flash Block that can block content then make sure that such extensions aren't blocking content.

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Question owner

OK, so I first started by clearing my cache and deleting my cookies as well as disabling Adblock Plus, which didn't do anything, so I re-enabled it, and started Firefox in Safe Mode, which didn't help anything either.

I then tried disabling hardware acceleration, and that too didn't help the issue.

So I upgraded to the beta in hopes that the issue might have a fix somewhere, but no luck there either. I find it odd though that the myspace music player works on my mac running the same version of flash and Firefox.

And on a side note, I am running the Firefox version of Flash, not the IE version.

Thank you for your help so far! :)

Chosen Solution

I found the answer: download the OrganizationalSSL Intermediate cert (http://www.globalsign.com/support/intermediate-root-install-old.php)

click the OrganizationSSL Intermediate link, copy/paste the contents into notepad, and save locally as OrganizationSSL.crt (click the dropdown box next to the file name, and make sure (All types) *.* is selected)

note: this cert is already installed on my mac firefox install...

import the cert into firefox by going toTools>Options>Advanced>Encryption>View Certificates, and click Import

Browse to wherever you saved it and select the file. Make sure you allow it to identify websites

Restart Firefox and launch the myspace music player, it should work.

Modified by cor-el

eyerock36 0 solutions 1 answers

Helpful Reply

Thank you! Although seemingly complicated, this fix actually worked!!

Charixfox 0 solutions 6 answers

Note to people who get a 404 when trying to visit that URL: The ) on the end breaks it.

Use below to get directly to the necessary certificate: https://www.globalsign.com/support/intermediate/organizationssl_intermediate.php

(This is a bad sign for MySpace, by the way, when the cert they use has no validation path in a major browser.)

brucer 0 solutions 1 answers

firefox doesn't work with my space music


brucer.robbins7@gmail.com 708-456-4196

Question owner

Brucer, have you tried installing the certificate that both I, and Charixfox have linked to? Firefox DOES work with Myspace music player- there's simply an issue on Mypsace's end, which requires some work for those of us who use Firefox and Windows.

soerduke 0 solutions 1 answers

ok, everything done, worked till the moment of import: System say: this is already in the list. After i search the list for this file: no file with this name is in the list.

Whats now??????????????

Thanks

roude108 0 solutions 2 answers

I downloaded that certificate and now Myspace works fine in Firefox. Unfortunately, now Firefox cannot play certain videos online. The audio will play, but the video will be black.

Here is a Youtube video that is black for me: http://www.youtube.com/watch?v=Kw_F1qEdx1E

And here is a different user with the same video that works fine for me: http://www.youtube.com/watch?v=cKHX2XAMZmw

Is there a fix for this as well? It started happening when I installed the certificate to fix the Myspace issue. If there is no fix, can you explain exactly how to undo what I did to install this certificate? I would rather switch to IE for myspace, than have to switch for every other video I watch.

Should I just delete all the GlobalSign certificates in Firefox?

Question owner

Hmm... I'm not having an issue playing either of those videos, and I have the certificate installed, so I'm pretty sure that the timing is a pure coincidence. However, Adobe and Firefox just published a series of updates because of issues with the Flash Player, so make sure Firefox is updated to the latest version (You can also try the beta version, which is what I use), and you might try uninstalling, and re-downloading and installing Adobe Flash. (You can get flash here: http://get.adobe.com/flashplayer/)

Sorry for the inconvenience doing this has caused you; I hope this helps.

roude108 0 solutions 2 answers

Strange...I just tried that video again and now it works. I tried another one that was giving me problems, and that one still isn't working. But I'll try reinstalling flash and making sure Firefox is updated.

Thanks for the suggestions!

Mr_and_Mrs_D 1 solutions 27 answers

Me too I get :

This certificate is already installed as a certificate authority.

Apparently it is there with another name ?

Maybe someone should fill a bug to mozilla for this

Velvetkiss 0 solutions 1 answers

I had this same issue, but eventually sites like you tube and even grocery store sites stopped showing there videos and would not display grocery ads. I uninstalled my adobe flash player completely and then installed adobe flash player 10.3 an older version as I had the newest version of Flash player and this fixed the problem. Myspace playlists work, videos work and grocery ads all work. Not sure if this is your exact issue but it might be worth a try to see if it fixes the issue.

misfitbully 0 solutions 1 answers

I spent a few weeks of frustration several months ago trying all sorts of solutions to get my MySpace Music player to play in firefox again. I finally did the uninstall flash and then got an old version from them and so far it is still working. I have tried a couple flash updates but it always results in the same mess again where everything works except the myspace player. I then run the uninstall file from Adobe and then install the old flash and it works again. I currently have version 11,2,202,235 installed instead of the current 11.3.300.265. I have not tried changing this again since the last firefox update. I do keep the IE flash current though and it works fine.

Sicknero 0 solutions 3 answers

I'm trying your solution but no joy so far. However at no stage can I see an option to allow or disallow it to identfy websites. Anybody help please..?

Hermes 1 solutions 20 answers

You can try one of the following:

1) Enter https://www.myspace.com once (you can return to http-connection again afterwards).

2) Login to your myspace account.

In both cases the right certificate should be installed and can be used by the myspace music player.

This odd behaviour might be a bug in the myspace website or in the flash-plugin for firefox, but please don't ask me ;-).

Modified by Hermes

jacrone 0 solutions 1 answers

It appears that any extension that requires you to "click to play" a plug-in causes some sites that use Flash to stop working. Try disabling this function, and see if it helps.

This resolved my problem in Chrome and Safari. I can now listen to music on myspace, soundcloud, and sounds on the google doodle.