X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Myspace audio player+FF= :(

Posted

I've got a problem with the MySpace audio player. When I'm trying to listen to a song, there is a message popping up saying that the Flash cannot be played, it suggests me to refresh/restart browser or upgrade flash . But I'm already using this version of flash and I've got the latest FF. p.s.: IE had no problems.

Chosen solution

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

Read this answer in context 1

Additional System Details

Sites Affected

http://www.myspace.com/music/player

Installed Plug-ins

  • Shockwave Flash 11.1 r102
  • Google Update
  • GEPlugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_29 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.1
  • 4.0.60831.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0.1) Gecko/20100101 Firefox/8.0.1

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Chosen Solution

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

Question owner

It seems that it was the unusual behaviour of the Flashblock plugin which caused the problem. Thanks a lot.

Modified by dreamca4er

MisterEwok 0 solutions 2 answers

I don't have the flashblock plugin installed, but I have the same problem. I click "play" on a song or album on myspace, the player window pops up and it gives this message:

Flash is unavailable for playback. Your Flash version is: 11.1.102 To proceed, try the following:

   Refreshing the Page
   Restarting your Browser
   Upgrading your Flash Player


I do the same thing in google chrome and it plays no problem. But this is the only website where I've encountered a problem with flash player on firefox.

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Google Chrome comes with its own Flash plugin, so doesn't require and external plugin to be installed like Firefox needs.

Test if you have the Flash player installed and working.


MisterEwok 0 solutions 2 answers

I have the plugin installed, and it works properly on every other website that I have been to. The myspace music player is the only problem I've experienced so far.

J.M.Ward 0 solutions 1 answers

I too have the problem, and running in Safe Mode and disabling various things does not make it go away. Internet Explorer and Google Chrome both work OK. My experience otherwise is the same as MisterEwok's.

gonifsystems 0 solutions 4 answers

Same problem with Firefox 6.0 on Solaris and iceweasel/Firefox 8.0 on Debian. Chromium-browser on Debian works OK.

asalminen 0 solutions 2 answers

Same problem. I have FF 10 and the newest flash which is working

http://www.adobe.com/software/flash/about/

FF 10 is in safe mode and I still get the same message in MySpace "flash cannot be played". IE works fine!

Modified by asalminen

gonifsystems 0 solutions 4 answers

I'm rephrasing this. It's Myspace that is not working with Firefox. http://www.espace.mu/ (Radio-Canada) exhibits the same behaviour. I just stopped using them.

leipzigonkel 0 solutions 2 answers

answer is coming...

Modified by leipzigonkel

leipzigonkel 0 solutions 2 answers

Helpful Reply

I have the solution!

Firefox needs the following certificate to let myspace player work: http://www.globalsign.com/support/intermediate/organizationssl_intermediate.php

http://eigene.dyndns.org/download.php?file=GlobalSignOrganizationValidationCA.crt

I asked the german firefox support chat and they have found it. I don't know why it is so. How to import the certicficate: from my german ff in english:

preferences>Settings>Advanced settings>encoding>'show certificates'>import

Modified by leipzigonkel

gonifsystems 0 solutions 4 answers

Thanks! Solved for Myspace with iceweasel/FF 8.0 + libflashplayer.so 11.1 or 11.2 on Debian PC's.

gonifsystems 0 solutions 4 answers

P.S. Problem with espace.mu was unrelated. Fixed by accepting third-party cookies.

foxprobs1 0 solutions 2 answers

Me too!

vw66bus 0 solutions 1 answers

Fixed my: "Flash is unavailable for playback. Your Flash version is: 11.1.102 To proceed, try the following:

  Refreshing the Page
  Restarting your Browser
  Upgrading your Flash Player"

Problem by importing the Certificate Tools-> Options-> Advanced -> Encryption -> View Certificates -> Import Select file Checkbox Identify Websites (from memory, so maybe incorrect, it was the 1st check box)

Thanks! vw66bus