Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Flash-based applications just randomly pause or stop playing sound in Firefox

more options

A couple of days ago, I started having issues with Flash-based applications in Firefox, but not in, say, Internet Explorer. Basically, the thing that happens is that either the Flash-based music player pauses or the video that's being played loses sound, but not the video.

I've seen this on three different occasions: - myspace player abruptly pauses a couple of minutes into a song - embedded bandcamp player abruptly pauses a couple of minutes into a song - a streaming video based on Flash cuts sound off, but not video, making me have to rewind back to before that happened

I've tried reinstalling both Firefox and Flash (after doing a clean uninstall), I've tried disabling hardware acceleration, I've tried disabling Avira, and all of my other add-ons are up-to-date. As I said, at least the myspace player thing does not happen in IE, so I believe this is a strictly Firefox issue.

Does anyone know what to do?

All Replies (3)

more options

Check your Plugins are updated!

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

more options

Thanks, but Firefox Safe Mode doesn't solve the problem. Any other ideas?

more options

Type about:config in Address Bar and search plugins.click_to_play change the value to false.