Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I stop page from automatically reloading when I hit the back button?

  • 5 replies
  • 1 has this problem
  • 3387 views
  • Last reply by cor-el

more options

A couple months back, I upgraded to a new laptop, and ever since then, when I hit the back button, it refreshes the previous page from what I can figure out. On my last laptop, if I was doing searches on a site, and hit the back button, the search bar would be automatically ready to hit the backspace and delete what is in there for a new search. Now when I hit the back button, I have to manually click inside the search box to do so, and I hate it. When you are doing multiple searches on sites, time savers like this really help. This applies to regular sites (forums, online stores, etc), not search sites like Google.

I did not have this issue on my old laptop, and can't figure out how to fix it on this one. They are both Win7 x64, and browser version isn't the issue. I started out Firefox on this computer as the exact same one on the last one, and after upgrades, it still is the same. I am currently on 8.0, but will be upgrading soon to the new one.

Chosen solution

Do you mean that the search bar on that page doesn't get focus?

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

Read this answer in context 👍 0

All Replies (5)

more options

Hi SyRenSkywolf, I am trying to reproduce the problem you are having with the inline search. Do you have add-ons installed? Or programs that run keybindings?

Have you tried running Firefox on Safe Mode?

Modified by JeanAustinR

more options

Honestly never heard of keybindings before. This was going on even before I added my usual addons to it. The only thing I can think of along those lines would be the Kaspersky addons, that automatically came with the virus software.

Kaspersky URL Advisor 12.0.0.449 Kaspersky Virtual Keyboard 12.0.0.449


The other addons I have, which were added well after I started using this computer is:

Social Fixer 6.221 Photobucket Uploader 1.3.3 New Tabs at the End 1.0 Adblock Plus 2.0.3

more options

Pressing Backspace will go back a page in the session history is default Firefox behaviour in Windows. If you want to disable it you must modify browser.backspace_action


type in the address bar about:config

then press the button i'll be careful i promise

then type in the bar browser.backspace_action (or copied from here)

then right-click on it, select modify and change the value to 2 (probably you have 0 value).

then click OK, exit firefox and restart-it.


See for more info : Browser.backspace action


thank you

Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.

more options

That does absolutely nothing to help this, and only makes more of an issue for what I wanted. I want to keep the backspace option for going back pages. Disabling it does nothing for the issue I am having. I've always used backspace to go back to the original search page.

more options

Chosen Solution

Do you mean that the search bar on that page doesn't get focus?

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).