X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Can I turn off or disable Javascript Scratchpad?

Posted

Sometimes, when I start to type in an email or a form, Javascript Scratchpad opens, and I'm typing in that window. I don't know anything about Scratchpad and don't want it to open. Why does it open? Is there any way I can turn that off?

Additional System Details

This happened

Every time Firefox opened

This started when...

I got a new computer and Firefox was updated.

Installed Plug-ins

  • Shockwave Flash 11.1 r102
  • Next Generation Java Plug-in 1.6.0_30 for Mozilla browsers
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.1
  • McAfee MSC FF plugin DLL
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.5"
  • Coupons, Inc. Coupon Printer Plugin
  • Coupons, Inc. Coupon Printer DLL
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1

More Information

Application Basics
Name
Firefox
Version
9.0.1
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
LastPass
1.80.0
true
support@lastpass.com
McAfee ScriptScan for Firefox
14.4.1
true
{D19CA586-DD6C-4a0a-96F8-14644F340D60}
Java Console
6.0.30
false
{CAFEEFAC-0016-0000-0030-ABCDEFFEDCBA}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://www.google.com/ig
browser.startup.homepage_override.buildID
20111220165912
browser.startup.homepage_override.mstone
rv:9.0.1
browser.tabs.warnOnClose
false
dom.disable_open_during_load
false
extensions.lastAppVersion
9.0.1
general.useragent.extra.brc
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1325799138
places.history.expiration.transient_current_max_pages
104858
places.history.expiration.transient_optimal_database_size
167772160
plugin.disable_full_page_plugin_for_types
application/pdf
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
AMD Radeon HD 6700 Series
Vendor ID
1002
Device ID
68b8
Adapter RAM
1024
Adapter Drivers
aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Driver Version
8.850.0.0
Driver Date
4-19-2011
Adapter RAM (GPU #2)
Unknown
Adapter Drivers (GPU #2)
Unknown
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17563)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Google Inc. -- ANGLE (AMD Radeon HD 6700 Series) -- OpenGL ES 2.0 (ANGLE 0.0.0.809)
GPU Accelerated Windows
1/1 Direct3D 10

the-edmeister
  • Top 10 Contributor
  • Moderator
3193 solutions 24378 answers

{Shft + F4} opens the Scratchpad - could you be inadvertently triggering it with that key combo?

Question owner

I saw that shortcut, but I don't think that's the problem. On my keyboard, the F4 is relatively out of reach. But it makes me wonder if I inadvertently made some kind of other shortcut on the keyboard that's triggering it. I know it happens when I use shift + a letter to start a sentence or fill in a form, but I haven't paid attention to what the letter is. I need to figure out if I can clear any existing shortcuts and see if that clears it up.

TorreyLisa 0 solutions 5 answers

I am having the same problem, likely triggered from a recent upgrade to Firefox. Every time I hit the SHIFT key to author anything, it opens the scratchpad. Very annoying. I don't want to disable Java completely...so how can this feature be disabled entirely? Everything I've found tells you how to access it (ie, SHIFT+F4) but not how to UNDO it.

Help? Anyone?

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Various Web Developer tools each have their own pref on the about:config page to enable or disable them.

  • devtools.scratchpad.enabled
  • devtools.inspector.enabled

You can search for devtools via the Search bar at the top of the about:config page.

You can set the Boolean pref devtools.scratchpad.enabled to false on the about:config page to disable the Scratchpad.

Modified by cor-el

TorreyLisa 0 solutions 5 answers

I changed the 'enabled' to the following:

devtools.scratchpad.enabled;false devtools.inspector.enabled;false

And it is still happening. :(

Any more ideas? Thanks for trying!

Modified by TorreyLisa

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Start Firefox in Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

TorreyLisa 0 solutions 5 answers

You have been so patient and helpful, so thank you.

Unfortunately, it is already on the default theme (13.0.1)

I took the liberty of resetting my Firefox to default settings and it still isn't removing this annoying scratchpad! It's stuck like glue. :(

I am hoping to get this fixed so thanks for being so patient while I try each of your suggestions.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

I'm not seeing the Scratchpad in the menu after disabling the pref and closing and restarting Firefox and the Shift+F4 shortcut doesn't work as well.

TorreyLisa 0 solutions 5 answers

Strange. I am wondering if it isn't even attached to Firefox then? It's still present. I have definitely restored to default, changed the preferences to devtools to false, restarted, etc. This is such a pain. :(

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Does this only happen if you press specific keys?


You can try to reset Firefox.

Reset creates a new profile and tries to import some settings from the old profile leaving the old profile intact.

TorreyLisa 0 solutions 5 answers

Any time I open a new email, comment on FB or any other application, the moment I hit the SHIFT key and ANY LETTER it opens the scratchpad.

As noted above I already reset Firefox back to default settings. Then I went back again to the devtools and selected "false" to disable those features. They had changed back to 'true' after I had done the reset.

Thanks again for being so patient.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Yes, that happens because a reset creates a new profile and all the settings have the default.

Which security software (firewall, anti-virus) do you have?


You can try a clean reinstall and delete the Firefox program folder (C:\Program Files\Mozilla Firefox\).

Download a fresh Firefox copy and save the file to the desktop.

Uninstall your current Firefox version, if possible.

  • Do NOT remove personal data when you uninstall your current Firefox version, because all profile folders will be removed and you will also lose your personal data like bookmarks and passwords from profiles of other Firefox versions.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

Your bookmarks and other profile data are stored elsewhere in the Firefox Profile Folder and won't be affected by a reinstall, but make sure that you do not select to remove personal data if you uninstall Firefox.


cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

If pressing the Shift key is sufficient to open the Scratchpad then you may have a sticky F4 key that Firefox sees as pressed.
You can try to press the F4 key a few times to see if that fixes it or try to reboot the computer or try a different keyboard.