X
Tap here to go to the mobile version of the site.

Support Forum

javascript: is not working properly after update

Posted

Greetings,

I'm currently experiencing a problem using JavaScript with Firefox. I can load fine JavaScript in the website, and it's enabled and everything. In that sense, JavaScript is fine.

However, when I try to run a JavaScript with the "command", "javascript:" in the browsing bar, it doesn't works anymore. I can't even do simple stuff like "javascript: alert("Hi!");". I wish to know if there is some way to fix this. I do use this "feature" pretty often to test small scripts.

Thanks.

Greetings, I'm currently experiencing a problem using JavaScript with Firefox. I can load fine JavaScript in the website, and it's enabled and everything. In that sense, JavaScript is fine. However, when I try to run a JavaScript with the "command", "javascript:" in the browsing bar, it doesn't works anymore. I can't even do simple stuff like "javascript: alert("Hi!");". I wish to know if there is some way to fix this. I do use this "feature" pretty often to test small scripts. Thanks.

Chosen solution

Running javascript: in the browsing bar is disabled for security. Users were installing malware. You can use the new feature called scratchpad for this instead.

Read this answer in context 1

Additional System Details

This happened

Every time Firefox opened

This started when...

Since I updated to 6.0.

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.3"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Pando Web Plugin
  • Shockwave Flash 10.3 r183
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • Yahoo Application State Plugin version 1.0.0.7
  • 4.0.60531.0
  • Nexon Game Controller

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.1) Gecko/20100101 Firefox/6.0.1

More Information

knorretje 161 solutions 582 answers

Chosen Solution

Running javascript: in the browsing bar is disabled for security. Users were installing malware. You can use the new feature called scratchpad for this instead.

Running javascript: in the browsing bar is disabled for security. Users were installing malware. You can use the new feature called scratchpad for this instead.

Question owner

Thanks a lot! It's not as good as the previous one since it's a bit annoy to change window, but, it works for my propose!

Solved ^^

Thanks a lot! It's not as good as the previous one since it's a bit annoy to change window, but, it works for my propose! Solved ^^
ankurtyagi 0 solutions 1 answers

but it creating problem for site that use javascript... for eg. yahoo

but it creating problem for site that use javascript... for eg. yahoo
Alexandrandjohnny 0 solutions 2 answers

Youtube says : An error has ocurred,please try again later. Picmonkey ( PhotoEditor) Not loading. It's been 4 days now,I installed all my updates,Youtube works with Internet Explorer browser but not with Firefox wich is the one I use, picmonkey works also there but I can't just slide the picture into it,I have to browse it from the folder,it's disturbing PLEASE HELP. I have the latest Flash,real player,firefox updates.

Youtube says : An error has ocurred,please try again later. Picmonkey ( PhotoEditor) Not loading. It's been 4 days now,I installed all my updates,Youtube works with Internet Explorer browser but not with Firefox wich is the one I use, picmonkey works also there but I can't just slide the picture into it,I have to browse it from the folder,it's disturbing PLEASE HELP. I have the latest Flash,real player,firefox updates.
cor-el
  • Top 10 Contributor
  • Moderator
12764 solutions 117276 answers

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).


This may be caused by a recent Flash 11.3 update.

See:

Clear the cache and the cookies from sites that cause problems. "Clear the Cache": *Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now" "Remove Cookies" from sites causing problems: *Tools > Options > Privacy > Cookies: "Show Cookies" Start Firefox in <u>[[Safe Mode]]</u> to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes). *Don't make any changes on the Safe mode start window. *https://support.mozilla.org/kb/Safe+Mode ---- This may be caused by a recent Flash 11.3 update. See: *https://support.mozilla.org/kb/keep-flash-up-to-date-and-troubleshoot-problems *https://support.mozilla.org/kb/flash-crashes-or-does-not-load-firefox-13 *http://forums.adobe.com/thread/1018071?tstart=0 *http://blogs.adobe.com/asset/2012/06/inside-flash-player-protected-mode-for-firefox.html