X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox browser constantly lagging and not responding

Posted

It does it on any site I visit. I have tried clearing my cashe and cookies. It has gotten to the point I can't do anything becasue it stops responding. This started when I had version 3.5 and has continued since I upgraded to the newst version. It is only Firefox and not my other browsers so I don't see how it is my computer. Anything I can do to make it stop and work properly?


The reason mine was doing it was becasue of the add-ons. I deleted them all and only reinstalled AdBlock Plus, no script, request policy, and the video downloader. I have not had a problem since. It was either Mr Tech Toolkit or the personas. :(

Modified by ika_hinotama

Additional System Details

This happened

Every time Firefox opened

This started when...

A few weeks ago but has just gotten worse.

Installed Plug-ins

AdBlock Plus, Mr Tech toolkit, NoScript, Request policy, Download helper, personas

Application

  • User Agent:

More Information

It will not even respond long enough for me to try. :(

Question owner

Wow 28 people and no one as a solution.  :(

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).

  • Don't make any changes on the Safe mode start window.

See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems and Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

Also make sure that Firefox and the plugin-container process have full, unrestricted, access to internet.


Tonbaby 0 solutions 1 answers

Helpful Reply

I did restart in safe mode, myself. I cleared all the cookies and the browsing history, I took out all the bookmarks (after printing them out) and that didn't help. I've had Windows 7 for about 6 months, now. There weren't any problems at all until just recently. It started with Firefox lagging, hanging and becoming just generally unresponsive. Then, even after switching to other browsers, which are driving me insane, windows explorer began restarting constantly. There was no stopping it. I let the compy run a diagnostic on the memory...no probs. I ran a few deep virus scans...no probs. I restarted in safe mode, still had the prob. When I removed all the start up programs, save for the essentials, everything worked great. This meant it's a 3rd party problem...but figuring out which one was a pain. At a person's suggestion, I deleted everything that had to do with Firefox and my problem completely resolved. Problem is...I want Firefox BACK!!! I'm going crazy with these other, inadequate browsers. My general point here is, everything was working great until a few weeks ago...the only difference I can think of is updates! If anyone else had any ideas, please, let me know. I started a thread on this and a couple of people have reported the same problem, but there aren't any solutions or ideas as of yet.

comet1 0 solutions 1 answers

Helpful Reply

This was driving me to use another computer not suffering the same hangups. So when bored I'd read posts and play with possible solutions.

I ended up going to Firefox, opening Tools -- Addons -- Extensions and disabling groups of Extensions for a test.

What worked for me was disabling all the older version Java Consoles except the latest one I had loaded which was 6.0.22.

Miracles happen, so far 2 days of speedy Firefox again. Sometimes it's just a crap shoot and you get lucky. Of course no guarantee it'll work for you too, there never is, but it was an easy enough thing to try.

Good Luck!

urlybird 0 solutions 2 answers

THANKYOU! This worked for me. What a RELIEF! I was really frustrated. Well done Comet1. Karma points coming your way.

urlybird 0 solutions 2 answers

That solution was shortlived. Initially it seemed faster and problem-free but within 15 minutes, same problem - not responding, but this time my computer crashed. Back to the drawing board.

Omegaphoenix 0 solutions 1 answers

of all the things i've tried, this was awesome! thanks, man. so far so good!

eni8ma 0 solutions 7 answers

I am finding that implementing the solution at this page is helping so far: http://support.mozilla.com/en-US/kb/Firefox%20hangs#w_hang-after-prolonged-use

In Preferences > General > Main

In the "When Firefox starts" drop-down, select "Show my windows and tabs from last time"

Then from time to time, I shut down Firefox completely, and let it rest for a bit before I open it again.

I've been doing that for a couple of days now, and so far, so good.

I did clear the cache, and uninstall some tools I wasn't using, but that didn't seem to help any. It was only when I followed the suggestion I've just described that the system started to settle down.

Krostog 0 solutions 3 answers

I had the same problem as well (though much worse, Firefox Beta 11, but it is not the beta's fault, as i switched versions several times and kept the problem). A possible cause can be Mcafee, which can be easily fixed by changing the security level of firefox from "Outgoing Access" (badly translated from dutch to english, my apologies for that)", which only lets programs send information, and not recieve, to "full access" which lets programs recieve information as well.

Do note that this may make your computer somewhat more vulnerable, so either look if the cause is something else, or take the chance.

Modified by Krostog

Sara_Tonyn 0 solutions 2 answers

I just posted this elsewhere on the site but it may be of assistance to someone here so I'll repost it:

POSSIBLE SOLUTION (it worked for me!)

From what I've read on different forums there may be several different causes for the hanging/not responding problem but here's the one that was guilty in my case:

ADOBE READER 9 ... which I downloaded (and soon found out I didn't have any use for) right before my Firefox prob started.

There's no uninstall program built into ADOBE READER 9, so I downloaded and used Myuninstaller and it did the trick! ADOBE READER 9 is all gone and I have had no further hanging/not responding messages when using Firefox.

Here's a link to Myuninstaller. You may want to download it for future use if nothing else. It's really smooth and easy!

http://download.cnet.com/MyUninstaller/3000-2248_4-10549224.html

Hope this helps! Good luck!

jeane99 0 solutions 2 answers

this worked for me.

"This workaround is recommended:

  1. When Firefox is started,launch the Windows Task Manager (press CTRL+ALT+DEL, or right click the clock display on the Windows Taskbar and select Task Manager)
  2. Select the process tab
  3. Locate and right-click on the Firefox process
  4. Select the set affinity option from the popup menu
  5. Uncheck CPU 1 and validate with OK.
  6. You can go back to Firefox. "

http://forums.mozillazine.org/viewtopic.php?t=270174

thanks awaysale.

Modified by jeane99

marfis 0 solutions 1 answers

wats wrong to firefox4???????? its really stubborn like a cold girl advising nevr go to street again but she did sneakly.... so if any engineer reading this post please help..... i dnt want my computer give a heart-attack!!!!

djqcquinn 0 solutions 2 answers

I think I may have solved this issue - as I have had the same issues with firefox 4.....

The steps I took to solve the problem....

1) Open Control Panel and select "Uninstall a Program" 2) Find Mozilla Firefox in the list then click on Firefox to highlight it and click the Uninstall button. (No need to delete bookmarks or settings during uninstall) 3) Open Internet Explorer (I know, I know) or Chrome and redownload Firefox. 4) Install Firefox 4 again. 5) Reboot System. 6) Open Firefox and come to this website and make the website check your Add-Ons. 7) You will find you need a Java update to 6u25 and a Shockwave update to version 11.blah.blah.blah 8) Install both of these updates. 9) Reboot then again check for updates (there should be none now (or the silly research me ones) which I always leave alone). 10) Should be cooking on gas again - mine is now running again like Usain Bolt on Steroids.

Please let me know if this works for you aswell; as I have quite a high-spec machine and have never come across this problem before - I can only assume that a Firefox automatic update somehow didn't get along with either the previous Shockwave or Java version.

Regards, djqcquinn

djqcquinn 0 solutions 2 answers

O and one last thing, if you are running the AVG professional toolbar like myself, you will get a slight delay between pages as AVG checks the page before it allows it to be displayed.

Toodlepip!

net500cg 0 solutions 1 answers

Interesting 'repair' .. or should I say cludge ... djqcquinn. Not that I am being a SA here at all. It's just that I don't see WHY anyone using FF should have to be an acrobatic contortionist to get FF to work without a 'Not Responding' note all the time.

There MUST be a better repair to this than a 'Hail Mary' uninstall/reinstall !!!!

Please! Someone in 'official capacity' at Mozilla get involved in solving this. I've been experiencing this rotten malfunction since the last 4.0x update. I had hoped installing 5.0 would remove the plague. But it has not. In fact, it's worse than ever!

I've been using FF since it first arrived on the seen .. and Mozilla before that. So, when a trusted tool begins to bite and growl and misbehave... it's very disconcerting.

H E L P !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Frustrated in Hoosierville!

donpb2 0 solutions 4 answers

Firefox 5 was becoming hung/unresponsive quite often which had been literally driving me bonkers for months and seemed to first start occurring with the 4.01 beta release.

I then tried all the above aforementioned solutions with much hopes and dreams but to no avail. The problem ended up being a corrupted places.sqlite file. I simply renamed the file and that fixed it. See here for details.

Modified by donpb2

tlisiewicz 0 solutions 1 answers

I was playing QuakeLive plugin in FF4, 5, then 6 and there was sometime a lagging period, especially when I left my browser open and hibernated Win7 several times. After that it just starts to hang up, freeze every 3-6second... its annoying.

I figured out that changing process priority of QuakeLive (plugincontainer.exe loaded by FF) DID make a change. I had no more lagging in a game!

I hope that changing firefox.exe process priority to High will make a difference too. ALSO its important to not have any processes with priority higher than Normal.

Cheers Tom

Brackloona 0 solutions 1 answers

I disabled Java Console 6.0.19 in the add-ons, nothing else, and instantly gained my speed back. Let's see how it fairs over the next few days

AlexSea 0 solutions 1 answers

Are you using Firefox Sync? I had the same problem but now it's gone since I unchecked History and Tabs from "Sync My" list. Try doing that in Options-Sync. (EDIT: Maybe I spoke too soon. Non-responsiveness is still happening but the frequency seems to have gone down a little bit.)

Modified by AlexSea