X
Tap here to go to the mobile version of the site.

Support Forum

Firefox browser constantly lagging and not responding

Posted

It does it on any site I visit. I have tried clearing my cashe and cookies. It has gotten to the point I can't do anything becasue it stops responding. This started when I had version 3.5 and has continued since I upgraded to the newst version. It is only Firefox and not my other browsers so I don't see how it is my computer. Anything I can do to make it stop and work properly?


The reason mine was doing it was becasue of the add-ons. I deleted them all and only reinstalled AdBlock Plus, no script, request policy, and the video downloader. I have not had a problem since. It was either Mr Tech Toolkit or the personas. :(

It does it on any site I visit. I have tried clearing my cashe and cookies. It has gotten to the point I can't do anything becasue it stops responding. This started when I had version 3.5 and has continued since I upgraded to the newst version. It is only Firefox and not my other browsers so I don't see how it is my computer. Anything I can do to make it stop and work properly? The reason mine was doing it was becasue of the add-ons. I deleted them all and only reinstalled AdBlock Plus, no script, request policy, and the video downloader. I have not had a problem since. It was either Mr Tech Toolkit or the personas. :(

Modified by ika_hinotama

Additional System Details

This happened

Every time Firefox opened

This started when...

A few weeks ago but has just gotten worse.

Installed Plug-ins

AdBlock Plus, Mr Tech toolkit, NoScript, Request policy, Download helper, personas

Application

  • User Agent:

More Information

It will not even respond long enough for me to try. :(

Prince_c3 0 solutions 1 answers

Well, it really sad to say but I have been using Firefox since when it started. I like the features they add every now and then but after 4.5 plus versions, Firebox is going in drain honestly. Firefox according to the Maximum PC magazine was number one and loosing its place really fast, because of IE 8 and IE 9 now. Finally after having so many bullshit issues with Firefox and no solution in sight I reluctantly downloaded IE 8.0 and I wasn't expecting much from IE, but believe me I was amazed to see the speed and all the functionality which I have been using with Firefox over the years with the exception of no lagging and no bullshit crappy Firefox "Not Responding" freeze window. IE 8.0 is not only lighting fast to test the browser I opened 10 tabs, believe me I opened 10 tabs with netflix, Wikipedia, big picture and all those websites which download pics and take lots of CPU just to see whether it freeze the hell like FF, but alas with slight lagging all the windows are working so fast and their I decided to divorce my long time wife Firefox. But still I can take Firefox back if they really come up with no bullshit version which should be better than 5.0, with all the fixes. So far Firefox 5.o having these issues, I mean these are major issues I am not putting lots of smaller one. 1. I cant open two to three tabs without Firefox getting freeze. 2. Every two minutes its shows Firefox not responding window and freeze up. 3. Cant watch Youtube, Netflix without Firefox crashing 100 times. 4. First time after crash it come up with previous tabs only to freeze again. 5. But on second and subsequent crashes it come up with a message that Firefox is embarrassed that it could not able to open the previous windows, I say be embarrassed and shame on your browser. 6. Cant open two tabs having pictures, it freezes. 7. Not able to bring the stored passwords on occasions unless I have to close and open the browser. Whats the point in storing passwords then. 8. Every time my CPU shows 100%, I check the task manager and always found Firefox the biggest CPU hog with more than 60% CPU being consumed by it. With just two websites open Firefox consumes around 60% CPU, its ridiculous. With IE 8.0 I opened 6 tabs and found that CPU consumption between 10-15%. Firefox is a JOKE.


Overall, I believe IE8.0 and IE 9.0 are the best browser I have tested and second place is Chrome though I don't like Chrome and I believe Firefox which was number 1 till two to three months back are in drain and don't know what number 3 or 4.

Also note that I am posting this reply from IE 8.0, If I have to use Firefox then I have to spend some 30-40 Mins because it will freeze and crash some 10 times during this time.

All the best Firefox for your shitty browser.

Well, it really sad to say but I have been using Firefox since when it started. I like the features they add every now and then but after 4.5 plus versions, Firebox is going in drain honestly. Firefox according to the Maximum PC magazine was number one and loosing its place really fast, because of IE 8 and IE 9 now. Finally after having so many bullshit issues with Firefox and no solution in sight I reluctantly downloaded IE 8.0 and I wasn't expecting much from IE, but believe me I was amazed to see the speed and all the functionality which I have been using with Firefox over the years with the exception of no lagging and no bullshit crappy Firefox "Not Responding" freeze window. IE 8.0 is not only lighting fast to test the browser I opened 10 tabs, believe me I opened 10 tabs with netflix, Wikipedia, big picture and all those websites which download pics and take lots of CPU just to see whether it freeze the hell like FF, but alas with slight lagging all the windows are working so fast and their I decided to divorce my long time wife Firefox. But still I can take Firefox back if they really come up with no bullshit version which should be better than 5.0, with all the fixes. So far Firefox 5.o having these issues, I mean these are major issues I am not putting lots of smaller one. 1. I cant open two to three tabs without Firefox getting freeze. 2. Every two minutes its shows Firefox not responding window and freeze up. 3. Cant watch Youtube, Netflix without Firefox crashing 100 times. 4. First time after crash it come up with previous tabs only to freeze again. 5. But on second and subsequent crashes it come up with a message that Firefox is embarrassed that it could not able to open the previous windows, I say be embarrassed and shame on your browser. 6. Cant open two tabs having pictures, it freezes. 7. Not able to bring the stored passwords on occasions unless I have to close and open the browser. Whats the point in storing passwords then. 8. Every time my CPU shows 100%, I check the task manager and always found Firefox the biggest CPU hog with more than 60% CPU being consumed by it. With just two websites open Firefox consumes around 60% CPU, its ridiculous. With IE 8.0 I opened 6 tabs and found that CPU consumption between 10-15%. Firefox is a JOKE. Overall, I believe IE8.0 and IE 9.0 are the best browser I have tested and second place is Chrome though I don't like Chrome and I believe Firefox which was number 1 till two to three months back are in drain and don't know what number 3 or 4. Also note that I am posting this reply from IE 8.0, If I have to use Firefox then I have to spend some 30-40 Mins because it will freeze and crash some 10 times during this time. All the best Firefox for your shitty browser.

Modified by Prince_c3

tedellis 0 solutions 1 answers

Performed some updates in the last few days - possibly to Firefox itself (I do too much to remember - now at 3.6.9) - definitely to some of the add-ons. Problems ever since. I have now disabled all but the essential add-ons (pretty much all of them) and everything fine again. When I have the time I will investigate which one caused the problem.

Performed some updates in the last few days - possibly to Firefox itself (I do too much to remember - now at 3.6.9) - definitely to some of the add-ons. Problems ever since. I have now disabled all but the essential add-ons (pretty much all of them) and everything fine again. When I have the time I will investigate which one caused the problem.
finitarry 251 solutions 3421 answers

Another thing you might try is removing the cache directory (not just emptying the cache). Sometimes that helps. It seems you have tried everything but a new profile, so I think that should be the next step if removing the cache directory and getting a new one built does not help. Back up your bookmarks first.

Another thing you might try is removing the cache directory (not just emptying the cache). Sometimes that helps. It seems you have tried everything but a new profile, so I think that should be the next step if removing the cache directory and getting a new one built does not help. Back up your bookmarks first.
LunaWolf 0 solutions 3 answers

I had the same problem and couldn't figure out what the problem was. I went to Tools: Options: Manage Add-Ons and went to my plugins, and disabled the Java Deployment Toolkit and it seems to have solved the problem. I hope this helps.

I had the same problem and couldn't figure out what the problem was. I went to Tools: Options: Manage Add-Ons and went to my plugins, and disabled the Java Deployment Toolkit and it seems to have solved the problem. I hope this helps.
crm911 0 solutions 9 answers

I have this in FIrefox 6.0 as well. I am trying the suggestion to remove affinity with one of the four CPUs I have. Too early to say if that works. I cannot remove the older Java consoles because all of them are greyed out.

I have this in FIrefox 6.0 as well. I am trying the suggestion to remove affinity with one of the four CPUs I have. Too early to say if that works. I cannot remove the older Java consoles because all of them are greyed out.
igr7 0 solutions 4 answers

I have tried ever one of the suggestions on here. None work. I am now using IE8

I have tried ever one of the suggestions on here. None work. I am now using IE8

Question owner

The reason mine was doing it was becasue of the add-ons. I deleted them all and only reinstalled AdBlock Plus, no script, request policy, and the video downloader. I have not had a problem since.

The reason mine was doing it was becasue of the add-ons. I deleted them all and only reinstalled AdBlock Plus, no script, request policy, and the video downloader. I have not had a problem since.

Question owner

Prince_c3 if you hate FF then why post in the forums? Also IE's security is a joke and using that browser is like asking to be hacked. :(

Prince_c3 if you hate FF then why post in the forums? Also IE's security is a joke and using that browser is like asking to be hacked. :(

Modified by ika_hinotama

Vegeta100 0 solutions 8 answers

i cant see it: Can't find any servers to help you

The mozillazine servers seem to be on strike. The systems team is negotiating...

Please try again later

[this used to be the "drupal.org error"]

i cant see it: Can't find any servers to help you The mozillazine servers seem to be on strike. The systems team is negotiating... Please try again later [this used to be the "drupal.org error"]
red_android 0 solutions 1 answers

I had the same problem. My FF 6.0 is loading CPU to 50% every 2 minutes without any open pages. This lag continued exactly 30 sec. It happens on all my 3 computers, including one Mac. When I complete uninstalled FF, then installed again - no problem on a clean FF with the same addons and plugins and without sync. But as I set up sync again, the problem come back. Turning sync off (deactivate computer) gives nothing. Next, after one reinstalling, I have synced ONLY bookmarks and passwords. The lags go out. Then I added preferences to sync. All is OK. Then I added history (3 records after install). All is OK. Then I added tabs. All's good! I.e. the trouble was - my old history. Not my, firefox's. After it, I launched FF on Mac, sync, relaunch. No lags at all. May be it can be solved by simply cleaning cash and history, but I don't want to experiment onwards.

I had the same problem. My FF 6.0 is loading CPU to 50% every 2 minutes without any open pages. This lag continued exactly 30 sec. It happens on all my 3 computers, including one Mac. When I complete uninstalled FF, then installed again - no problem on a clean FF with the same addons and plugins and without sync. But as I set up sync again, the problem come back. Turning sync off (deactivate computer) gives nothing. Next, after one reinstalling, I have synced ONLY bookmarks and passwords. The lags go out. Then I added preferences to sync. All is OK. Then I added history (3 records after install). All is OK. Then I added tabs. All's good! I.e. the trouble was - my old history. Not my, firefox's. After it, I launched FF on Mac, sync, relaunch. No lags at all. May be it can be solved by simply cleaning cash and history, but I don't want to experiment onwards.
Vegeta100 0 solutions 8 answers

it works firefox 6 Uncheck CPU 1 and validate with OK. but do i have to do it every time??

it works firefox 6 Uncheck CPU 1 and validate with OK. but do i have to do it every time??
Cyber Spyder 0 solutions 3 answers

I have been having the same problem, one thing i do notice when i bring up the task manager (CTRL+ALT+DEL) is the PLUGINCONTAINER is always running when it happens... as soon as i choose to END TASK on PLUGINCONTAINER firefox pops right back into action and all is well.

Windows XP SP3 Firefox 6.0 Sony Vaio 3.2 ghz with 2 gigs ram ATI Radeon X300/X550/X1050 Series

P.S. At the top of this page i clicked the button "I'm having this problem too" and got a java type looking grey and white box saying "THERE WAS AN ERROR" with no other explanation whatsoever. I agree with one of the other posters... Firefox is going downhill fast... maybe the not responding is them trying to apply the brakes. I did not have these problems in the last installment of firefox and i have not installed anything or altered my pc at all in the interim. Good Luck

I have been having the same problem, one thing i do notice when i bring up the task manager (CTRL+ALT+DEL) is the PLUGINCONTAINER is always running when it happens... as soon as i choose to END TASK on PLUGINCONTAINER firefox pops right back into action and all is well. Windows XP SP3 Firefox 6.0 Sony Vaio 3.2 ghz with 2 gigs ram ATI Radeon X300/X550/X1050 Series P.S. At the top of this page i clicked the button "I'm having this problem too" and got a java type looking grey and white box saying "THERE WAS AN ERROR" with no other explanation whatsoever. I agree with one of the other posters... Firefox is going downhill fast... maybe the not responding is them trying to apply the brakes. I did not have these problems in the last installment of firefox and i have not installed anything or altered my pc at all in the interim. Good Luck

Modified by Cyber Spyder

sanexp 0 solutions 1 answers

I'm almost sure this is JAVA's fault!!! I tried everything, disabled all addons; deleted FX completely and reinstalled with a whole new profile; upgraded to FX7b2; disable java console, Java deployment toolkit, java platform and uninstall JRE6.27; tried new profile in FX7b2 with no addons and plugins; downgraded to FX6, and after all the efforts, I formatted the disk and reinstalled win7. this was the point that I gained the normal FX back. i ran three days without any problem until i install JRE 6.27. The not-responding problem CAME AGAIN the moment I restart FX.

I will roll back to jre6.23 as suggested here to see if the problem could be solved. I just write to express how much I hate JAVA now!!!

I'm almost sure this is JAVA's fault!!! I tried everything, disabled all addons; deleted FX completely and reinstalled with a whole new profile; upgraded to FX7b2; disable java console, Java deployment toolkit, java platform and uninstall JRE6.27; tried new profile in FX7b2 with no addons and plugins; downgraded to FX6, and after all the efforts, I formatted the disk and reinstalled win7. this was the point that I gained the normal FX back. i ran three days without any problem until i install JRE 6.27. The not-responding problem CAME AGAIN the moment I restart FX. I will roll back to jre6.23 as suggested here to see if the problem could be solved. I just write to express how much I hate JAVA now!!!
FreeSoul 0 solutions 1 answers

Hey guys. I sweeped the internet for ages trying to find an answer to this and I finally found it! Going on peoples generic advise didn't work for me, I did all the disabling of extentions, disabling CPU 1 processor affinity, but was still gettng the problems. I then decided to try a completely new profile for firefox by typing in "firefox.exe -ProfileManager" in the windows run box, created a new profile and set it to start as standard. I then copied over all my bookmarks and password history and BOOM, it's all working like a well oiled machine now! I hope this helps anyone else going through the same annoyance as me. If this helped then please make sure to click the "Helpful" button to get this reply to the top, so it can help others too. I think after so long using firefox and hacking about:config took its toll, but I'm so happy to finally get my trusted browser working again, rather than having to go to chrome which was going to be my last resort, thankfully I avoided that!

Hey guys. I sweeped the internet for ages trying to find an answer to this and I finally found it! Going on peoples generic advise didn't work for me, I did all the disabling of extentions, disabling CPU 1 processor affinity, but was still gettng the problems. I then decided to try a completely new profile for firefox by typing in "firefox.exe -ProfileManager" in the windows run box, created a new profile and set it to start as standard. I then copied over all my bookmarks and password history and BOOM, it's all working like a well oiled machine now! I hope this helps anyone else going through the same annoyance as me. If this helped then please make sure to click the "Helpful" button to get this reply to the top, so it can help others too. I think after so long using firefox and hacking about:config took its toll, but I'm so happy to finally get my trusted browser working again, rather than having to go to chrome which was going to be my last resort, thankfully I avoided that!
RKFan26 0 solutions 2 answers

FreeSoul's tip worked for me! I would recommend doing that.

FreeSoul's tip worked for me! I would recommend doing that.
odettegreyling 0 solutions 1 answers

POSSIBLE SOLUTION! This is what worked for me.

I went to ad-ons and was that iwin games is not compatible with this version of ff and has been disabled, but i guess that is not enough, so I uninstalled it. I also uninstalled all the iwin games. Next I uninstalled the touch call for skype as it was HUGE in any case. I also uninstalled microsoft silverlight as it seemed VERY redundant and i have no been playing games and opening and closing new tabs and going crazy trying to freeze my ff and so far... so good :). but with this version I don't want to put the cart before the horse you know. Just for some extra info, I'm on Windows 7 if that makes any difference in terms of comparability.

POSSIBLE SOLUTION! This is what worked for me. I went to ad-ons and was that iwin games is not compatible with this version of ff and has been disabled, but i guess that is not enough, so I uninstalled it. I also uninstalled all the iwin games. Next I uninstalled the touch call for skype as it was HUGE in any case. I also uninstalled microsoft silverlight as it seemed VERY redundant and i have no been playing games and opening and closing new tabs and going crazy trying to freeze my ff and so far... so good :). but with this version I don't want to put the cart before the horse you know. Just for some extra info, I'm on Windows 7 if that makes any difference in terms of comparability.
IamCree 0 solutions 1 answers

I've had this same problem. According to some of the posts here, it looked like Firefox updates were not compatible with some of the old plugins etc. I didn't feel like a drastic fix effort, so I just went under Tools>Addons>Plugins and clicked the link at the top to check if all my plugins were updated. Firefox had disabled Flash because it was an old version, so I updated that. So far, everything is back to normal and working fast. It might not be a fix for everyone, but I'd check for elements that aren't compatible with the latest versions of Firefox. Bad form though, FF!

I've had this same problem. According to some of the posts here, it looked like Firefox updates were not compatible with some of the old plugins etc. I didn't feel like a drastic fix effort, so I just went under Tools>Addons>Plugins and clicked the link at the top to check if all my plugins were updated. Firefox had disabled Flash because it was an old version, so I updated that. So far, everything is back to normal and working fast. It might not be a fix for everyone, but I'd check for elements that aren't compatible with the latest versions of Firefox. Bad form though, FF!

Modified by IamCree

Durgan 0 solutions 4 answers

Number One. Firefox should be on this problem with both feet. I have had the problem for about a week, and read all the convoluted replies. I do not want to do the programming for Firefox.

Here is how I solved the problem.

In Firefox.

Tools, Add ons. I disabled all add ons. Presto The "not responding" is gone.

I will eventually eliminate the add on creating the problem, but am so happy to get the browser working, that I will operate without the add ons until I feel like disabling one at a time.

Flash Player Shockwave Flash 10.1.53.64 is the culprit. I removed and tried to install a later version, but it won't initialize. So now have another problem.

I eventually installed the latest version of flash player and the problem of "not responding" is still present. So now I have no media player integrated with Firefox.

Serious problem. Firefox and Adobe should get on this case. Dead silence from both to date.

Number One. Firefox should be on this problem with both feet. I have had the problem for about a week, and read all the convoluted replies. I do not want to do the programming for Firefox. Here is how I solved the problem. In Firefox. Tools, Add ons. I disabled all add ons. Presto The "not responding" is gone. I will eventually eliminate the add on creating the problem, but am so happy to get the browser working, that I will operate without the add ons until I feel like disabling one at a time. Flash Player Shockwave Flash 10.1.53.64 is the culprit. I removed and tried to install a later version, but it won't initialize. So now have another problem. I eventually installed the latest version of flash player and the problem of "not responding" is still present. So now I have no media player integrated with Firefox. Serious problem. Firefox and Adobe should get on this case. Dead silence from both to date.

Modified by Durgan

Sasssysweeet 0 solutions 5 answers

Okay, almost 4,000 people with this problem and it's still not fixed. Really sad. Mozilla is honestly the only browser app that use. I've tried others but they don't offer what Firefox offers. Having said that, this is really upsetting me. It's delaying my projects. I'm almost out of time on one of them and this is really holding me up. Please fix this. In the meantime I will try the add on disabling and see if that helps until an update is created. I hope it's soon because I'll miss my add ons. :-(

Okay, almost 4,000 people with this problem and it's still not fixed. Really sad. Mozilla is honestly the only browser app that use. I've tried others but they don't offer what Firefox offers. Having said that, this is really upsetting me. It's delaying my projects. I'm almost out of time on one of them and this is really holding me up. Please fix this. In the meantime I will try the add on disabling and see if that helps until an update is created. I hope it's soon because I'll miss my add ons. :-(
Durgan 0 solutions 4 answers

I solved the problem by installing Chrome Google. Now I have an integrated video player. I can no longer wait for Adobe or Firefox to solve their very real problem.

I solved the problem by installing Chrome Google. Now I have an integrated video player. I can no longer wait for Adobe or Firefox to solve their very real problem.