X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox browser constantly lagging and not responding

Posted

It does it on any site I visit. I have tried clearing my cashe and cookies. It has gotten to the point I can't do anything becasue it stops responding. This started when I had version 3.5 and has continued since I upgraded to the newst version. It is only Firefox and not my other browsers so I don't see how it is my computer. Anything I can do to make it stop and work properly?


The reason mine was doing it was becasue of the add-ons. I deleted them all and only reinstalled AdBlock Plus, no script, request policy, and the video downloader. I have not had a problem since. It was either Mr Tech Toolkit or the personas. :(

Modified by ika_hinotama

Additional System Details

This happened

Every time Firefox opened

This started when...

A few weeks ago but has just gotten worse.

Installed Plug-ins

AdBlock Plus, Mr Tech toolkit, NoScript, Request policy, Download helper, personas

Application

  • User Agent:

More Information

It will not even respond long enough for me to try. :(

Places2fish 0 solutions 16 answers

I've been having exactly the same problem, Firefox hanging and not responding with my hard drive going crazy since upgrading to the latest version. Really started to get to me now as its happening at the most critical times when I'm trying to get things done. May reluctantly have to change to another browser if this continues, have tried all the fixes to no avail and I just haven't got the time to be messing about with it. I do wonder though if it might be a conflict between Firefox and Java as both updates seem to have happened around the same time, also my Spam Filter Inbox Guardian which also uses Java decided to play up as well, I haven't got to the bottom of that either.

Modified by Places2fish

Places2fish 0 solutions 16 answers

I think I have at last got to the bottom of this problem 'Trusteer Rapport' security software provided by many online banks, which is supposed to protect you from online theft but unfortunately seems to constantly run in the background when first starting your computer/browser, hogging your CPU and interfering with your computer and browsers operation. I've found by switching it off one regains full control of the computer and browser.

wahahey 0 solutions 1 answers

I confess, I haven't read everything above but the solution I found was by using Safe Mode - browsing returned to normal speed. So I set about trying out different Add-Ons to see which was the culprit.

And here is the irony - the go-slow and non-responsiveness was caused by the Add-on/s "Page Speed" and/or "Yslow" (both used to test page load speeds).

Now disabled - i do not need them for normal browsing - everything works fine.

A note on Rapport: I had that installed for a while a year or so ago but it caused InDesign to crash without warning. I now wouldn't touch it with a barge pole as it clearly isn't tested comprehensively enough for professional users!

CH868 0 solutions 1 answers

I had the same problem with Firefox 8 and just upgraded to version 9. Does anyone experience the same problem with version 9 ?

winedog 0 solutions 2 answers

Still having this problem. The new firefox accelerated release program is a total disaster in my opinion

Crystalsno 0 solutions 12 answers

I am at work and running windows 7, my co worker on the same dsl connection is running windows xp. She is not having a slow or loading problem like I am. So I'm assuming it has something to do with windows 7. FIREFOX FIX IT OR I WILL RETURN TO IE!!!!!!!!!! Dang...first I have to deal with the almost terrifying takeover of Tmobile to AT&Terrible and now I have to deal with a slow loading FF. UGH!!!! I don't want to know what is coming next!!!! Dang...looks like 2012 is REALLY going to suck! Stop the world and let me off!!!!!!!!!!!!!

07724chris 0 solutions 1 answers

im using vista basic so dont think the prolem lies with win7, i have the version9 firefox and it has never een worse, to me everything was ok up to and including ff 6.5 but since then i have been getting the not responding often, but now it is nearly everytime i try loading any page. i did even think it was something to to with facebook as i spend alot of time on there and i know they have updated their servers, but no it seems any page i try loading has problem.

also, i dont know if its linked, but since updating to fireox 9, ive been getting alot of unresponsive scripts, im not a comp genius so dont know if thats linked or just something else on my laptop i need to sort out

Jim Fell 0 solutions 4 answers

I've had this same problem on one of my computers for a while too (now at version 9.0.1), and I've found that the problem pretty much goes away if you disable all of the load*InBackground features in about:config :

  • browser.tabs.loadBookmarksInBackground
  • browser.tabs.loadDivertedInBackground
  • browser.tabs.loadInBackground

Double-click on each of these to set to false, and you should be good to go.

Modified by Jim Fell

David Tenser
  • Administrator
  • Moderator
32 solutions 294 answers

This is a very old thread about Firefox 3.6 that people still seem to vote on. ika_hinotama, are you still using 3.6 or did you try to upgrade to 9.0.1? I'm tempted to lock this thread because it's unclear whether everyone who "me too"-ed this thread are really having the same problem as the original poster.

geniuzgrost232 1 solutions 3 answers

I already posted this solution in another thread in this blog... But well, no one hurts if I posted it again...

Hmmm... I believe some already have this solution... But, I want to re-post the solution i found in case somebody missing the solution to this problem...

Okay, The issue(correct Me if i'm wrong) : When you open mozilla firefox, surf for 2-3minutes and then the freezing/not responding will occur every 3 minutes or less. It say not responding, if you wait, it will take 30second - 2 minutes then it will be fine again.

If this is your issue, I have working solution.

Don't try to Install/Uninstall/Reinstall/Change version as it will be useless for this case.

The solution is actually must change the PROFILE. How to change the profile...? For Complete guide, I'm suggesting you Read this blog post as it contain screenshot or picture to aid you rather than a mere writing guide.

Note : Sometime Registry Fix may solve this problem, and disabling add-ons also may help. But, If you think you already try all method possible and has no luck, This might help you as I already confirm it. And it works most of the time.. 99.99%.

Read here : Fix Not Responding Mozilla Firefox or Change Mozilla Firefox Profile. Say thanks if it helps you!!!

John99
  • Top 25 Contributor
  • Moderator
622 solutions 7999 answers

One thing all of you may consider doing is turning on telemetry. Since Firefox 7 there has been a facility to allow firefox to report some of the performance data to mozilla. This includes information about startup times and hangs.

It is easyto do

Please remember this is an old thread, firefox and much other software has been updated since the thread started. For general information see also

diden 0 solutions 1 answers

I have the latest Firefox update 10.2 ... but this is so much lagging than IE, pliz firefox fix this thing up, I do love firefox coz I'm enjoy using it, but this bug cuz me no choice to switch another browser, PLease! :D

Cornelius Fichtner 0 solutions 1 answers

I have Firefox 10.0.2 installed and have been fighting this problem for about 4 days. I've found a solution that worked for me. The root cause of the problem is rather unexpected, but in hindsight it makes a lot of sense: There were bad sectors on my hard disk and files that Firefox wanted to access were located in these bad sectors. So every time FF tried accessing the files in those bad sectors it stopped responding and that slowed the complete system down. The whole thing seems so "obvious" now that I'm surprised that I didn't think of this sooner!

Here are the steps that I recommend you follow to resolve this:

1.) Locate your Firefox profile and make a backup by copying the complete directory onto a different hard disk. (I also made a copy to a USB flash drive.)

2.) Start the Firefox profile manager and delete your profile including all the files. This article explains how: http://kb.mozillazine.org/Profile_manager

3.) Manually verify that your profile directory has been deleted.

4.) Uninstall Firefox from your system.

5.) Download Advanced SystemCare Free from http://www.iobit.com/advancedsystemcareper.html, install it and then run a "Deep Care" on your system. Note that this step isn't necessarily required, but it helped me to identify some unrelated registry problems and it also deleted all the temporary internet files. So I do recommend that you run this or another type of "system care" software on your machine before proceeding. (Also... I'm not affiliated in any way with the developers of Advanced SystemCare Free)

6.) Check your C drive for errors:

6.1) Start "My Computer" (Windows Explorer), RIGHT-click on the C: drive and select "Properties" from the menu.

6.2) Now go to the "Tools" tab and click on the "Check now..." button under Error checking.

6.3) Make sure that both check-boxes are checked and click on "Start".

6.4) Most likely Windows will now tell you that it cannot perform this task while the disk is in use. Simply click on "Schedule Disk check".

7.) Restart your machine and a disk check will be performed upon start-up. As this check is progressing you may see messages about bad sectors and files in those sectors. Based on the names I saw I could tell that these were files used by Firefox. Note that it took a full 3 hours for my system to complete this, because of the bad sectors on the disc. So... BE PATIENT and let the check complete. At the end of this process your system has identified any bad sectors on the disk and will avoid them in the future.

8.) I decided to repeat steps 5, 6 and 7 above just to be safe...

9.) Reinstall Firefox. Restore your profile. My problem was resolved.

10.) Occasionally perform steps 6/7 again in the future to identify and resolve issues with bad sectors on your drive. I most certainly will.

Please let me know if this solution helped.

Cornelius Fichtner

Modified by Cornelius Fichtner

jakebe2 0 solutions 6 answers

I have had this problem on two computers running Firefox. I finally discovered that Carbonite Online Backup was what was causing my problem. My computers had AMD 4 core processors and I have 8GB of memory but for whatever reason Carbonite would bring it to a crawl at times. I can pause Carbonite and the problem goes away. Turn it back on and I'm at a crawl again. Just thought I'd post this in case anyone else has Carbonite running.

regularman 0 solutions 1 answers

After months of fighting this problem, trying every solution offered, deleting profiles and add-ons, and getting no support from Mozilla I've finally solved this problem. I just did a complete uninstall of Firefox and installed Chrome. Problem solved.

It's really too bad because I'd been using Firefox very happily for many, many years. Oh well ... change is good.

davesolo 0 solutions 2 answers

I found that the problem was a java script from Superfish at startup that was causing the hang while selecting bookmarks.

NoScript for blocking Superfish = no more problem.

John99
  • Top 25 Contributor
  • Moderator
622 solutions 7999 answers

Registry Cleaners Probably a general problem with the computer rather than a specific Firefox fix. Better discussed in some other forum, but also consider, maybe OS reinstalls and manual cleaning.

Software Extensions from third parties, and indeed other background tasks or online systems may cause problems as mentioned in posts above.

The problem is a Firefox problem if Firefox is running slowly! but it is not always a direct Firefox fault that is the root cause. I did give some tips in a post above that may be helpful.

Paul Hubert 0 solutions 17 answers

2012-04-22 16:50 hrs PDT

I'm running FF 11.0.1 under 64 bit Ubuntu 11.04. Just TODAY, Firefox began going to 100%+ of CPU (dual core, Dell Optiplex 360) even with NO TABS OPEN.

I did a complete removal and reinstall, to no avail.

Naturally, I shut the box down as well.

Now, how does an application in LINUX act like I have a virus?????

Right now I'm on Chromium - not much choice at the moment! (and I HATE the dad blasted thing).

Modified by Paul Hubert

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Create a new profile as a test to check if your current profile is causing the problems.

See "Basic Troubleshooting: Make a new profile":

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If that new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

See:

Paul Hubert 0 solutions 17 answers

Thanks, cor-el. I guess I'll have to try that.

When I _upgraded_ from Ubuntu 10.04 to 10.10 some things were hosed (Update Manager, Software Center installs, and a bit more - have to use Synaptic) and the upgrade to 11.04 didn't improve anything.

I'm waiting until Mint 12 is considered ready for general use, then I'll buy the DVD and try going with a nice, fresh, install on my 2nd hard drive.

FF had been degrading over time. Chrome, by comparison, is to me a bit clumsy. No nice tab function settings!!!!

Anyway, thanks again - just means hard (drudge, not difficult) work, of course, but at least you gave me some great references!!!

By the way, you don't happen to be an old WordPerfect user, do you?????? Once they were very good. Sad.

Modified by Paul Hubert