X
Tap here to go to the mobile version of the site.

Support Forum

Firefox browser constantly lagging and not responding

Posted

It does it on any site I visit. I have tried clearing my cashe and cookies. It has gotten to the point I can't do anything becasue it stops responding. This started when I had version 3.5 and has continued since I upgraded to the newst version. It is only Firefox and not my other browsers so I don't see how it is my computer. Anything I can do to make it stop and work properly?


The reason mine was doing it was becasue of the add-ons. I deleted them all and only reinstalled AdBlock Plus, no script, request policy, and the video downloader. I have not had a problem since. It was either Mr Tech Toolkit or the personas. :(

It does it on any site I visit. I have tried clearing my cashe and cookies. It has gotten to the point I can't do anything becasue it stops responding. This started when I had version 3.5 and has continued since I upgraded to the newst version. It is only Firefox and not my other browsers so I don't see how it is my computer. Anything I can do to make it stop and work properly? The reason mine was doing it was becasue of the add-ons. I deleted them all and only reinstalled AdBlock Plus, no script, request policy, and the video downloader. I have not had a problem since. It was either Mr Tech Toolkit or the personas. :(

Modified by ika_hinotama

Additional System Details

This happened

Every time Firefox opened

This started when...

A few weeks ago but has just gotten worse.

Installed Plug-ins

AdBlock Plus, Mr Tech toolkit, NoScript, Request policy, Download helper, personas

Application

  • User Agent:

More Information

It will not even respond long enough for me to try. :(

Durgan 0 solutions 4 answers

I finally installed Google Chrome. At least now I have a video player. Flash Player add on if enabled caused the problem even with the latest version installed. The problem is beyond Firefox and Adobe so time to move on. There solutions don't make sense and are the typical technical help tap dance.

Durgan

I finally installed Google Chrome. At least now I have a video player. Flash Player add on if enabled caused the problem even with the latest version installed. The problem is beyond Firefox and Adobe so time to move on. There solutions don't make sense and are the typical technical help tap dance. Durgan
LokiNya 0 solutions 3 answers

I had the same problem here, tried almost every solution I found on the net, tried old, new and beta versions of Firefox, but nothing helped. Firefox froze up so often that it was pretty much rendered useless. I also tried out Chrome, Opera and IE, but it's just not Firefox... I missed the bookmark sidebar and my addons.

Yesterday I installed Pale Moon 6.0.2, an optimized Firefox build. Imported my Firefox profile with all my bookmarks, add-ons and setting, and it runs even better then the official Firefox releases! No more hang-ups for me!

I had the same problem here, tried almost every solution I found on the net, tried old, new and beta versions of Firefox, but nothing helped. Firefox froze up so often that it was pretty much rendered useless. I also tried out Chrome, Opera and IE, but it's just not Firefox... I missed the bookmark sidebar and my addons. Yesterday I installed [http://www.palemoon.org/ Pale Moon] 6.0.2, an optimized Firefox build. Imported my Firefox profile with all my bookmarks, add-ons and setting, and it runs even better then the official Firefox releases! No more hang-ups for me!

Modified by LokiNya

saitohhajimi 0 solutions 1 answers

DAMNIT THIS IS SOO ANNOYING

I have all my bookmarks organized properly, so i always have firefox still installed, but this problem isnt being fixed at all.

DAMNIT THIS IS SOO ANNOYING I have all my bookmarks organized properly, so i always have firefox still installed, but this problem isnt being fixed at all.
Aart 0 solutions 1 answers

I, too, have this same issue... but only on one particular machine. I use four PC's/Laptops, all running Win7Pro. All machines use the same add-ons and FF is configured the same on all. Same programs, same AV (AVG 2012). Problem child is HP DV8000, Centrino dual-core, 2GB RAM. I have tried all the suggestions I have found so far; Safe Mode, New Profile, No Extensions, Re-installing FF, Diasableing AV and firewall, etc. Nothing affects FF from Not Responding. It happens very regularly. Around every 60 to 90 seconds FF stops responding for about 60 to 180 seconds, sometimes longer. Anybody have any other constructive suggestions? No other program stop responding. Just FF. Not even IE9 has any issues. Just installed FF 7, and it still does it.

I, too, have this same issue... but only on one particular machine. I use four PC's/Laptops, all running Win7Pro. All machines use the same add-ons and FF is configured the same on all. Same programs, same AV (AVG 2012). Problem child is HP DV8000, Centrino dual-core, 2GB RAM. I have tried all the suggestions I have found so far; Safe Mode, New Profile, No Extensions, Re-installing FF, Diasableing AV and firewall, etc. Nothing affects FF from Not Responding. It happens very regularly. Around every 60 to 90 seconds FF stops responding for about 60 to 180 seconds, sometimes longer. Anybody have any other constructive suggestions? No other program stop responding. Just FF. Not even IE9 has any issues. Just installed FF 7, and it still does it.

Modified by Aart

Cheng Wang 34 solutions 435 answers

There's a bug that is causing this behavior:

If you suddenly increase the number of history/bookmark items (either through sync or if you haven't restarted Firefox in a long time and browsed a whole lot from an empty profile) it may be poorly optimized for the database size.

http://blog.bonardo.net/2011/09/30/is-your-firefor-freezing-at-regular-intervals has a workaround although a fix is likely coming in Firefox 8 or 9.

There's a bug that is causing this behavior: If you suddenly increase the number of history/bookmark items (either through sync or if you haven't restarted Firefox in a long time and browsed a whole lot from an empty profile) it may be poorly optimized for the database size. http://blog.bonardo.net/2011/09/30/is-your-firefor-freezing-at-regular-intervals has a workaround although a fix is likely coming in Firefox 8 or 9.
finitarry 251 solutions 3421 answers

I just found out about one more trick you can try in about:config. Change the setting for the maximum number of network connections.

network.http.max-connections - try 48

The new default is 256, and perhaps that is too much.

I just found out about one more trick you can try in about:config. Change the setting for the maximum number of network connections. network.http.max-connections - try 48 The new default is 256, and perhaps that is too much.
Kerroj 0 solutions 1 answers

Firefox would hang sometimes when I didn't even touch the mouse, but most of the time I was clicking on something or scrolling when it decided to hang. When this happened, I would go to Task Manager (Ctrl/Alt/Delete) and I would always see 2 instances of Firefox with "Not Responding" for both. Hitting the "End Task" button for either one did nothing and did not work, the only thing I could do is restart my computer. After restart, everything was okay until it happens again, could be 4 hours later or 4 minutes later. This was such a pain in the butt that I wanted to switch to Chrome permanently but, although it is faster, I just didn't like it as much as Firefox. After reading what seemed like countless possible solutions on here and other websites, I tried disabling all of my Extensions, but that didn't work, so I turned them back on. Then I tried disabling all my Plug-ins except Shockwave Flash. THAT WORKED! I've been going 3 days now without 1 hang!!! Prior to this, it was hanging every day several times a day. I don't know which plug-in is causing the problem, but I haven't missed any of them yet!

Firefox would hang sometimes when I didn't even touch the mouse, but most of the time I was clicking on something or scrolling when it decided to hang. When this happened, I would go to Task Manager (Ctrl/Alt/Delete) and I would always see 2 instances of Firefox with "Not Responding" for both. Hitting the "End Task" button for either one did nothing and did not work, the only thing I could do is restart my computer. After restart, everything was okay until it happens again, could be 4 hours later or 4 minutes later. This was such a pain in the butt that I wanted to switch to Chrome permanently but, although it is faster, I just didn't like it as much as Firefox. After reading what seemed like countless possible solutions on here and other websites, I tried disabling all of my Extensions, but that didn't work, so I turned them back on. Then I tried disabling all my Plug-ins except Shockwave Flash. THAT WORKED! I've been going 3 days now without 1 hang!!! Prior to this, it was hanging every day several times a day. I don't know which plug-in is causing the problem, but I haven't missed any of them yet!
unclewilley 0 solutions 1 answers

Using IE Tab 2 add-on and switching rendering engine to IE WORKS, MUCH faster!!! but certainly not what I want to need to do all the time!!

Tried safe-mode w/o success.

'''Using IE Tab 2 add-on and switching rendering engine to IE WORKS, MUCH faster!!!''' but certainly not what I want to need to do all the time!! Tried safe-mode w/o success.
finitarry 251 solutions 3421 answers

If you are using IETab then you are using Internet Explorer rather than Firefox to make connections.

If you are using IETab then you are using Internet Explorer rather than Firefox to make connections.
RKFan26 0 solutions 2 answers

I am back... I changed my FireFox profile everything was good and now its lagging terrible again. Worse than before. I will lag/freeze up for a minute. So annoying.

I am back... I changed my FireFox profile everything was good and now its lagging terrible again. Worse than before. I will lag/freeze up for a minute. So annoying.
finitarry 251 solutions 3421 answers

Try changing the number of maximum connections.

network.http.max-connections - try 48

Try changing the number of maximum connections. network.http.max-connections - try 48
bcpetey 0 solutions 2 answers

I have a Dell Studio with Winddows 7 and after playing with turning off/on f-secure anti virus, wifi vs lan, and generally ripping my hair out, I think the problem has to do with hyper-threading. I followed the simple steps re turning on the compatibility mode (chose Vista) and now FF flies like before.

From thread mentioned above: "I have found a easier way to disable hyperthreading is to right click the Firefox icon click>properties>compatibility>put check mark in compatibility mode box and run in xxxx mode.This will disable hyperthreading for Firefox on a windows system."

Like I said, I picked Vista mode and it works pretty fast now. See attached screenshot. Hope this helps.

PS Btw I didn't see a difference with changing network connections in about:config as described above in earlier posts. After making the compatibility Vista, I changed the # n/w connections from 48 back to default 256 and it still runs fast.

I have a Dell Studio with Winddows 7 and after playing with turning off/on f-secure anti virus, wifi vs lan, and generally ripping my hair out, I think the problem has to do with hyper-threading. I followed the simple steps re turning on the compatibility mode (chose Vista) and now FF flies like before. From thread mentioned above: "I have found a easier way to disable hyperthreading is to right click the Firefox icon click>properties>compatibility>put check mark in compatibility mode box and run in xxxx mode.This will disable hyperthreading for Firefox on a windows system." Like I said, I picked Vista mode and it works pretty fast now. See attached screenshot. Hope this helps. PS Btw I didn't see a difference with changing network connections in about:config as described above in earlier posts. After making the compatibility Vista, I changed the # n/w connections from 48 back to default 256 and it still runs fast.

Modified by bcpetey

Red114 0 solutions 1 answers

I have been having similar issues for quite some time, and have grown increasingly frustrated to the point where I just about ended my relationship with Firefox in favor of Chrome. I have tried every suggestion mentioned in this thread as well as a number of other methods recommended from other sources, all to no avail.

However, a few days ago I came across this information that I had previously missed in my quest to fix this annoying problem. It may be basic information that I was just unaware of, and perhaps many of you have already tried it. But it was new to me, and after trying it, my browser has been back to normal with no hang time for three or four days now.

I hope this helps.

I have been having similar issues for quite some time, and have grown increasingly frustrated to the point where I just about ended my relationship with Firefox in favor of Chrome. I have tried every suggestion mentioned in this thread as well as a number of other methods recommended from other sources, all to no avail. However, a few days ago I came across [https://support.mozilla.com/en-US/kb/Firefox%20hangs?s=hang&r=0&as=s#w_periodic-hangs this information] that I had previously missed in my quest to fix this annoying problem. It may be basic information that I was just unaware of, and perhaps many of you have already tried it. But it was new to me, and after trying it, my browser has been back to normal with no hang time for three or four days now. I hope this helps.
John99 971 solutions 13138 answers

Just as a summary

Just as a summary * [[firefox hangs]] this is the standard troubleshooting and explanation article for this problem * [[firefox never finishes loading certain websites]] ** it has been updated recently to mention about the possible advantage of changing the preference [[firefox never finishes loading certain websites#w_lower-the-max-number-of-http-connections|Lower-the-max-number-of-http-connections]] (<- edited link) * [[http://blog.bonardo.net/2011/09/30/is-your-firefor-freezing-at-regular-intervals]] is about what is mainly hopefully a temporary problem, it may well have already been fixed in Firefox 8 * <u> Number of Connections & Router reset ? </u><br/> Some of the developers are looking at the suggestion that the Router may sometimes cause the problems when high connection numbers are used see [/forums/contributors/707680?last=43042#post-43041] If you see this sort of problem consider posting in the contributors forum, or even the bug.

Modified by John99

mark.au 0 solutions 1 answers

For me it turned out to be the skype addon, the one which highlights the numbers, works like a bought one now...cheers

For me it turned out to be the skype addon, the one which highlights the numbers, works like a bought one now...cheers
aardvark2zz 0 solutions 7 answers

For slow and memory consuming FF. It's a well known bug, but is not yet fixed. It's related to zombie compartments where, when tabs are closed or URL changes, FF does not release the memory.

The way to reduce the problem is to disable some addons; like those that play with web page properties. Most notably: Firebug, AdBlockPlus, ImageZoom, and more to be possibly discovered.

The only fix right-now is to disable some specific addons, or restart FF when memory used exceeds 700 MB approx.

(I use FF 7.0.1)

For slow and memory consuming FF. It's a well known bug, but is not yet fixed. It's related to zombie compartments where, when tabs are closed or URL changes, FF does not release the memory. The way '''to reduce the problem is to disable some addons; like''' those that play with web page properties. Most notably: Firebug, AdBlockPlus, ImageZoom, and more to be possibly discovered. The only '''fix right-now is to disable some specific addons, or restart FF''' when memory used exceeds 700 MB approx. (I use FF 7.0.1)
vfiduccia 0 solutions 1 answers

Right now I continue to get a crash report everytime I start foxfire. Using IE right now to see if anyone else is experiencing this.

Thanks.

Just got fosfire back.. Don't know why everyone is saying to switch to IE. it is so slow, I could paint the house during the time it takes to regenerate. I have all MS software, and if I could avoid using them I would. Their product design stinks, and I am being very generous by saying that.

Right now I continue to get a crash report everytime I start foxfire. Using IE right now to see if anyone else is experiencing this. Thanks. Just got fosfire back.. Don't know why everyone is saying to switch to IE. it is so slow, I could paint the house during the time it takes to regenerate. I have all MS software, and if I could avoid using them I would. Their product design stinks, and I am being very generous by saying that.

Modified by vfiduccia

John99 971 solutions 13138 answers

aardvark2zz,
Some plugins do tend to cause problems, and firebug, which is a plugin you mention, is probably intended as a diagnostic tool rather than being expected to be kept open all the time in normal browsing.
The zombie compartments: where in some circumstances certain web sites do not release memory; is also an issue, and I believe developers would like to know the details of any such problems that are seen (especially from someone who is willing to detail which site, and the about:memory results they get whilst using such a site)

vfiduccia
May I suggest

Please read Firefox crashes - Troubleshoot, prevent and get help fixing crashes and start your own thread. It will help if you are able to obtain the crash ID s as explained in the above linked article.

<u>aardvark2zz</u>,<br/> Some plugins do tend to cause problems, and firebug, which is a plugin you mention, is probably intended as a diagnostic tool rather than being expected to be kept open all the time in normal browsing. <br> The zombie compartments: where in some circumstances certain web sites do not release memory; is also an issue, and I believe developers would like to know the details of any such problems that are seen (especially from someone who is willing to detail which site, and the ''about:memory'' results they get whilst using such a site) <u>vfiduccia</u> <br> May I suggest Please read [[firefox crashes]] and start your own thread. It will help if you are able to obtain the crash ID s as explained in the above linked article.
Carm 6 solutions 179 answers

I does some extensive testing and concluded for the people that are having freezes with flash content that it is NOT an adobe flash issue, it is an issue with the process: plugin-container.exe

How do i know this:

I completely uninstalled all flash components via add/remove, then i also went and deleted ALL folders and files associated with flash/shockwave.

I then installed Firefox 4.01 and then went to the adobe Flash site and got the latest version of Flash. Guess what... Crash/hang free for days. Went back to 7.01 and tried to use the 4.01 plugin-container.exe and FAIL lol...

I am about ready to give up with Firefox completely in favor of Chrome cuz it works. I will wait til full version of 8 to come out and if the issue is not fixed, i am going to use chrome for browsing permanently. Firefox continues to loose browser stats over Chrome monthly, being in denial over this and their " rapid updates " or whatever they call them has led to rapid blunders

I does some extensive testing and concluded for the people that are having freezes with flash content that it is NOT an adobe flash issue, it is an issue with the process: plugin-container.exe How do i know this: I completely uninstalled all flash components via add/remove, then i also went and deleted ALL folders and files associated with flash/shockwave. I then installed Firefox 4.01 and then went to the adobe Flash site and got the latest version of Flash. Guess what... Crash/hang free for days. Went back to 7.01 and tried to use the 4.01 plugin-container.exe and FAIL lol... I am about ready to give up with Firefox completely in favor of Chrome cuz it works. I will wait til full version of 8 to come out and if the issue is not fixed, i am going to use chrome for browsing permanently. Firefox continues to loose browser stats over Chrome monthly, being in denial over this and their " rapid updates " or whatever they call them has led to rapid blunders
John99 971 solutions 13138 answers

This thread may well contain comments on more than one problem. It is not however normally a good idea to use Firefox 4, as I explained elsethread you will put your system and personal data at risk.

This thread may well contain comments on more than one problem. It is not however normally a good idea to use Firefox 4, as I [/questions/888865#answer-264487 explained elsethread] you will put your system and personal data at risk.