Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox 108.0.1 Win10 no option to request desktop site.

  • 5 replies
  • 1 has this problem
  • 47 views
  • Last reply by cor-el

more options

AndyMark.com is displaying as a mobile site and unusable. No option in Firefox to request desktop site. Running Windows 10. Instructions online say to go to Firefox menu and select desktop site but that option is no longer available. I realize that Windows is a phone operating system but my phone is Android and my laptops are Windows and I use Windows no my computer. Firefox is unusable if we can not set it to always use desktop views.

Please put the option back. Thank you.

AndyMark.com is displaying as a mobile site and unusable. No option in Firefox to request desktop site. Running Windows 10. Instructions online say to go to Firefox menu and select desktop site but that option is no longer available. I realize that Windows is a phone operating system but my phone is Android and my laptops are Windows and I use Windows no my computer. Firefox is unusable if we can not set it to always use desktop views. Please put the option back. Thank you.

All Replies (5)

more options

A screenshot showing the issue would be nice. I'm not able to replicate the issue. see screenshot

more options

Here is a screen shot of AndyMark.com in Mobile View on Win 10 with FireFox 108.0.1 and FF's Menu with no option to request or set Desktop View.

All this image does is shows one that I am telling the truth. But okay. Here it is. Will have to use Chrome now.

P.S. On PopOS with FF it worked yesterday. ie on PopOS AndyMark's site does not see Windows and assume I'm on my phone. I've never owned a Windows phone and would not know where to obtain one. I assume we do not need an image of it working correctly.

Its probably Windows incorrectly configured somewhere or changed to send out that I'm on a Mobile Laptop.

more options

Check to see what this option is set to. see screenshot

Modified by jonzn4SUSE

more options

Under View / Page Style / Basic Page Style was already selected. No style does not work either. Both Views give the same Mobile page.

more options

This usually means that CSS files are blocked.

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window