Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can no longer ope Outlook in Firefox after 10 years of being okay

  • 1 reply
  • 1 has this problem
  • 9 views
  • Last reply by cor-el

more options

I can no longer open Outlook (Office 365) in Firefox. I reset to original factory setting and was able to open it once but now I keep getting the same error message attached. I get through the login and then it starts "glitching" in the bottom left of the screen while trying to connect.

I can no longer open Outlook (Office 365) in Firefox. I reset to original factory setting and was able to open it once but now I keep getting the same error message attached. I get through the login and then it starts "glitching" in the bottom left of the screen while trying to connect.
Attached screenshots

All Replies (1)

more options

What security software do you have?

It is possible that (anti-virus) security software is causing the problem. Try to disable security software temporarily to see if that makes a difference.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window