Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google's two step sign in allows you to 'trust' a device to bypass the second step. I can't get it to work with Firefox

  • 5 replies
  • 1 has this problem
  • 18 views
  • Last reply by DickyOZ

more options

When I sign in to my Google account on my PC it sends a link to my phone for me to click "Yes it's me" to authenticate the sign in. The Google sign-in screen on my PC (Firefox browser) has a checkbox to 'trust' this device. Even though I select that option it still insists on sending the phone link to click on. How do I get Firefox/Google to remember the 'trust' checkbox state?

PS. I don't like cookies or browsing history to be saved, but do allow certain exceptions.

DickyOZ.

Chosen solution

Detail like websites remembering you is stored in a cookie, so make sure you aren't clearing important cookies.

You can use these steps to make a website recognize and remember you.

  • create a cookie allow exception with the proper protocol (https:// or http://) to make a website remember you

You can check that you aren't clearing important cookies.

  • using "Delete cookies and site data when Firefox is closed" keeps cookies with an allow exception
  • using "Clear history when Firefox closes" to clear cookies clears all cookies including cookies with an allow exception you may want to keep
  • clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exceptions for passwords and other website specific data
  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Exceptions"
Read this answer in context 👍 0

All Replies (5)

more options

Just test it and do not delete your cookies and see if it works the way you want. For websites that have the option to remember the device works via cookies.

https://policies.google.com/technologies/cookies?hl=en-US

Modified by jonzn4SUSE

Helpful?

more options

Chosen Solution

Detail like websites remembering you is stored in a cookie, so make sure you aren't clearing important cookies.

You can use these steps to make a website recognize and remember you.

  • create a cookie allow exception with the proper protocol (https:// or http://) to make a website remember you

You can check that you aren't clearing important cookies.

  • using "Delete cookies and site data when Firefox is closed" keeps cookies with an allow exception
  • using "Clear history when Firefox closes" to clear cookies clears all cookies including cookies with an allow exception you may want to keep
  • clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exceptions for passwords and other website specific data
  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Exceptions"

Helpful?

more options

Many thanks for the prompt replies. Attached screenshot shows my current cookies exceptions, but they don't seem to be working.

How do I display what cookies are being used when I have Firefox browser open?

Helpful?

more options

Create the allow exception for the google.com.au top level domain to include sub domains.

You can possibly create one for the international google.com domain.

Modified by cor-el

Helpful?

more options

Many thanks to cor-el.

I never realised that "Clear history when Firefox closes" also cleared allowed exceptions. All is now well.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.