Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"allow cookies to be stored on this device" warning, but cookies are enabled

more options

Hi there, I have a strange behavior in firefox: when navigating to Yeastar support website (https://support.yeastar.com/hc/en-us) and trying to sign in, i receive the following message: "To continue signing in using Firefox, allow cookies to be stored on this device. You might see this screen more than once. " If I put my username and passwords, I am unable to press the "Sign in" button. If I do the same from an incognito session, the message doesn't appear and I am able to log in through the "Sign in" button (see attached screenshot).

I tried to read many articles about allowing cookies from the firefox documentation but none has solved my problem. I'm running Firefox version 91.0 from a VDI (Citrix Desktop) and I have no admin privileges. Is there anything I can set in order to resolve this problem?

Attached screenshots

All Replies (8)

more options

https://support.mozilla.org/en-US/kb/websites-say-cookies-are-blocked-unblock-them


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem,

Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

While you are in Troubleshoot(Safe) mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Helpful?

more options

Hi FredMcD, thank you for the kind reply. The first link (delete cookies/cache) I had already read and didn't solve the problem. Restarting Firefox in safe mode temporarily solved the problem, as I was able to enter the username/password in the corresponding fileds. The hardware acceleration is already disabled and I cannot switch it on since the field is grayed (see attached screenshot). Is there anything else should I try?

Helpful?

more options

Helpful?

more options

Hello Fred, as I said in my previous answer, restarting firefox in safe mode has temporarily solved the problem, but once restarted in normal mode, the problem arose again.

Helpful?

more options

If clearing cookies didn't help then it is possible that the cookies.sqlite file that stores the cookies got corrupted.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookies files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted.

https://support.mozilla.org/kb/Deleting+cookies


Type about:support<enter> in the address bar.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the above file. Then rename or delete it. Restart Firefox.

Helpful?

more options

Hi fred, thank you for your kind reply. I followed your instructions and located only one cookies.sqlite file (see attachment). I closed firefox, deleted the file and reopened firefox, but unfortunately this didn't solve my problem :(

Helpful?

more options

This is characteristic of support sites that embed a frame from Zendesk. The permissions you give to the main site do not transfer to the framed page. You can give express cookie permission to the Zendesk site as described in this thread: Cookies required to use Firefox.

Also, if you want Firefox to save your login for this framed page, I suggest using this method:

right-click in the login form > This Frame > Open Frame in New Tab

Then sign in and Firefox should be able to properly associate the login with the framed site.

Helpful?

more options

Ok, it seems we're getting closer to the solution. If I right click on the frame and open in a new tab I realized that the login form is on yeastar.zendesk.com as opposite of the main page which is support.yeastar.com. Opening the login form in another tab works and I can fill in my authentication data. What I'm missing is how could I set cookie permission to the zendesk site. I put an exception in firefox settings for both the domains but that annoying popup keeps showing out....

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.