Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

I have encountered the problem. Flash player doesn't work on firefox.

  • 8 replies
  • 2 have this problem
  • 67 views
  • Last reply by FredMcD

more options

Firstly I thought that the web might have some inconsistencies but then another site also couldn't work. For example before I could pay from my VISA using form on website but now the form doesn't work. Or when I try to watch video at movies' site the flash player doesn't work. But when I open Microsoft Edge all the websites work. What's wrong with my firefox 75 at win 10 pro x64?

Chosen solution

The guilty is Urban Free VPN proxy unblocker

Read this answer in context 👍 1

All Replies (8)

more options

The flash plugin is about to be sunset by adobe and all browser vendors within the next months - not allowing it to run by default anymore is one of the steps in the transition away from it.

Also, see;
https://support.mozilla.org/en-US/forums/support-forum-contributors/713656 Filed a Bug Report - Users complaining of removing Always Allow for flash player

Helpful?

more options

What is the interim decision?

Helpful?

more options

Ieahsan said

What is the interim decision?

Enable the Flash Player manually each time it wants to run / that you want to use Flash.
https://support.mozilla.org/en-US/kb/why-do-i-have-click-activate-plugins

Helpful?

more options

Hi Ieahsan, are these new problems for you in Firefox 75, but Firefox 74 was working normally?

I think the payment form issue probably is separate from the Flash issue, so let me comment on that.

If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally:

Double-check content blockers: Firefox's Content Blocking/Tracking Protection feature, and extensions that counter ads and tracking, may break websites that embed third party content (meaning, from a secondary server).

(A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: Enhanced Tracking Protection in Firefox for desktop (before Firefox 70: Content blocking).

(B) Extensions such as Adblock Plus, Blur, Disconnect, DuckDuckGo Privacy Essentials, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Helpful?

more options

Yep, Firefox 74 was working normally. And, Firefox 75 is working normally in safe mode. Of course, I cleared Firefox cache some days ago with null result. I am not using Adblock, Blur and so on. But McAfee including WebAdvisor. So, after all, I have to use 75th version in safe mode till next update, don't I?

Helpful?

more options

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.


It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Helpful?

more options

Chosen Solution

The guilty is Urban Free VPN proxy unblocker

Helpful?

more options

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution.

Thank you for contacting Mozilla Support.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.