X
Tap here to go to the mobile version of the site.

Support Forum

Videos won't play in Facebook

Posted

I recently upgraded my Windows 7 laptop to Windows 10. Now in Facebook, videos won't play. I am using the latest Firefox and Flash player. The picture for the video shows up, but when I press play, it turns to a blur and won't play. I restarted Firefox in safe mode and the videos play normally, so it is an add-on causing the issue. I have disable each add-on, but can't seem to find the culprit. Maybe iI am not fully disabling them?

This raises another question...do I still need Flash Player at all? Do browsers now have other ways to play the videos?

Thanks in advance

I recently upgraded my Windows 7 laptop to Windows 10. Now in Facebook, videos won't play. I am using the latest Firefox and Flash player. The picture for the video shows up, but when I press play, it turns to a blur and won't play. I restarted Firefox in safe mode and the videos play normally, so it is an add-on causing the issue. I have disable each add-on, but can't seem to find the culprit. Maybe iI am not fully disabling them? This raises another question...do I still need Flash Player at all? Do browsers now have other ways to play the videos? Thanks in advance

Chosen solution

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting for changes to take effect.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.


If it works in Safe Mode and in normal mode with all extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via one of these:

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit
Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:71.0) Gecko/20100101 Firefox/71.0

More Information

Question owner

I just uninstalled Flash and tried to use Firefox without it with no luck...also cleared the cache and facebook cookie...no luck. Also reinstalled Flash with no luck. Also uninstalled and reinstalled Firefox with no luck.

I just uninstalled Flash and tried to use Firefox without it with no luck...also cleared the cache and facebook cookie...no luck. Also reinstalled Flash with no luck. Also uninstalled and reinstalled Firefox with no luck.

Modified by sdodell

Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17759 solutions 160605 answers

Chosen Solution

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting for changes to take effect.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.


If it works in Safe Mode and in normal mode with all extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via one of these:

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit
You can try to disable hardware acceleration in Firefox. *Options/Preferences -> General: Performance<br>remove checkmark: [ ] "Use recommended performance settings"<br>remove checkmark: [ ] "Use hardware acceleration when available" *https://support.mozilla.org/en-US/kb/performance-settings Close and restart Firefox after modifying the setting for changes to take effect. *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems You can check if there is an update for your graphics display driver and check for hardware acceleration related issues. *https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration ---- If it works in Safe Mode and in normal mode with all extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears. Close and restart Firefox after each change via one of these: *"3-bar" menu button -> Exit (Power button) *Windows: File -> Exit *Mac: Firefox -> Quit Firefox *Linux: File -> Quit
Was this helpful to you? 1
Quote

Question owner

Thanks Cor-el...this has virtually solved the issue! Only one video out of about 30 didn't play after I changed the setting.

Thanks Cor-el...this has virtually solved the issue! Only one video out of about 30 didn't play after I changed the setting.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.