X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

facebook videos not playing in firefox. IE plays them fine, also no problem with youtube videos in firefox.

Posted

Facebook videos are not playing in firefox, it plays youtube videos fine. The fb videos start to load and after that just a black screen remains.

No such issues in IE, I've no addons installed, flash player is latest, and tried by enabling/disabling the block popups option.

Thanks in advance.

Chosen solution

go to Help Menu -> select "Restart with Add-ons Disabled"

Firefox will close then it will open up with just basic Firefox. You can enable the Add-ons later. Check and tell if its working.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.2 r153
  • Google Talk Plugin Video Accelerator version:0.1.44.5
  • Version 2.1.6.0
  • Google Update
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • 4.0.51204.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0

More Information

dynamite 60 solutions 382 answers

Check if clearing the Cache helps:

  1. Go to Tools menu > Options > Advanced > Network.
  2. Under the Offline Storage section, click on the Clear Now button.

Otherwise, see the possible solutions in this article: Fix common audio and video issues.

Hasan 477 solutions 5600 answers

Crashes on sites with Windows Media Player video or audio

https://support.mozilla.com/en-US/kb/Firefox%20crashes%20when%20loading%20certain%20pages#w_crashes-on-sites-with-windows-media-player-video-or-audio

Modified by Hasan

Question owner

Thanks @dynamite and @mha007, but the problem still remains.

There were no conflicting plugins, vlc or any dlls.

Hasan 477 solutions 5600 answers

Chosen Solution

go to Help Menu -> select "Restart with Add-ons Disabled"

Firefox will close then it will open up with just basic Firefox. You can enable the Add-ons later. Check and tell if its working.

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

You can try to disable the hardware acceleration in the Flash Player. See Flash video won't play full screen on YouTube, Facebook and other websites

Flash "Display settings" window:


Your above posted system details show outdated plugin(s) with known security and stability risks that you should update.

Update the Flash plugin to the latest version.

Question owner

Thanks @mha007, yes it worked for me.