X
Tap here to go to the mobile version of the site.

Support Forum

Firefox cannot open "mailto:" or other URIs in firefox. Other browsers work fine.

Posted

When I try to open a URI in firefox, nothing happens. For URIs in the application list (General-Applications) nothing happens. For new URIs, there is no popup asking me if I want to open it. I am able to open these links in any other browser.

When I try to open a URI in firefox, nothing happens. For URIs in the application list (General-Applications) nothing happens. For new URIs, there is no popup asking me if I want to open it. I am able to open these links in any other browser.
Quote

Additional System Details

Installed Plug-ins

OpenH264 Video Codec provided by Cisco Systems, Inc. Shockwave Flash Widevine Content Decryption Module provided by Google Inc.

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/77.0.3865.90 Safari/537.36

More Information

WMagicModel
  • Top 25 Contributor
  • Administrator
14 solutions 204 answers

Hi derektietze91,

I dug up another thread which may relate to your issue with mailto : I cannot open mailto links in external websites. {link}

Hi derektietze91, I dug up another thread which may relate to your issue with mailto : [https://support.mozilla.org/en-US/questions/1007048 I cannot open mailto links in external websites.] {link}
Was this helpful to you? 1
Quote

Question owner

Thanks for digging that up. I was hopeful, but mimeTypes.rdf does not appear in my profile folder. This is a fresh install of Firefox, if that matters.

Thanks for digging that up. I was hopeful, but mimeTypes.rdf does not appear in my profile folder. This is a fresh install of Firefox, if that matters.
Was this helpful to you?
Quote
WMagicModel
  • Top 25 Contributor
  • Administrator
14 solutions 204 answers

Helpful Reply

Have you tried starting Firefox in Safe Mode?

In case you already installed add-ons, this will disable them to eliminate the possibility of interfering with your web browser.

To start in Safe Mode:

  1. Click the '3-bar' menu icon in your web browser
  2. Click Help(?)
  3. Click Restart with Add-ons Disabled...
  4. Click Restart and when prompted choose Restart in Safe Mode ( Refresh will create a New Profile while saving your old profile to your desktop while removing features so read carefully)

You could also try creating a New Profile

The following steps were taken from the above link under Creating a profile :

  1. Type about:profiles into the address bar and press the Enter key.
  2. Click Create Profile... to start the Create Profile Wizard.
  3. Click Next and enter the name of the profile.
  4. Disregard the Choose Folder prompt unless you wish to choose where to store the profile on your computer.
  5. To create the new profile, click Finish.

You could also check out extensions available for in Firefox Add-ons website ( i used mailto as a search )

See also MailTo : One click to open your mail client with the current tab's URL in a new message

Have you tried starting Firefox in [[Troubleshoot Firefox issues using Safe Mode|Safe Mode]]? In case you already installed add-ons, this will disable them to eliminate the possibility of interfering with your web browser. To start in Safe Mode: # Click the '3-bar'''' menu''' icon in your web browser # Click''' Help(?)''' # Click '''Restart with Add-ons Disabled...''' # Click '''Restart''' and when prompted choose '''Restart in Safe Mode''' ( [[Refresh Firefox - reset add-ons and settings|Refresh]] will create a New Profile while saving your old profile to your desktop while removing features so read carefully) You could also try creating a [[Profile Manager - Create, remove, or switch Firefox profiles|New Profile]] The following steps were taken from the above link under '''Creating a profile''' : # Type''' about:profiles''' into the address bar and press the Enter key. # Click '''Create Profile... '''to start the Create Profile Wizard. # Click''' Next '''and enter the name of the profile. # Disregard the Choose Folder prompt unless you wish to choose where to store the profile on your computer. # To create the new profile, click '''Finish'''. You could also check out extensions available for in [https://addons.mozilla.org/en-US/firefox/search/?q=mailto&platform=WINNT&appver=71.0a1 Firefox Add-ons ] website ( i used ''mailto'' as a search ) See also [https://addons.mozilla.org/en-US/firefox/addon/mailto-we/?src=search MailTo ]: One click to open your mail client with the current tab's URL in a new message
Was this helpful to you? 2
Quote

Question owner

Thanks for the advice. I tried starting in safe mode and the behavior of firefox persisted. I tried creating a new profile as well and it still did so. I also tried reinstalling firefox to no avail.

Thanks for the advice. I tried starting in safe mode and the behavior of firefox persisted. I tried creating a new profile as well and it still did so. I also tried reinstalling firefox to no avail.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158887 answers

Helpful Reply

mimeTypes.rdf has been replaced by handlers.json, so you can check this file and possibly rename to handlersOLD.json to see if that has effect.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

mimeTypes.rdf has been replaced by handlers.json, so you can check this file and possibly rename to handlersOLD.json to see if that has effect. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *https://support.mozilla.org/en-US/kb/Profiles
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158887 answers
See also: *https://support.mozilla.org/en-US/kb/change-program-used-open-email-links
Was this helpful to you? 0
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.