X
Tap here to go to the mobile version of the site.

Support Forum

I cannot open mailto links in external websites.

Posted

when I click on an email link in some websites, it says there is no application to open the mailto link. I went through the help menus, where I am asked to find the mailto feature and add an application. There is no mailto feature listed, so I can't link an application. It seems my firefox has no knowledge of mailto. I don't get a yahoo pop-up as others do. What do I do? I have Firefox 20.0.1and gmail and windows 7.

when I click on an email link in some websites, it says there is no application to open the mailto link. I went through the help menus, where I am asked to find the mailto feature and add an application. There is no mailto feature listed, so I can't link an application. It seems my firefox has no knowledge of mailto. I don't get a yahoo pop-up as others do. What do I do? I have Firefox 20.0.1and gmail and windows 7.

Chosen solution

So in the Options dialog, Applications panel, mailto doesn't appear or doesn't have any choices? This could indicate that the settings file which stores download actions is corrupted. Since its format is somewhat inscrutable, the standard medicine in this situation is to rename it so Firefox can't find it, and then a new one will be generated automatically.

Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • Help menu > Troubleshooting Information

In the first table on the page, click the "Show Folder" button

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • File menu > Exit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old

Start Firefox back up again. Does mailto appear in Options?

The next time you go to Yahoo it should trigger Firefox to display an infobar between the bottom of the toolbar area and the top of its page to add the latest version of its mailto handler.

Any luck?

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 13.0 r0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.07
  • NPWLPG
  • 5.1.30214.0
  • GEPlugin
  • iTunes Detector Plug-in
  • IBM 821 Conference Plugin for Mozilla version 8.2.10.911
  • Intel web components updater - Installs and updates the Intel web components
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 29.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
  • Support URL: https://support.mozilla.org/1/firefox/29.0.1/WINNT/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4600
  • adapterDescription2: NVIDIA GeForce GTX 765M
  • adapterDeviceID: 0x0416
  • adapterDeviceID2: 0x11e2
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterRAM: Unknown
  • adapterRAM2: 2048
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 10-31-2013
  • driverDate2: 11-11-2013
  • driverVersion: 10.18.10.3345
  • driverVersion2: 9.18.13.3182
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4600 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 6
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140506152807
  • browser.startup.homepage_override.buildID: 20140506152807
  • browser.startup.homepage_override.mstone: 29.0.1
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 29.0.1
  • gfx.direct3d.last_used_feature_level_idx: 0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1403142868
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1401663674

Misc

  • User JS: No
  • Accessibility: No
christ1
  • Top 25 Contributor
1894 solutions 13724 answers

In Windows you'll need to designate an application as your default email application, e.g. like Thunderbird.

In Windows you'll need to designate an application as your default email application, e.g. like Thunderbird.

Question owner

I did that I think. Windows says that firefox enabled, and that the "current email program" is the default. I cannot find a way to directly specify gmail.

When I click on a website "choose an application for the mailto application", it sends me to my document file. I searched for gmail.exe on the entire hard drive. Nothing.

I did that I think. Windows says that firefox enabled, and that the "current email program" is the default. I cannot find a way to directly specify gmail. When I click on a website "choose an application for the mailto application", it sends me to my document file. I searched for gmail.exe on the entire hard drive. Nothing.
christ1
  • Top 25 Contributor
1894 solutions 13724 answers
Google is your friend. http://blog.hubspot.com/marketing/set-gmail-as-browser-default-email-client-ht

Question owner

This should work, but in the last step where I click for a drop down menu of possible applications, there is nothing there. No option of any kind, much less use gmail.

This should work, but in the last step where I click for a drop down menu of possible applications, there is nothing there. No option of any kind, much less use gmail.
cor-el
  • Top 25 Contributor
  • Moderator
16161 solutions 145855 answers

Helpful Reply

See:


You can check the network.protocol-handler.external.mailto prefs on the about:config page.

If network.protocol-handler.external.mailto prefs are user set (bold) then right-click and Reset them to the default value. You can also try to change the network.protocol-handler.warn-external.mailto pref to true.

See: *https://support.mozilla.org/kb/Changing+the+e-mail+program+used+by+Firefox ---- You can check the network.protocol-handler.external.mailto prefs on the about:config page. *http://kb.mozillazine.org/about:config If network.protocol-handler.external.mailto prefs are user set (bold) then right-click and Reset them to the default value. You can also try to change the network.protocol-handler.warn-external.mailto pref to true.
jscher2000
  • Top 10 Contributor
7254 solutions 59020 answers

Chosen Solution

So in the Options dialog, Applications panel, mailto doesn't appear or doesn't have any choices? This could indicate that the settings file which stores download actions is corrupted. Since its format is somewhat inscrutable, the standard medicine in this situation is to rename it so Firefox can't find it, and then a new one will be generated automatically.

Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • Help menu > Troubleshooting Information

In the first table on the page, click the "Show Folder" button

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • File menu > Exit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old

Start Firefox back up again. Does mailto appear in Options?

The next time you go to Yahoo it should trigger Firefox to display an infobar between the bottom of the toolbar area and the top of its page to add the latest version of its mailto handler.

Any luck?

So in the Options dialog, Applications panel, mailto doesn't appear or doesn't have any choices? This could indicate that the settings file which stores download actions is corrupted. Since its format is somewhat inscrutable, the standard medicine in this situation is to rename it so Firefox can't find it, and then a new one will be generated automatically. Here's how: Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" button > Troubleshooting Information * Help menu > Troubleshooting Information In the first table on the page, click the "Show Folder" button Leaving that window open, switch back to Firefox and Exit, either: * "3-bar" menu button > "power" button * File menu > Exit Pause while Firefox finishes its cleanup, then rename '''mimeTypes.rdf''' to something like mimeTypes.old Start Firefox back up again. Does mailto appear in Options? The next time you go to Yahoo it ''should'' trigger Firefox to display an infobar between the bottom of the toolbar area and the top of its page to add the latest version of its mailto handler. Any luck?
jscher2000
  • Top 10 Contributor
7254 solutions 59020 answers

My bad, you want Gmail, not Yahoo. That handler is built-in and should appear on the drop-down if the mimeTypes.rdf file regenerates cleanly.

My bad, you want Gmail, not Yahoo. That handler is built-in and should appear on the drop-down if the mimeTypes.rdf file regenerates cleanly.

Question owner

Bingo!!!

Your directions were very clear and worked perfectly.

Thank you. And I did select gmail in the now available drop down box.

northsea

Bingo!!! Your directions were very clear and worked perfectly. Thank you. And I did select gmail in the now available drop down box. northsea