Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I have an issue with online banking logon, the firefox window simply never completes. I've tried most of the help solutions. Help welcome.

  • 11 replies
  • 1 has this problem
  • 40 views
  • Last reply by FredMcD

more options

I'm using Windows 7 and have recently encountered this problem (I say recently - last month to 6 wks). I can enter my login details, but when entering memorable data it's as if Firefox just freezes - the window looks like it's trying to move on, but never does. If I then try to access different sites, I end up with the same problem there too! I have to end the firefox process in order to use other sites again. Oddly enough, I don't have this problem on IE 11.

Chosen solution

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Read this answer in context 👍 0

All Replies (11)

more options

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

First of all, thanks for taking the time to reply and offer advice.

I had previously tried the cookie removal and cleared the cache, which hadn't worked.

So, I've restarted in Safe Mode, as you suggested, but this didn't help. I also then tried disabling the hardward acceleration, but this also didn't help.

The problem still exists. :(

I should add that when having to end the firefox.exe process there are sometimes 2 or 3 of them active.

Oddly enough, I just check the processes running now (as I'm typing) and there are 6 firefox.exe processes running - is this normal?

Modified by James11

more options

More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/

Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess


https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history

Remove History For One Site

Open the History Manager <Control><Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any settings.

more options

Hi and thanks again for replying.

I went through and removed the site from the history manager, as instructed, but still have the same problem.

more options

Chosen Solution

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

Ok, thanks for your patience.

I tried running windows in Safe Mode, but I then had no internet connection - so that didn't really work.

I also tried running a brand new Firefox profile, but still no joy. The problem still occured in the new profile.

more options

cor-el said

Windows Safe mode with network support
more options

Hi, hmmm, maybe I didn't choose that option. My apologies.

However, the issue has been resolved. I uninstalled another software program, which I suspected might be causing the problem, and it was. The problem disappeared.

Sorry for taking up your time, but thanks for the support. :)

more options

We are glad to help. For others with similar issues, what program did you remove?

more options

Solved problem

It was a program called Covenant Eyes. I'm in contact with them about getting to the bottom of the issue.

Thanks again.

Modified by James11

more options

That was very good work. Well done. Please flag your last post as Solved Problem as this could help others with the same problem.