X
Tap here to go to the mobile version of the site.

Support Forum

After upgrade to Firefox 66.0.2 <Enter> is disabled from address bar

Posted

Suddenly, following the latest upgrade, I can no longer hit <Enter> after typing a url into the address bar. Nothing happens. I have to click the green arrow at the far right of the address bar to make it load the page. This is a real nuisance. What happened to simply hitting <Enter>? Firefox 66.0.2 Windows 7

Suddenly, following the latest upgrade, I can no longer hit <Enter> after typing a url into the address bar. Nothing happens. I have to click the green arrow at the far right of the address bar to make it load the page. This is a real nuisance. What happened to simply hitting <Enter>? Firefox 66.0.2 Windows 7

Chosen solution

Well, I decided to wait them out. After the upgrade to 68.0, the issue was resolved, along with some other minor things as well. Although... for some reason, they changed my theme back to the default theme. And then proceeded to recommend "themes" to me! I don't consider a "refresh" a reasonable response, that's like "why don't you 'just' re-install Windows?" After all the tweaks to get this usable, I'm supposed to start over? I have better things to do. Otherwise, thanks for the trys, guys!

Read this answer in context 0
Quote
Wesley Branton
  • Top 10 Contributor
573 solutions 4884 answers

Helpful Reply

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

'''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem.
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17346 solutions 156790 answers

A possible cause that all suggestions for the location/address bar are disabled, so if you have done this then try to enable at least one suggestion like open tabs.

The location bar drop-down list can show history items, bookmarked pages, pages opened in tabs, and search suggestions. You can set what suggestions show when you enter an URL in the location/address bar bar.

  • Options/Preferences -> Privacy & Security
    Address Bar: When using the location bar, suggest:
    History
    Bookmarks
    Open tabs
A possible cause that all suggestions for the location/address bar are disabled, so if you have done this then try to enable at least one suggestion like open tabs. The location bar drop-down list can show history items, bookmarked pages, pages opened in tabs, and search suggestions. You can set what suggestions show when you enter an URL in the location/address bar bar. *Options/Preferences -> Privacy & Security<br>Address Bar: When using the location bar, suggest:<br>History<br>Bookmarks<br>Open tabs
Was this helpful to you? 0
Quote

Question owner

Starting in Safe Mode stops the problem; however, I have tried everything in the Troubleshooting page and have not been able to find what is causing it. Another interesting note: in normal (unsafe?) mode, none of the extensions or plug-ins show in the add-ons page. They all show up in safe mode.

Also, the blue bar that drops down when you begin to type in the address bar, is there any way to get rid of that? All "suggestions" are off. Do all these "aids" to help us really help anyone? My computer never knows what I want to do. "Please, Mother, I'd rather do it myself!"

Starting in Safe Mode stops the problem; however, I have tried everything in the Troubleshooting page and have not been able to find what is causing it. Another interesting note: in normal (unsafe?) mode, none of the extensions or plug-ins show in the add-ons page. They all show up in safe mode. Also, the blue bar that drops down when you begin to type in the address bar, is there any way to get rid of that? All "suggestions" are off. Do all these "aids" to help us really help anyone? My computer never knows what I want to do. "Please, Mother, I'd rather do it myself!"
Was this helpful to you?
Quote

Question owner

Also weird, if I type in the address, then click in the window, then click back in the address bar, then hit <Enter>, it works.

Also weird, if I type in the address, then click in the window, then click back in the address bar, then hit <Enter>, it works.
Was this helpful to you?
Quote
philipp
  • Top 25 Contributor
  • Moderator
5282 solutions 23334 answers

i'd try to perform a refresh of firefox in this situation: Refresh Firefox - reset add-ons and settings

i'd try to perform a refresh of firefox in this situation: [[Refresh Firefox - reset add-ons and settings]]
Was this helpful to you? 0
Quote
Wesley Branton
  • Top 10 Contributor
573 solutions 4884 answers

I received the following email from another user who was not able to reply to the thread, but was having similar issues. I am posting their response here, as it may be beneficial to the topic:

"I’m using the Classic CSS tweaks for Firefox Quantum. After a recent Firefox upgrade, enter key stopped working and address bar was no longer appearing above the tabs.

An internet search provided me with a solution to the address bar location, but not the enter key issue. Various search results hinted at an issue with userChrome.css. After a visual scan of this file, decided to comment out the following line:

@import url(./css/locationbar/ac_popup_classic_with_two_lines.css);

from this section:
/************************************************************************************************/
/* LOCATION BAR - 'autocomplete popup' appearance ***********************************************/
/************************************************************************************************/ 
/* NOTE: 'Classic popup with two lined resuls' will stop working soon, because Mozilla is going to drop XBL support: see https://bugzilla.mozilla.org/show_bug.cgi?id=1397874 **********/

in my userChrome.css …

Perhaps this same line (or file import) is responsible for the problems experienced by some of the others in [this thread]."

Hopefully this provides some assistance in this thread.

I received the following email from another user who was not able to reply to the thread, but was having similar issues. I am posting their response here, as it may be beneficial to the topic: <blockquote>"I’m using the [https://github.com/aris-t2/customcssforfx/releases Classic CSS tweaks for Firefox Quantum]. After a recent Firefox upgrade, enter key stopped working and address bar was no longer appearing above the tabs.<br><br> An internet search provided me with a solution to the address bar location, but not the enter key issue. Various search results hinted at an issue with userChrome.css. After a visual scan of this file, decided to comment out the following line:<br><br> <code>@import url(./css/locationbar/ac_popup_classic_with_two_lines.css);</code><br><br> from this section:<br> <pre>/************************************************************************************************/ /* LOCATION BAR - 'autocomplete popup' appearance ***********************************************/ /************************************************************************************************/ /* NOTE: 'Classic popup with two lined resuls' will stop working soon, because Mozilla is going to drop XBL support: see https://bugzilla.mozilla.org/show_bug.cgi?id=1397874 **********/</pre> in my userChrome.css … Perhaps this same line (or file import) is responsible for the problems experienced by some of the others in [this thread]."</blockquote> Hopefully this provides some assistance in this thread.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8580 solutions 70167 answers

Wesley Branton said

I received the following email from another user who was not able to reply to the thread, but was having similar issues. I am posting their response here, as it may be beneficial to the topic:
"I’m using the Classic CSS tweaks for Firefox Quantum. After a recent Firefox upgrade, enter key stopped working and address bar was no longer appearing above the tabs.

And to connect some more dots: Firefox's Safe Mode disables any userChrome.css and userContent.css files you might have set up.

''Wesley Branton [[#answer-1211235|said]]'' <blockquote> I received the following email from another user who was not able to reply to the thread, but was having similar issues. I am posting their response here, as it may be beneficial to the topic: <blockquote>"I’m using the [https://github.com/aris-t2/customcssforfx/releases Classic CSS tweaks for Firefox Quantum]. After a recent Firefox upgrade, enter key stopped working and address bar was no longer appearing above the tabs.</blockquote> </blockquote> And to connect some more dots: Firefox's Safe Mode disables any userChrome.css and userContent.css files you might have set up.
Was this helpful to you?
Quote

Chosen Solution

Well, I decided to wait them out. After the upgrade to 68.0, the issue was resolved, along with some other minor things as well. Although... for some reason, they changed my theme back to the default theme. And then proceeded to recommend "themes" to me! I don't consider a "refresh" a reasonable response, that's like "why don't you 'just' re-install Windows?" After all the tweaks to get this usable, I'm supposed to start over? I have better things to do. Otherwise, thanks for the trys, guys!

Well, I decided to wait them out. After the upgrade to 68.0, the issue was resolved, along with some other minor things as well. Although... for some reason, they changed my theme back to the default theme. And then proceeded to recommend "themes" to me! I don't consider a "refresh" a reasonable response, that's like "why don't you 'just' re-install Windows?" After all the tweaks to get this usable, I'm supposed to start over? I have better things to do. Otherwise, thanks for the trys, guys!
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.